net/keepalived: update to version 2.0.7
Update keepalived to version 2.0.7. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
This commit is contained in:
parent
3fc7f7b8cc
commit
4868b6f7a8
2 changed files with 30 additions and 3 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=keepalived
|
PKG_NAME:=keepalived
|
||||||
PKG_VERSION:=1.4.4
|
PKG_VERSION:=2.0.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.keepalived.org/software
|
PKG_SOURCE_URL:=http://www.keepalived.org/software
|
||||||
PKG_HASH:=147c2b3b782223128551fd0a1564eaa30ed84a94b68c50ec5087747941314704
|
PKG_HASH:=bce45d6d5cf3620bfd88472ec839a75b5a14a54fda12d09e890670244873b8ab
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0+
|
PKG_LICENSE:=GPL-2.0+
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
@ -36,7 +36,9 @@ define Package/keepalived
|
||||||
+libip4tc \
|
+libip4tc \
|
||||||
+IPV6:libip6tc \
|
+IPV6:libip6tc \
|
||||||
+libxtables \
|
+libxtables \
|
||||||
+kmod-macvlan
|
+kmod-macvlan \
|
||||||
|
+libmagic \
|
||||||
|
+libnl-route
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/keepalived/description
|
define Package/keepalived/description
|
||||||
|
|
|
@ -0,0 +1,25 @@
|
||||||
|
From 6c7a281473083f7ac47b426b2127a8c8e76caca5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Quentin Armitage <quentin@armitage.org.uk>
|
||||||
|
Date: Sat, 25 Aug 2018 11:36:11 +0100
|
||||||
|
Subject: [PATCH] Include stdbool.h in process.c
|
||||||
|
|
||||||
|
Signed-off-by: Quentin Armitage <quentin@armitage.org.uk>
|
||||||
|
---
|
||||||
|
keepalived/core/process.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/keepalived/core/process.c b/keepalived/core/process.c
|
||||||
|
index f11c32a3..22bcf254 100644
|
||||||
|
--- a/keepalived/core/process.c
|
||||||
|
+++ b/keepalived/core/process.c
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
#ifdef _HAVE_SCHED_RT_
|
||||||
|
#include <sched.h>
|
||||||
|
#endif
|
||||||
|
+#include <stdbool.h>
|
||||||
|
|
||||||
|
#include "process.h"
|
||||||
|
#include "logger.h"
|
||||||
|
--
|
||||||
|
2.11.0
|
||||||
|
|
Loading…
Reference in a new issue