Merge pull request #10066 from BKPepe/sysrepo
sysrepo: Use correct SPDX License Identifier
This commit is contained in:
commit
481f66e043
6 changed files with 26 additions and 39 deletions
|
@ -7,17 +7,18 @@
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_LICENSE:=ASL-2.0
|
|
||||||
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
|
||||||
|
|
||||||
PKG_NAME:=sysrepo
|
PKG_NAME:=sysrepo
|
||||||
PKG_VERSION:=0.7.7
|
PKG_VERSION:=0.7.7
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=5
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/sysrepo/sysrepo/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/sysrepo/sysrepo/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=2bf8cb4d810d19231eba1e549f58f3a0ce068d170a5e7b212b927396098560e4
|
PKG_HASH:=2bf8cb4d810d19231eba1e549f58f3a0ce068d170a5e7b212b927396098560e4
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
||||||
|
PKG_LICENSE:=Apache-2.0
|
||||||
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
CMAKE_INSTALL:=1
|
CMAKE_INSTALL:=1
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
@ -38,8 +39,8 @@ PKG_BUILD_DEPENDS:=SYSREPO_BINDINGS:swig/host
|
||||||
define Package/libsysrepo
|
define Package/libsysrepo
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
URL:=$(PKG_SOURCE_URL)
|
|
||||||
TITLE:=YANG-based data store library
|
TITLE:=YANG-based data store library
|
||||||
|
URL:=https://www.sysrepo.org/
|
||||||
DEPENDS:=+libyang +libprotobuf-c +libev +libredblack +librt +libpthread +SYSREPO_BINDINGS:libstdcpp +SYSREPO_PYTHON:python-base +SYSREPO_LUA:lua
|
DEPENDS:=+libyang +libprotobuf-c +libev +libredblack +librt +libpthread +SYSREPO_BINDINGS:libstdcpp +SYSREPO_PYTHON:python-base +SYSREPO_LUA:lua
|
||||||
MENU:=1
|
MENU:=1
|
||||||
endef
|
endef
|
||||||
|
@ -47,24 +48,24 @@ endef
|
||||||
define Package/sysrepo
|
define Package/sysrepo
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
URL:=$(PKG_SOURCE_URL)
|
|
||||||
TITLE:=YANG-based data store daemon and plugin
|
TITLE:=YANG-based data store daemon and plugin
|
||||||
|
URL:=https://www.sysrepo.org/
|
||||||
DEPENDS:=+libsysrepo
|
DEPENDS:=+libsysrepo
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/sysrepoctl
|
define Package/sysrepoctl
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
URL:=$(PKG_SOURCE_URL)
|
|
||||||
TITLE:=sysrepo cli tool
|
TITLE:=sysrepo cli tool
|
||||||
|
URL:=https://www.sysrepo.org/
|
||||||
DEPENDS:=+libsysrepo
|
DEPENDS:=+libsysrepo
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/sysrepocfg
|
define Package/sysrepocfg
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
URL:=$(PKG_SOURCE_URL)
|
|
||||||
TITLE:=sysrepo configuration tool
|
TITLE:=sysrepo configuration tool
|
||||||
|
URL:=https://www.sysrepo.org/
|
||||||
DEPENDS:=+libsysrepo
|
DEPENDS:=+libsysrepo
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,5 @@
|
||||||
Index: sysrepo-0.7.5/src/common/sysrepo.pb-c.c
|
|
||||||
===================================================================
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ sysrepo-0.7.5/src/common/sysrepo.pb-c.c
|
+++ b/src/common/sysrepo.pb-c.c
|
||||||
@@ -0,0 +1,10537 @@
|
@@ -0,0 +1,10537 @@
|
||||||
+/* Generated by the protocol buffer compiler. DO NOT EDIT! */
|
+/* Generated by the protocol buffer compiler. DO NOT EDIT! */
|
||||||
+/* Generated from: sysrepo.proto */
|
+/* Generated from: sysrepo.proto */
|
||||||
|
@ -10540,10 +10538,8 @@ Index: sysrepo-0.7.5/src/common/sysrepo.pb-c.c
|
||||||
+ sr__operation__value_ranges,
|
+ sr__operation__value_ranges,
|
||||||
+ NULL,NULL,NULL,NULL /* reserved[1234] */
|
+ NULL,NULL,NULL,NULL /* reserved[1234] */
|
||||||
+};
|
+};
|
||||||
Index: sysrepo-0.7.5/src/common/sysrepo.pb-c.h
|
|
||||||
===================================================================
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ sysrepo-0.7.5/src/common/sysrepo.pb-c.h
|
+++ b/src/common/sysrepo.pb-c.h
|
||||||
@@ -0,0 +1,4238 @@
|
@@ -0,0 +1,4238 @@
|
||||||
+/* Generated by the protocol buffer compiler. DO NOT EDIT! */
|
+/* Generated by the protocol buffer compiler. DO NOT EDIT! */
|
||||||
+/* Generated from: sysrepo.proto */
|
+/* Generated from: sysrepo.proto */
|
||||||
|
|
|
@ -1,8 +1,6 @@
|
||||||
Index: sysrepo-0.7.5/CMakeLists.txt
|
--- a/CMakeLists.txt
|
||||||
===================================================================
|
+++ b/CMakeLists.txt
|
||||||
--- sysrepo-0.7.5.orig/CMakeLists.txt
|
@@ -310,7 +310,7 @@ install (FILES ${INTERNAL_YANGS} DESTINA
|
||||||
+++ sysrepo-0.7.5/CMakeLists.txt
|
|
||||||
@@ -303,7 +303,7 @@ install (FILES ${INTERNAL_YANGS} DESTINA
|
|
||||||
|
|
||||||
# install NACM YANG module
|
# install NACM YANG module
|
||||||
if(ENABLE_NACM)
|
if(ENABLE_NACM)
|
||||||
|
@ -11,7 +9,7 @@ Index: sysrepo-0.7.5/CMakeLists.txt
|
||||||
endif(ENABLE_NACM)
|
endif(ENABLE_NACM)
|
||||||
|
|
||||||
find_package(PkgConfig QUIET)
|
find_package(PkgConfig QUIET)
|
||||||
@@ -327,9 +327,9 @@ if(WITH_SYSTEMD)
|
@@ -334,9 +334,9 @@ if(WITH_SYSTEMD)
|
||||||
FILES_MATCHING PATTERN "*.service")
|
FILES_MATCHING PATTERN "*.service")
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
|
@ -22,5 +20,5 @@ Index: sysrepo-0.7.5/CMakeLists.txt
|
||||||
+#INSTALL_YANG("nc-notifications" "" "666")
|
+#INSTALL_YANG("nc-notifications" "" "666")
|
||||||
+#INSTALL_YANG("notifications" "" "666")
|
+#INSTALL_YANG("notifications" "" "666")
|
||||||
|
|
||||||
if(GEN_LANGUAGE_BINDINGS)
|
# uninstall
|
||||||
add_subdirectory(swig)
|
add_custom_target(uninstall "${CMAKE_COMMAND}" -P "${CMAKE_MODULE_PATH}/uninstall.cmake")
|
||||||
|
|
|
@ -1,7 +1,5 @@
|
||||||
Index: sysrepo-0.7.5/src/clientlib/client_library.c
|
--- a/src/clientlib/client_library.c
|
||||||
===================================================================
|
+++ b/src/clientlib/client_library.c
|
||||||
--- sysrepo-0.7.5.orig/src/clientlib/client_library.c
|
|
||||||
+++ sysrepo-0.7.5/src/clientlib/client_library.c
|
|
||||||
@@ -396,13 +396,13 @@ sr_connect(const char *app_name, const s
|
@@ -396,13 +396,13 @@ sr_connect(const char *app_name, const s
|
||||||
if (opts & SR_CONN_DAEMON_REQUIRED) {
|
if (opts & SR_CONN_DAEMON_REQUIRED) {
|
||||||
if ((opts & SR_CONN_DAEMON_START) && (0 == getuid())) {
|
if ((opts & SR_CONN_DAEMON_START) && (0 == getuid())) {
|
||||||
|
|
|
@ -1,8 +1,6 @@
|
||||||
Index: sysrepo-0.7.0-7aa2f18d234267403147df92c0005c871f0aa840/src/common/sr_utils.c
|
--- a/src/common/sr_utils.c
|
||||||
===================================================================
|
+++ b/src/common/sr_utils.c
|
||||||
--- sysrepo-0.7.0-7aa2f18d234267403147df92c0005c871f0aa840.orig/src/common/sr_utils.c
|
@@ -477,14 +477,24 @@ sr_fd_set_nonblock(int fd)
|
||||||
+++ sysrepo-0.7.0-7aa2f18d234267403147df92c0005c871f0aa840/src/common/sr_utils.c
|
|
||||||
@@ -460,14 +460,24 @@ sr_fd_set_nonblock(int fd)
|
|
||||||
|
|
||||||
#if defined(SO_PEERCRED)
|
#if defined(SO_PEERCRED)
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,5 @@
|
||||||
Index: sysrepo-0.7.7/src/common/sysrepo.pb-c.c
|
--- a/src/common/sysrepo.pb-c.c
|
||||||
===================================================================
|
+++ b/src/common/sysrepo.pb-c.c
|
||||||
--- sysrepo-0.7.7.orig/src/common/sysrepo.pb-c.c
|
|
||||||
+++ sysrepo-0.7.7/src/common/sysrepo.pb-c.c
|
|
||||||
@@ -8013,7 +8013,7 @@ const ProtobufCMessageDescriptor sr__eve
|
@@ -8013,7 +8013,7 @@ const ProtobufCMessageDescriptor sr__eve
|
||||||
(ProtobufCMessageInit) sr__event_notif_replay_resp__init,
|
(ProtobufCMessageInit) sr__event_notif_replay_resp__init,
|
||||||
NULL,NULL,NULL /* reserved[123] */
|
NULL,NULL,NULL /* reserved[123] */
|
||||||
|
@ -51,10 +49,8 @@ Index: sysrepo-0.7.7/src/common/sysrepo.pb-c.c
|
||||||
sr__data_provide_req__field_descriptors,
|
sr__data_provide_req__field_descriptors,
|
||||||
sr__data_provide_req__field_indices_by_name,
|
sr__data_provide_req__field_indices_by_name,
|
||||||
3, sr__data_provide_req__number_ranges,
|
3, sr__data_provide_req__number_ranges,
|
||||||
Index: sysrepo-0.7.7/src/common/sysrepo.pb-c.h
|
--- a/src/common/sysrepo.pb-c.h
|
||||||
===================================================================
|
+++ b/src/common/sysrepo.pb-c.h
|
||||||
--- sysrepo-0.7.7.orig/src/common/sysrepo.pb-c.h
|
|
||||||
+++ sysrepo-0.7.7/src/common/sysrepo.pb-c.h
|
|
||||||
@@ -1630,10 +1630,11 @@ struct _Sr__DataProvideReq
|
@@ -1630,10 +1630,11 @@ struct _Sr__DataProvideReq
|
||||||
char *subscriber_address;
|
char *subscriber_address;
|
||||||
uint32_t subscription_id;
|
uint32_t subscription_id;
|
||||||
|
|
Loading…
Reference in a new issue