alsa-lib: update to 1.2.5
Refresh patches. Remove upstream one. Switch to AUTORELEASE for simplicity. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
e2d9e874dc
commit
47b48b2088
4 changed files with 8 additions and 35 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=alsa-lib
|
||||
PKG_VERSION:=1.2.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=1.2.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
|
||||
http://distfiles.gentoo.org/distfiles/
|
||||
PKG_HASH:=f7554be1a56cdff468b58fc1c29b95b64864c590038dd309c7a978c7116908f7
|
||||
PKG_HASH:=9092894a8c083b33acf8d6deb901b58f5d20d6da583789f814e8e46f2850ef18
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
|
||||
Peter Wagner <tripolar@gmx.at>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -490,7 +490,7 @@ clean-libLTLIBRARIES:
|
||||
@@ -491,7 +491,7 @@ clean-libLTLIBRARIES:
|
||||
}
|
||||
|
||||
libasound.la: $(libasound_la_OBJECTS) $(libasound_la_DEPENDENCIES) $(EXTRA_libasound_la_DEPENDENCIES)
|
||||
|
@ -11,7 +11,7 @@
|
|||
-rm -f *.$(OBJEXT)
|
||||
--- a/src/pcm/scopes/Makefile.in
|
||||
+++ b/src/pcm/scopes/Makefile.in
|
||||
@@ -410,7 +410,7 @@ clean-pkglibLTLIBRARIES:
|
||||
@@ -411,7 +411,7 @@ clean-pkglibLTLIBRARIES:
|
||||
}
|
||||
|
||||
scope-level.la: $(scope_level_la_OBJECTS) $(scope_level_la_DEPENDENCIES) $(EXTRA_scope_level_la_DEPENDENCIES)
|
||||
|
|
|
@ -17,9 +17,9 @@
|
|||
const char *_snd_module_pcm_shm = "";
|
||||
--- a/src/ucm/ucm_local.h
|
||||
+++ b/src/ucm/ucm_local.h
|
||||
@@ -53,6 +53,14 @@
|
||||
#define SEQUENCE_ELEMENT_TYPE_CSET_TLV 6
|
||||
#define SEQUENCE_ELEMENT_TYPE_CMPT_SEQ 7
|
||||
@@ -58,6 +58,14 @@
|
||||
#define SEQUENCE_ELEMENT_TYPE_SYSSET 11
|
||||
#define SEQUENCE_ELEMENT_TYPE_CFGSAVE 12
|
||||
|
||||
+#if _POSIX_C_SOURCE >= 200809L
|
||||
+#define usleep(a) \
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From ad8c8e5503980295dd8e5e54a6285d2d7e32eb1e Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Kysela <perex@perex.cz>
|
||||
Date: Thu, 22 Oct 2020 20:57:32 +0200
|
||||
Subject: [PATCH] dlmisc: the snd_plugin_dir_set / snd_plugin_dir must be
|
||||
declared even for \!DL_ORIGIN_AVAILABLE
|
||||
|
||||
Fixes: 8580c081c2 ("dlsym: add support for ALSA_PLUGIN_DIR environment variable")
|
||||
BugLink: https://github.com/alsa-project/alsa-lib/issues/91
|
||||
Signed-off-by: Jaroslav Kysela <perex@perex.cz>
|
||||
---
|
||||
src/dlmisc.c | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
--- a/src/dlmisc.c
|
||||
+++ b/src/dlmisc.c
|
||||
@@ -42,11 +42,9 @@
|
||||
#ifndef PIC
|
||||
struct snd_dlsym_link *snd_dlsym_start = NULL;
|
||||
#endif
|
||||
-#ifdef DL_ORIGIN_AVAILABLE
|
||||
static int snd_plugin_dir_set = 0;
|
||||
static char *snd_plugin_dir = NULL;
|
||||
#endif
|
||||
-#endif
|
||||
|
||||
#if defined(DL_ORIGIN_AVAILABLE) && defined(HAVE_LIBPTHREAD)
|
||||
static pthread_mutex_t snd_dlpath_mutex = PTHREAD_MUTEX_INITIALIZER;
|
Loading…
Reference in a new issue