xmlrpc-c: Update to 1.51.03
Small Makefile reorganization. Switch BUILD_PARALLEL to 1. Seems to work now. Added nanosleep patch that replaces usleep usage. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
8fecab45bd
commit
473356a562
4 changed files with 24 additions and 30 deletions
|
@ -8,22 +8,20 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xmlrpc-c
|
||||
PKG_VERSION:=1.43.08
|
||||
PKG_VERSION:=1.51.03
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=@SF/xmlrpc-c/Xmlrpc-c%20Super%20Stable/$(PKG_VERSION)
|
||||
PKG_HASH:=c9f5b584a42493877ae0f09ed680d94e035ab389e8fa1873b1ec42118d5cfca3
|
||||
PKG_HASH:=82f9a4f6dee03f6a58921d75a65949dd4f0036a4c268bce6a4343338932ec065
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=VARIOUS
|
||||
PKG_LICENSE_FILES:=doc/COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=0
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/config.mk.in
|
||||
+++ b/config.mk.in
|
||||
@@ -176,7 +176,7 @@ ifeq ($(patsubst linux-gnu%,linux-gnu,$(
|
||||
shlibfn = $(1:%=%.$(SHLIB_SUFFIX).$(MAJ).$(MIN))
|
||||
shliblefn = $(1:%=%.$(SHLIB_SUFFIX))
|
||||
# SHLIB_CLIB = -lc
|
||||
- LDFLAGS_SHLIB = -shared -Wl,-soname,$(SONAME) $(SHLIB_CLIB)
|
||||
+ LDFLAGS_SHLIB = -shared -Wl,-soname,$(SONAME) $(SHLIB_CLIB) $(LDFLAGS)
|
||||
CFLAGS_SHLIB=-fPIC
|
||||
endif
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -223,9 +223,7 @@ dnl Checks for programs.
|
||||
dnl =======================================================================
|
||||
|
||||
AC_PROG_CC
|
||||
-if test x"$enable_cplusplus" != xno; then
|
||||
- AC_PROG_CXX
|
||||
-fi
|
||||
+AC_PROG_CXX
|
||||
|
||||
|
||||
dnl =======================================================================
|
20
libs/xmlrpc-c/patches/010-nanosleep.patch
Normal file
20
libs/xmlrpc-c/patches/010-nanosleep.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- a/lib/libutil/sleep.c
|
||||
+++ b/lib/libutil/sleep.c
|
||||
@@ -8,7 +8,7 @@
|
||||
# include <windows.h>
|
||||
# include <process.h>
|
||||
#else
|
||||
-# include <unistd.h>
|
||||
+# include <time.h>
|
||||
#endif
|
||||
|
||||
|
||||
@@ -18,6 +18,7 @@ xmlrpc_millisecond_sleep(unsigned int const milliseconds) {
|
||||
#if MSVCRT
|
||||
SleepEx(milliseconds, true);
|
||||
#else
|
||||
- usleep(milliseconds * 1000);
|
||||
+ const struct timespec req = {0, milliseconds * 1000 * 1000};
|
||||
+ nanosleep(&req, NULL);
|
||||
#endif
|
||||
}
|
Loading…
Reference in a new issue