nfs-utils: Fix compilation on some platforms
Added a patch sent upstream. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
2c28e01f59
commit
46fc281e9e
2 changed files with 30 additions and 1 deletions
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=nfs-kernel-server
|
||||
PKG_VERSION:=2.3.3
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
PKG_HASH:=3c8c63611c7e78b7a3b2f8a28b9928a5b5e66d5e9ad09a1e54681508884320a4
|
||||
|
||||
PKG_SOURCE_URL:=@SF/nfs
|
||||
|
|
|
@ -0,0 +1,29 @@
|
|||
From: Rosen Penev <rosenp@gmail.com>
|
||||
To: linux-nfs@vger.kernel.org
|
||||
Subject: [PATCH] idmapd: Add missing libgen header
|
||||
Date: Sun, 14 Apr 2019 19:11:40 -0700
|
||||
Message-Id: <20190415021140.1388-1-rosenp@gmail.com>
|
||||
X-Mailer: git-send-email 2.17.1
|
||||
|
||||
Otherwise compilation can fail with an implicit declaration of basename.
|
||||
|
||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||
---
|
||||
utils/idmapd/idmapd.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/utils/idmapd/idmapd.c b/utils/idmapd/idmapd.c
|
||||
index 91c0253..62e37b8 100644
|
||||
--- a/utils/idmapd/idmapd.c
|
||||
+++ b/utils/idmapd/idmapd.c
|
||||
@@ -59,6 +59,7 @@
|
||||
#include <grp.h>
|
||||
#include <limits.h>
|
||||
#include <ctype.h>
|
||||
+#include <libgen.h>
|
||||
#include <nfsidmap.h>
|
||||
|
||||
#ifdef HAVE_CONFIG_H
|
||||
--
|
||||
2.17.1
|
||||
|
Loading…
Reference in a new issue