gitolite: Update to 3.6.8
Update to newest release. We also drop a now unnecesary patch. Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
This commit is contained in:
parent
f2c06977a9
commit
46d91345c2
2 changed files with 4 additions and 30 deletions
|
@ -8,14 +8,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gitolite
|
||||
PKG_VERSION:=3.6.6
|
||||
PKG_VERSION:=3.6.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=b2d96c36682391f45c63b21a91fbe77a969a7b362417c851dd0091a06fcc74d9
|
||||
PKG_MIRROR_HASH:=652d3b3f8ed93b8ef56153337465cc7260974e5cd2653e949da1bb97a8421ea0
|
||||
|
||||
PKG_SOURCE_URL:=https://github.com/sitaramc/gitolite.git
|
||||
PKG_SOURCE_VERSION:=908f8c6f3b8ef5b95829be7155be2557e71f4579
|
||||
PKG_SOURCE_VERSION:=e126e97a4d5575821f89ae80dac402b017db94aa
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
|
||||
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From d0409ae1164030913801d37ce5425ed93529c69d Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Dickinson <gitolite@daniel.thecshore.com>
|
||||
Date: Fri, 1 Jul 2016 00:37:23 -0400
|
||||
Subject: [PATCH] Conf::Store: Fix missing hooks dir for symlink
|
||||
|
||||
At least when doing 'gitolite setup -pk user.pub', the
|
||||
symlinking of hooks fails because the hooks directory
|
||||
does not exist. Make sure we create it if it's missing.
|
||||
---
|
||||
src/lib/Gitolite/Conf/Store.pm | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/lib/Gitolite/Conf/Store.pm b/src/lib/Gitolite/Conf/Store.pm
|
||||
index 5568b3f..aac90d4 100644
|
||||
--- a/src/lib/Gitolite/Conf/Store.pm
|
||||
+++ b/src/lib/Gitolite/Conf/Store.pm
|
||||
@@ -363,6 +363,7 @@ sub store_common {
|
||||
chmod 0755, "$rc{GL_ADMIN_BASE}/hooks/gitolite-admin/post-update";
|
||||
$hook_reset++;
|
||||
}
|
||||
+ _mkdir("$repo.git/hooks");
|
||||
|
||||
# propagate user-defined (custom) hooks to all repos
|
||||
ln_sf( "$rc{LOCAL_CODE}/hooks/common", "*", "$repo.git/hooks" ) if $rc{LOCAL_CODE};
|
||||
--
|
||||
2.7.4
|
||||
|
Loading…
Reference in a new issue