oor: Add OpenOverlayRouter (oor) package
lispmob: OOR is a rename of LISPmob and replace the package Signed-off-by: Albert Lopez <alopez@ac.upc.edu>
This commit is contained in:
parent
a20433e813
commit
46d6c1093a
3 changed files with 57 additions and 88 deletions
|
@ -1,57 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (C) 2012-2014 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=lispmob
|
|
||||||
PKG_REV:=180aa39d338a00bb532e421de7f8513492cf2e8b
|
|
||||||
PKG_VERSION:=0.4
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_MIRROR_HASH:=584300e1a59cc976f3599213487ea8425f94300887a51c9804f0292cf2f0c8cc
|
|
||||||
PKG_SOURCE_URL:=git://github.com/LISPmob/lispmob.git
|
|
||||||
PKG_SOURCE_PROTO:=git
|
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
|
||||||
|
|
||||||
PKG_LICENSE:=GPLv2
|
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/lispd/default
|
|
||||||
MAINTAINER:=Vasileios Lakafosis <lakafv@gmail.com>
|
|
||||||
URL:=http://lisp.cisco.com/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/lispd
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Network
|
|
||||||
TITLE:=Locator/ID separation protocol (using TUN)
|
|
||||||
URL:=https://github.com/LISPmob
|
|
||||||
DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci @IPV6
|
|
||||||
$(call Package/lispd/default)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/lispd/description
|
|
||||||
This packet provides support for the Locator-ID Separation Protocol.
|
|
||||||
endef
|
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
|
||||||
platform=openwrt
|
|
||||||
|
|
||||||
define Package/lispd/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lispd/lispd $(1)/usr/sbin/
|
|
||||||
$(INSTALL_DIR) $(1)/etc/config
|
|
||||||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/openWRT/lispd.uci.example $(1)/etc/config/lispd
|
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/openWRT/openwrt.init.script $(1)/etc/init.d/lisp
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,lispd))
|
|
|
@ -1,31 +0,0 @@
|
||||||
--- a/lispd/lispd_output.c
|
|
||||||
+++ b/lispd/lispd_output.c
|
|
||||||
@@ -26,6 +26,7 @@
|
|
||||||
* Alberto Rodriguez Natal <arnatal@ac.upc.edu>
|
|
||||||
*/
|
|
||||||
|
|
||||||
+#define _GNU_SOURCE 1
|
|
||||||
|
|
||||||
|
|
||||||
#include <assert.h>
|
|
||||||
--- a/lispd/lispd_input.c
|
|
||||||
+++ b/lispd/lispd_input.c
|
|
||||||
@@ -26,6 +26,7 @@
|
|
||||||
* Alberto Rodriguez Natal <arnatal@ac.upc.edu>
|
|
||||||
*/
|
|
||||||
|
|
||||||
+#define _GNU_SOURCE 1
|
|
||||||
|
|
||||||
#include "lispd_input.h"
|
|
||||||
#include "lispd_map_notify.h"
|
|
||||||
--- a/lispd/lispd_pkt_lib.c
|
|
||||||
+++ b/lispd/lispd_pkt_lib.c
|
|
||||||
@@ -28,6 +28,8 @@
|
|
||||||
*
|
|
||||||
*/
|
|
||||||
|
|
||||||
+#define _GNU_SOURCE 1
|
|
||||||
+
|
|
||||||
#include "lispd_afi.h"
|
|
||||||
#include "lispd_pkt_lib.h"
|
|
||||||
#include "lispd_lib.h"
|
|
57
net/oor/Makefile
Normal file
57
net/oor/Makefile
Normal file
|
@ -0,0 +1,57 @@
|
||||||
|
# Copyright (C) 2011, 2015 Cisco Systems, Inc.
|
||||||
|
# Copyright (C) 2015 CBA research group, Technical University of Catalonia.
|
||||||
|
#
|
||||||
|
# Licensed under the Apache License, Version 2.0 (the "License");
|
||||||
|
# you may not use this file except in compliance with the License.
|
||||||
|
# You may obtain a copy of the License at:
|
||||||
|
#
|
||||||
|
# http://www.apache.org/licenses/LICENSE-2.0
|
||||||
|
#
|
||||||
|
# Unless required by applicable law or agreed to in writing, software
|
||||||
|
# distributed under the License is distributed on an "AS IS" BASIS,
|
||||||
|
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
|
||||||
|
# See the License for the specific language governing permissions and
|
||||||
|
# limitations under the License.
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=oor
|
||||||
|
PKG_VERSION:=1.2.2
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
|
||||||
|
PKG_SOURCE_URL=https://github.com/OpenOverlayRouter/oor/releases/download/$(PKG_VERSION)/
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_MD5SUM:=6702348fa314c2691f28c7e71337bb84
|
||||||
|
|
||||||
|
PKG_LICENSE:=Apache-2.0
|
||||||
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
PKG_MAINTAINER:=Albert Lopez <alopez@ac.upc.edu>
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
|
|
||||||
|
MAKE_FLAGS += platform=openwrt
|
||||||
|
|
||||||
|
define Package/oor
|
||||||
|
SECTION:=net
|
||||||
|
CATEGORY:=Network
|
||||||
|
TITLE:=Open Overlay Router
|
||||||
|
URL:=https://github.com/OpenOverlayRouter
|
||||||
|
DEPENDS:= +librt +confuse +kmod-tun +uci @IPV6
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/oor/description
|
||||||
|
This packet provides support for the Locator-ID Separation Protocol, VXLAN-GPE.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/oor/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/oor/oor $(1)/usr/sbin/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/config
|
||||||
|
$(INSTALL_CONF) $(PKG_BUILD_DIR)/openWRT/oor.uci.example $(1)/etc/config/oor
|
||||||
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/openWRT/openwrt.init.script $(1)/etc/init.d/oor
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,oor))
|
Loading…
Reference in a new issue