Merge pull request #14920 from luizluca/21.02/sane-backends-1.0.32
[21.02] sane backends 1.0.32
This commit is contained in:
commit
46b84dc335
5 changed files with 6 additions and 121 deletions
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=v4l-utils
|
||||
PKG_VERSION:=1.20.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
|
||||
|
@ -78,7 +78,7 @@ endef
|
|||
TARGET_CFLAGS += -flto
|
||||
TARGET_CXXFLAGS += -std=c++11
|
||||
TARGET_LDFLAGS += \
|
||||
$(if $(CONFIG_LIBC_USE_GLIBC),,-largp) \
|
||||
$(if $(CONFIG_USE_GLIBC),,-largp) \
|
||||
-Wl,--gc-sections,--as-needed
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
|
|
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sane-backends
|
||||
PKG_VERSION:=1.0.31
|
||||
PKG_VERSION:=1.0.32
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/8bf1cae2e1803aefab9e5331550e5d5d/
|
||||
PKG_HASH:=4a3b10fcb398ed854777d979498645edfe66fcac2f2fd2b9117a79ff45e2a5aa
|
||||
PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/104f09c07d35519cc8e72e604f11643f
|
||||
PKG_HASH:=3a28c237c0a72767086202379f6dc92dbb63ec08dfbab22312cba80e238bb114
|
||||
|
||||
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -442,7 +442,7 @@ target_alias = @target_alias@
|
||||
@@ -451,7 +451,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
https://gitlab.com/sane-project/backends/issues/237
|
||||
|
||||
--- a/backend/genesys/image_pipeline.cpp
|
||||
+++ b/backend/genesys/image_pipeline.cpp
|
||||
@@ -754,7 +754,11 @@ bool ImagePipelineNodeCalibrate::get_nex
|
||||
|
||||
float value_f = static_cast<float>(value) / max_value;
|
||||
value_f = (value_f - offset_[curr_calib_i]) * multiplier_[curr_calib_i];
|
||||
+#if defined(__UCLIBC__)
|
||||
+ value_f = round(value_f * max_value);
|
||||
+#else
|
||||
value_f = std::round(value_f * max_value);
|
||||
+#endif
|
||||
value = clamp<std::int32_t>(static_cast<std::int32_t>(value_f), 0, max_value);
|
||||
set_raw_channel_to_row(out_data, x, ch, value, format);
|
||||
|
|
@ -1,99 +0,0 @@
|
|||
From a380fb089499f6b5192c07ae2feaa3376997382f Mon Sep 17 00:00:00 2001
|
||||
From: Olaf Meeuwissen <paddy-hack@member.fsf.org>
|
||||
Date: Sun, 13 Sep 2020 18:47:32 +0900
|
||||
Subject: [PATCH] pixma: Restore old behaviour in case XML support is missing
|
||||
|
||||
Fixes #345.
|
||||
---
|
||||
backend/pixma/pixma_common.c | 4 ++--
|
||||
backend/pixma/pixma_common.h | 2 ++
|
||||
backend/pixma/pixma_mp150.c | 8 ++++++++
|
||||
backend/pixma/pixma_mp800.c | 8 ++++++++
|
||||
4 files changed, 20 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/backend/pixma/pixma_common.c
|
||||
+++ b/backend/pixma/pixma_common.c
|
||||
@@ -56,8 +56,6 @@
|
||||
|
||||
#if defined(HAVE_LIBXML2)
|
||||
# include <libxml/parser.h>
|
||||
-#else
|
||||
-# error "The pixma backend requires libxml2"
|
||||
#endif
|
||||
|
||||
#include "pixma_rename.h"
|
||||
@@ -1241,6 +1239,7 @@ pixma_get_device_status (pixma_t * s, pi
|
||||
return s->ops->get_status (s, status);
|
||||
}
|
||||
|
||||
+#if defined(HAVE_LIBXML2)
|
||||
static const char *
|
||||
format_xml_response(const char *resp_details)
|
||||
{
|
||||
@@ -1334,3 +1333,4 @@ clean:
|
||||
xmlFreeDoc(doc);
|
||||
return status;
|
||||
}
|
||||
+#endif
|
||||
--- a/backend/pixma/pixma_common.h
|
||||
+++ b/backend/pixma/pixma_common.h
|
||||
@@ -205,7 +205,9 @@ uint8_t *pixma_newcmd (pixma_cmdbuf_t *,
|
||||
int pixma_exec (pixma_t *, pixma_cmdbuf_t *);
|
||||
int pixma_exec_short_cmd (pixma_t *, pixma_cmdbuf_t *, unsigned cmd);
|
||||
int pixma_map_status_errno (unsigned status);
|
||||
+#if defined(HAVE_LIBXML2)
|
||||
int pixma_parse_xml_response(const char *xml_message);
|
||||
+#endif
|
||||
/**@}*/
|
||||
|
||||
#define pixma_fill_checksum(start, end) do { \
|
||||
--- a/backend/pixma/pixma_mp150.c
|
||||
+++ b/backend/pixma/pixma_mp150.c
|
||||
@@ -322,6 +322,10 @@
|
||||
<ivec:param_set servicetype=\"scan\"><ivec:jobID>00000001</ivec:jobID>\
|
||||
</ivec:param_set></ivec:contents></cmd>"
|
||||
|
||||
+#if !defined(HAVE_LIBXML2)
|
||||
+#define XML_OK "<ivec:response>OK</ivec:response>"
|
||||
+#endif
|
||||
+
|
||||
enum mp150_state_t
|
||||
{
|
||||
state_idle,
|
||||
@@ -459,7 +463,11 @@ send_xml_dialog (pixma_t * s, const char
|
||||
PDBG (pixma_dbg (10, "XML message sent to scanner:\n%s\n", xml_message));
|
||||
PDBG (pixma_dbg (10, "XML response back from scanner:\n%s\n", mp->cb.buf));
|
||||
|
||||
+#if defined(HAVE_LIBXML2)
|
||||
return pixma_parse_xml_response((const char*)mp->cb.buf) == PIXMA_STATUS_OK;
|
||||
+#else
|
||||
+ return (strcasestr ((const char *) mp->cb.buf, XML_OK) != NULL);
|
||||
+#endif
|
||||
}
|
||||
|
||||
static int
|
||||
--- a/backend/pixma/pixma_mp800.c
|
||||
+++ b/backend/pixma/pixma_mp800.c
|
||||
@@ -152,6 +152,10 @@
|
||||
<ivec:param_set servicetype=\"scan\"><ivec:jobID>00000001</ivec:jobID>\
|
||||
</ivec:param_set></ivec:contents></cmd>"
|
||||
|
||||
+#if !defined(HAVE_LIBXML2)
|
||||
+#define XML_OK "<ivec:response>OK</ivec:response>"
|
||||
+#endif
|
||||
+
|
||||
enum mp810_state_t
|
||||
{
|
||||
state_idle,
|
||||
@@ -291,7 +295,11 @@ static int send_xml_dialog (pixma_t * s,
|
||||
PDBG(pixma_dbg (10, "XML message sent to scanner:\n%s\n", xml_message));
|
||||
PDBG(pixma_dbg (10, "XML response back from scanner:\n%s\n", mp->cb.buf));
|
||||
|
||||
+#if defined(HAVE_LIBXML2)
|
||||
return pixma_parse_xml_response((const char*)mp->cb.buf) == PIXMA_STATUS_OK;
|
||||
+#else
|
||||
+ return (strcasestr ((const char *) mp->cb.buf, XML_OK) != NULL);
|
||||
+#endif
|
||||
}
|
||||
|
||||
static void new_cmd_tpu_msg (pixma_t *s, pixma_cmdbuf_t * cb, uint16_t cmd)
|
Loading…
Reference in a new issue