open-vm-tools: update to 12.2.0
Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
This commit is contained in:
parent
e60f16499d
commit
464e4c5802
6 changed files with 19 additions and 18 deletions
|
@ -8,13 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=open-vm-tools
|
PKG_NAME:=open-vm-tools
|
||||||
PKG_VERSION:=12.1.5
|
PKG_VERSION:=12.2.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-20735119.tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-21223074.tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/vmware/open-vm-tools/releases/download/stable-$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/vmware/open-vm-tools/releases/download/stable-$(PKG_VERSION)
|
||||||
PKG_HASH:=72cb68c71c59fd429bcb357926f41f07e21c737a341534b707fc1df010ed4868
|
PKG_HASH:=ddc797cb75c435ad03c197ee0753156add148d06aefb14587dd31bff7556479a
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-20735119
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-21223074
|
||||||
|
|
||||||
PKG_LICENSE:=LGPL-2.1-or-later
|
PKG_LICENSE:=LGPL-2.1-or-later
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
@ -22,7 +22,7 @@ PKG_LICENSE_FILES:=LICENSE
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_BUILD_DEPENDS:=glib2/host
|
PKG_BUILD_DEPENDS:=glib2/host rpcsvc-proto/host
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/nls.mk
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
|
|
|
@ -13,7 +13,7 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
||||||
|
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -1451,7 +1451,17 @@ AC_C_VOLATILE
|
@@ -1461,7 +1461,17 @@ AC_C_VOLATILE
|
||||||
|
|
||||||
### General flags / actions
|
### General flags / actions
|
||||||
CFLAGS="$CFLAGS -Wall"
|
CFLAGS="$CFLAGS -Wall"
|
||||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
||||||
|
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -1441,6 +1441,7 @@ AC_TYPE_OFF_T
|
@@ -1451,6 +1451,7 @@ AC_TYPE_OFF_T
|
||||||
AC_TYPE_PID_T
|
AC_TYPE_PID_T
|
||||||
AC_TYPE_SIZE_T
|
AC_TYPE_SIZE_T
|
||||||
AC_CHECK_MEMBERS([struct stat.st_rdev])
|
AC_CHECK_MEMBERS([struct stat.st_rdev])
|
||||||
|
|
|
@ -27,7 +27,7 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
||||||
|
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -1169,6 +1169,7 @@ AC_CHECK_FUNCS(
|
@@ -1179,6 +1179,7 @@ AC_CHECK_FUNCS(
|
||||||
|
|
||||||
AC_CHECK_FUNCS([ecvt])
|
AC_CHECK_FUNCS([ecvt])
|
||||||
AC_CHECK_FUNCS([fcvt])
|
AC_CHECK_FUNCS([fcvt])
|
||||||
|
@ -35,7 +35,7 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
||||||
|
|
||||||
AC_CHECK_FUNC([mkdtemp], [have_mkdtemp=yes])
|
AC_CHECK_FUNC([mkdtemp], [have_mkdtemp=yes])
|
||||||
|
|
||||||
@@ -1378,10 +1379,13 @@ fi
|
@@ -1388,10 +1389,13 @@ fi
|
||||||
###
|
###
|
||||||
|
|
||||||
AC_CHECK_HEADERS([crypt.h])
|
AC_CHECK_HEADERS([crypt.h])
|
||||||
|
@ -65,7 +65,7 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
||||||
#ifdef __APPLE__
|
#ifdef __APPLE__
|
||||||
#include <sys/socket.h>
|
#include <sys/socket.h>
|
||||||
#include <TargetConditionals.h>
|
#include <TargetConditionals.h>
|
||||||
@@ -1025,31 +1022,32 @@ Id_EndSuperUser(uid_t uid) // IN:
|
@@ -1025,24 +1022,23 @@ Id_EndSuperUser(uid_t uid) // IN:
|
||||||
static Bool
|
static Bool
|
||||||
IdIsSetUGid(void)
|
IdIsSetUGid(void)
|
||||||
{
|
{
|
||||||
|
@ -77,13 +77,13 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
||||||
* We use __secure_getenv, which returns NULL if the binary is
|
* We use __secure_getenv, which returns NULL if the binary is
|
||||||
- * setuid or setgid. Alternatives include,
|
- * setuid or setgid. Alternatives include,
|
||||||
+ * setuid or setgid, when issetugid or getauxval(AT_SECURE) is not
|
+ * setuid or setgid, when issetugid or getauxval(AT_SECURE) is not
|
||||||
+ * available. Alternatives include,
|
+ * available. Alternatives included
|
||||||
*
|
*
|
||||||
- * a) getauxval(AT_SECURE); not available until glibc 2.16.
|
- * a) getauxval(AT_SECURE); not available until glibc 2.16.
|
||||||
- * b) __libc_enable_secure; may not be exported.
|
- * b) __libc_enable_secure; may not be exported.
|
||||||
+ * a) issetugid(); not (yet?) available in glibc.
|
+ * a) issetugid(); not (yet?) available in glibc.
|
||||||
+ * b) getauxval(AT_SECURE); not available until glibc 2.16.
|
+ * b) getauxval(AT_SECURE); not available until glibc 2.16.
|
||||||
+ * c) __libc_enable_secure; may not be exported.
|
+ * c) c) __libc_enable_secure; may not be exported.
|
||||||
*
|
*
|
||||||
- * Use (a) when we are based on glibc 2.16, or newer.
|
- * Use (a) when we are based on glibc 2.16, or newer.
|
||||||
+ * Use (b) when we are based on glibc 2.16, or newer.
|
+ * Use (b) when we are based on glibc 2.16, or newer.
|
||||||
|
@ -99,10 +99,11 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
||||||
+#elif HAVE___SECURE_GETENV
|
+#elif HAVE___SECURE_GETENV
|
||||||
static const char envName[] = "VMW_SETUGID_TEST";
|
static const char envName[] = "VMW_SETUGID_TEST";
|
||||||
|
|
||||||
if (setenv(envName, "1", TRUE) == -1) {
|
/*
|
||||||
return TRUE; /* Conservative */
|
@@ -1062,7 +1058,9 @@ IdIsSetUGid(void)
|
||||||
|
return secure_getenv(envName) == NULL;
|
||||||
}
|
}
|
||||||
return __secure_getenv(envName) == NULL;
|
return TRUE;
|
||||||
-#endif
|
-#endif
|
||||||
+#else
|
+#else
|
||||||
+ /* Android does not have a secure_getenv, so be conservative. */
|
+ /* Android does not have a secure_getenv, so be conservative. */
|
||||||
|
|
|
@ -40,7 +40,7 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
||||||
#include "unicodeOperations.h"
|
#include "unicodeOperations.h"
|
||||||
--- a/lib/include/asyncsocket.h
|
--- a/lib/include/asyncsocket.h
|
||||||
+++ b/lib/include/asyncsocket.h
|
+++ b/lib/include/asyncsocket.h
|
||||||
@@ -171,7 +171,7 @@ typedef struct AsyncSocket AsyncSocket;
|
@@ -175,7 +175,7 @@ typedef struct AsyncSocket AsyncSocket;
|
||||||
* Or the client can specify its favorite poll class and locking behavior.
|
* Or the client can specify its favorite poll class and locking behavior.
|
||||||
* Use of IVmdbPoll is only supported for regular sockets and for Attach.
|
* Use of IVmdbPoll is only supported for regular sockets and for Attach.
|
||||||
*/
|
*/
|
||||||
|
|
|
@ -38,7 +38,7 @@
|
||||||
#include <stdlib.h>
|
#include <stdlib.h>
|
||||||
#include <stdio.h>
|
#include <stdio.h>
|
||||||
#include <unistd.h>
|
#include <unistd.h>
|
||||||
@@ -2573,7 +2574,7 @@ HgfsStatToFileAttr(struct stat *stats,
|
@@ -2566,7 +2567,7 @@ HgfsStatToFileAttr(struct stat *stats,
|
||||||
# define FMTTIMET "l"
|
# define FMTTIMET "l"
|
||||||
# endif
|
# endif
|
||||||
#else
|
#else
|
||||||
|
@ -47,7 +47,7 @@
|
||||||
#endif
|
#endif
|
||||||
LOG(4, "access: %"FMTTIMET"d/%"FMT64"u \nwrite: %"FMTTIMET"d/%"FMT64"u \n"
|
LOG(4, "access: %"FMTTIMET"d/%"FMT64"u \nwrite: %"FMTTIMET"d/%"FMT64"u \n"
|
||||||
"attr: %"FMTTIMET"d/%"FMT64"u\n",
|
"attr: %"FMTTIMET"d/%"FMT64"u\n",
|
||||||
@@ -5301,7 +5302,7 @@ HgfsWriteCheckIORange(off_t offset,
|
@@ -5294,7 +5295,7 @@ HgfsWriteCheckIORange(off_t offset,
|
||||||
goto exit;
|
goto exit;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue