conmon: fix segfault, correct a typo and update description
Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
This commit is contained in:
parent
d424d19b5a
commit
463227f70c
2 changed files with 28 additions and 2 deletions
|
@ -21,13 +21,17 @@ include ../../devel/meson/meson.mk
|
|||
define Package/conmon
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=Podmon conmon
|
||||
TITLE:=Podman conmon
|
||||
URL:=https://podman.io
|
||||
DEPENDS:=+glib2 $(INTL_DEPENDS) $(ICONV_DEPENDS)
|
||||
endef
|
||||
|
||||
define Package/conmon/description
|
||||
Podman: A tool for managing OCI containers and pods
|
||||
An OCI container runtime monitor.
|
||||
|
||||
Conmon is a monitoring program and communication tool between
|
||||
a container manager (like Podman or CRI-O) and an OCI runtime
|
||||
(like runc or crun) for a single container.
|
||||
endef
|
||||
|
||||
define Package/conmon/install
|
||||
|
|
|
@ -0,0 +1,22 @@
|
|||
--- a/src/conn_sock.c
|
||||
+++ b/src/conn_sock.c
|
||||
@@ -465,6 +465,9 @@ static void init_remote_sock(struct remo
|
||||
|
||||
static void close_sock(gpointer data, G_GNUC_UNUSED gpointer user_data)
|
||||
{
|
||||
+ if (data == NULL)
|
||||
+ return;
|
||||
+
|
||||
struct remote_sock_s *sock = (struct remote_sock_s *)data;
|
||||
|
||||
close(sock->fd);
|
||||
@@ -473,5 +476,9 @@ static void close_sock(gpointer data, G_
|
||||
|
||||
void close_all_readers()
|
||||
{
|
||||
+
|
||||
+ if (local_mainfd_stdin.readers == NULL)
|
||||
+ return;
|
||||
+
|
||||
g_ptr_array_foreach(local_mainfd_stdin.readers, close_sock, NULL);
|
||||
}
|
Loading…
Reference in a new issue