openvpn: update to 2.5.7
Added limited support for OpenSSL 3.0 Fixed some bugs Signed-off-by: Ivan Pavlov <AuthorReflex@gmail.com>
This commit is contained in:
parent
44149099e7
commit
45b751dd85
5 changed files with 14 additions and 14 deletions
|
@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=openvpn
|
PKG_NAME:=openvpn
|
||||||
|
|
||||||
PKG_VERSION:=2.5.6
|
PKG_VERSION:=2.5.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_URL:=\
|
PKG_SOURCE_URL:=\
|
||||||
https://build.openvpn.net/downloads/releases/ \
|
https://build.openvpn.net/downloads/releases/ \
|
||||||
https://swupdate.openvpn.net/community/releases/
|
https://swupdate.openvpn.net/community/releases/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_HASH:=13c7c3dc399d1b571cabf189c4d34ae34656ee72b6bde2a8059c1e9bc61574ed
|
PKG_HASH:=313bca7e996a4f59ef9940dd87c6c4b9168064db9be6cabebd37cd65f13759ed
|
||||||
|
|
||||||
PKG_MAINTAINER:=Magnus Kroken <mkroken@gmail.com>
|
PKG_MAINTAINER:=Magnus Kroken <mkroken@gmail.com>
|
||||||
|
|
||||||
|
|
|
@ -67,10 +67,10 @@ Signed-off-by: Gert Doering <gert@greenie.muc.de>
|
||||||
+ [enable_wolfssl_options_h="yes"]
|
+ [enable_wolfssl_options_h="yes"]
|
||||||
+)
|
+)
|
||||||
+
|
+
|
||||||
AC_ARG_VAR([PLUGINDIR], [Path of plug-in directory @<:@default=LIBDIR/openvpn/plugins@:>@])
|
AC_ARG_WITH(
|
||||||
if test -n "${PLUGINDIR}"; then
|
[openssl-engine],
|
||||||
plugindir="${PLUGINDIR}"
|
[AS_HELP_STRING([--with-openssl-engine], [enable engine support with OpenSSL. Default enabled for OpenSSL < 3.0, auto,yes,no @<:@default=auto@:>@])],
|
||||||
@@ -1020,6 +1027,105 @@ elif test "${with_crypto_library}" = "mb
|
@@ -1054,6 +1061,105 @@ elif test "${with_crypto_library}" = "mb
|
||||||
AC_DEFINE([ENABLE_CRYPTO_MBEDTLS], [1], [Use mbed TLS library])
|
AC_DEFINE([ENABLE_CRYPTO_MBEDTLS], [1], [Use mbed TLS library])
|
||||||
CRYPTO_CFLAGS="${MBEDTLS_CFLAGS}"
|
CRYPTO_CFLAGS="${MBEDTLS_CFLAGS}"
|
||||||
CRYPTO_LIBS="${MBEDTLS_LIBS}"
|
CRYPTO_LIBS="${MBEDTLS_LIBS}"
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/openvpn/ssl_mbedtls.c
|
--- a/src/openvpn/ssl_mbedtls.c
|
||||||
+++ b/src/openvpn/ssl_mbedtls.c
|
+++ b/src/openvpn/ssl_mbedtls.c
|
||||||
@@ -1538,7 +1538,7 @@ const char *
|
@@ -1539,7 +1539,7 @@ const char *
|
||||||
get_ssl_library_version(void)
|
get_ssl_library_version(void)
|
||||||
{
|
{
|
||||||
static char mbedtls_version[30];
|
static char mbedtls_version[30];
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -1177,68 +1177,15 @@ dnl
|
@@ -1211,68 +1211,15 @@ dnl
|
||||||
AC_ARG_VAR([LZ4_CFLAGS], [C compiler flags for lz4])
|
AC_ARG_VAR([LZ4_CFLAGS], [C compiler flags for lz4])
|
||||||
AC_ARG_VAR([LZ4_LIBS], [linker flags for lz4])
|
AC_ARG_VAR([LZ4_LIBS], [linker flags for lz4])
|
||||||
if test "$enable_lz4" = "yes" && test "$enable_comp_stub" = "no"; then
|
if test "$enable_lz4" = "yes" && test "$enable_comp_stub" = "no"; then
|
||||||
|
|
|
@ -11,7 +11,7 @@
|
||||||
* Should we include proxy digest auth functionality
|
* Should we include proxy digest auth functionality
|
||||||
--- a/src/openvpn/crypto_mbedtls.c
|
--- a/src/openvpn/crypto_mbedtls.c
|
||||||
+++ b/src/openvpn/crypto_mbedtls.c
|
+++ b/src/openvpn/crypto_mbedtls.c
|
||||||
@@ -383,6 +383,7 @@ int
|
@@ -396,6 +396,7 @@ int
|
||||||
key_des_num_cblocks(const mbedtls_cipher_info_t *kt)
|
key_des_num_cblocks(const mbedtls_cipher_info_t *kt)
|
||||||
{
|
{
|
||||||
int ret = 0;
|
int ret = 0;
|
||||||
|
@ -19,7 +19,7 @@
|
||||||
if (kt->type == MBEDTLS_CIPHER_DES_CBC)
|
if (kt->type == MBEDTLS_CIPHER_DES_CBC)
|
||||||
{
|
{
|
||||||
ret = 1;
|
ret = 1;
|
||||||
@@ -395,6 +396,7 @@ key_des_num_cblocks(const mbedtls_cipher
|
@@ -408,6 +409,7 @@ key_des_num_cblocks(const mbedtls_cipher
|
||||||
{
|
{
|
||||||
ret = 3;
|
ret = 3;
|
||||||
}
|
}
|
||||||
|
@ -27,7 +27,7 @@
|
||||||
|
|
||||||
dmsg(D_CRYPTO_DEBUG, "CRYPTO INFO: n_DES_cblocks=%d", ret);
|
dmsg(D_CRYPTO_DEBUG, "CRYPTO INFO: n_DES_cblocks=%d", ret);
|
||||||
return ret;
|
return ret;
|
||||||
@@ -403,6 +405,7 @@ key_des_num_cblocks(const mbedtls_cipher
|
@@ -416,6 +418,7 @@ key_des_num_cblocks(const mbedtls_cipher
|
||||||
bool
|
bool
|
||||||
key_des_check(uint8_t *key, int key_len, int ndc)
|
key_des_check(uint8_t *key, int key_len, int ndc)
|
||||||
{
|
{
|
||||||
|
@ -35,7 +35,7 @@
|
||||||
int i;
|
int i;
|
||||||
struct buffer b;
|
struct buffer b;
|
||||||
|
|
||||||
@@ -431,11 +434,15 @@ key_des_check(uint8_t *key, int key_len,
|
@@ -444,11 +447,15 @@ key_des_check(uint8_t *key, int key_len,
|
||||||
|
|
||||||
err:
|
err:
|
||||||
return false;
|
return false;
|
||||||
|
@ -51,7 +51,7 @@
|
||||||
int i;
|
int i;
|
||||||
struct buffer b;
|
struct buffer b;
|
||||||
|
|
||||||
@@ -450,6 +457,7 @@ key_des_fixup(uint8_t *key, int key_len,
|
@@ -463,6 +470,7 @@ key_des_fixup(uint8_t *key, int key_len,
|
||||||
}
|
}
|
||||||
mbedtls_des_key_set_parity(key);
|
mbedtls_des_key_set_parity(key);
|
||||||
}
|
}
|
||||||
|
@ -59,7 +59,7 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -770,10 +778,12 @@ cipher_des_encrypt_ecb(const unsigned ch
|
@@ -783,10 +791,12 @@ cipher_des_encrypt_ecb(const unsigned ch
|
||||||
unsigned char *src,
|
unsigned char *src,
|
||||||
unsigned char *dst)
|
unsigned char *dst)
|
||||||
{
|
{
|
||||||
|
|
Loading…
Reference in a new issue