Merge pull request #8583 from ammubhave/bump_glog
glog: Bump version to 0.4.0
This commit is contained in:
commit
4502666bae
2 changed files with 16 additions and 3 deletions
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=glog
|
||||
PKG_VERSION:=0.3.5
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=0.4.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/google/glog/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=7580e408a2c0b5a89ca214739978ce6ff480b5e7d8d7698a2aa92fadc484d1e0
|
||||
PKG_HASH:=f28359aeba12f30d73d9e4711ef356dc842886968112162bc73002645139c39c
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILE:=COPYING
|
||||
|
|
13
libs/libglog/patches/100-fix-musl-compilation.patch
Normal file
13
libs/libglog/patches/100-fix-musl-compilation.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
Index: glog-0.4.0/src/symbolize_unittest.cc
|
||||
===================================================================
|
||||
--- glog-0.4.0.orig/src/symbolize_unittest.cc
|
||||
+++ glog-0.4.0/src/symbolize_unittest.cc
|
||||
@@ -401,7 +401,7 @@ int main(int argc, char **argv) {
|
||||
FLAGS_logtostderr = true;
|
||||
InitGoogleLogging(argv[0]);
|
||||
InitGoogleTest(&argc, argv);
|
||||
-#if defined(HAVE_SYMBOLIZE)
|
||||
+#if defined(HAVE_SYMBOLIZE) && defined(HAVE_STACKTRACE)
|
||||
# if defined(__ELF__)
|
||||
// We don't want to get affected by the callback interface, that may be
|
||||
// used to install some callback function at InitGoogle() time.
|
Loading…
Reference in a new issue