libpbc: Pass CFLAGS properly
This was breaking ASLR builds. Fixed license tag. Added PKG_BUILD_PARALLEL for faster compilation. Small Makefile cleanups. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
9c43805ae5
commit
43f811ad5b
2 changed files with 17 additions and 4 deletions
|
@ -2,18 +2,21 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libpbc
|
||||
PKG_VERSION:=0.5.14
|
||||
PKG_RELEASE:=1
|
||||
PKG_HASH:=772527404117587560080241cedaf441e5cac3269009cdde4c588a1dce4c23d2
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=pbc-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://crypto.stanford.edu/pbc/files/
|
||||
PKG_HASH:=772527404117587560080241cedaf441e5cac3269009cdde4c588a1dce4c23d2
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/pbc-$(PKG_VERSION)
|
||||
PKG_INSTALL:=1
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=LGPL-3.0+
|
||||
PKG_LICENSE:=LGPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libpbc
|
||||
|
|
10
libs/libpbc/patches/010-pass-cflags.patch
Normal file
10
libs/libpbc/patches/010-pass-cflags.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -10,7 +10,6 @@ AC_CONFIG_SRCDIR([./])
|
||||
LT_INIT
|
||||
#AC_CANONICAL_HOST
|
||||
|
||||
-CFLAGS=
|
||||
default_fink_path=/sw
|
||||
case $host_os in
|
||||
darwin*)
|
Loading…
Reference in a new issue