Merge pull request #10212 from neheb/gdd

gddrescue: Remove uClibc++ patch
This commit is contained in:
Rosen Penev 2019-10-13 10:28:03 -07:00 committed by GitHub
commit 43aa7b8d94
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 3 additions and 105 deletions

View file

@ -6,14 +6,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gddrescue PKG_NAME:=gddrescue
PKG_VERSION:=1.23 PKG_VERSION:=1.23
PKG_RELEASE:=2 PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.xz PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.xz
PKG_SOURCE_URL:=http://http.debian.net/debian/pool/main/g/$(PKG_NAME) PKG_SOURCE_URL:=http://http.debian.net/debian/pool/main/g/$(PKG_NAME)
PKG_HASH:=5831d7e24070bc700d8f22deaeec56af1149392ce30ae67254096eaf8c9169ab PKG_HASH:=5831d7e24070bc700d8f22deaeec56af1149392ce30ae67254096eaf8c9169ab
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
PKG_LICENSE:=GPL-2.0 PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=LICENSE PKG_LICENSE_FILES:=LICENSE
PKG_INSTALL:=1 PKG_INSTALL:=1

View file

@ -1,102 +0,0 @@
--- a/fillbook.cc
+++ b/fillbook.cc
@@ -31,6 +31,9 @@
#include "block.h"
#include "mapbook.h"
+#ifdef __UCLIBCXX_MAJOR__
+#undef fputc
+#endif
// Return values: 1 write error, 0 OK.
//
--- a/genbook.cc
+++ b/genbook.cc
@@ -31,6 +31,9 @@
#include "block.h"
#include "mapbook.h"
+#ifdef __UCLIBCXX_MAJOR__
+#undef fputc
+#endif
const char * format_time( const long t, const bool low_prec )
{
--- a/loggers.cc
+++ b/loggers.cc
@@ -25,6 +25,9 @@
#include "block.h"
#include "loggers.h"
+#ifdef __UCLIBCXX_MAJOR__
+#undef fputc
+#endif
namespace {
--- a/main.cc
+++ b/main.cc
@@ -46,6 +46,11 @@
#include "non_posix.h"
#include "rescuebook.h"
+#ifdef __UCLIBCXX_MAJOR__
+#undef fgetc
+#undef fputc
+#endif
+
#ifndef O_BINARY
#define O_BINARY 0
#endif
--- a/main_common.cc
+++ b/main_common.cc
@@ -15,6 +15,10 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#ifdef __UCLIBCXX_MAJOR__
+#undef fputc
+#endif
+
int verbosity = 0;
namespace {
--- a/mapbook.cc
+++ b/mapbook.cc
@@ -32,6 +32,10 @@
#include "block.h"
#include "mapbook.h"
+#ifdef __UCLIBCXX_MAJOR__
+#undef fgetc
+#undef fputc
+#endif
namespace {
--- a/mapfile.cc
+++ b/mapfile.cc
@@ -29,6 +29,11 @@
#include "block.h"
+#ifdef __UCLIBCXX_MAJOR__
+#undef fgetc
+#undef ferror
+#undef feof
+#endif
namespace {
--- a/rescuebook.cc
+++ b/rescuebook.cc
@@ -36,6 +36,9 @@
#include "mapbook.h"
#include "rescuebook.h"
+#ifdef __UCLIBCXX_MAJOR__
+#undef fputc
+#endif
namespace {