open-vm-tools: update to 11.2.0
Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4fe39a4e2f
commit
436ac54916
10 changed files with 20 additions and 21 deletions
|
@ -8,13 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=open-vm-tools
|
PKG_NAME:=open-vm-tools
|
||||||
PKG_VERSION:=11.1.5
|
PKG_VERSION:=11.2.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-16724464.tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-16938113.tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/vmware/open-vm-tools/releases/download/stable-$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/vmware/open-vm-tools/releases/download/stable-$(PKG_VERSION)
|
||||||
PKG_HASH:=cb33171b22872d66632b4151feafd4da480aee0c6bd5dcc188651984c1e9c511
|
PKG_HASH:=df16b78bb919e85fe2b9190148f4987ea4942f9f9667836bf1311dfc2eb839db
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-16724464
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-16938113
|
||||||
|
|
||||||
PKG_LICENSE:=LGPL-2.1-or-later
|
PKG_LICENSE:=LGPL-2.1-or-later
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -1184,6 +1184,7 @@
|
@@ -1195,6 +1195,7 @@ AC_TYPE_OFF_T
|
||||||
AC_TYPE_PID_T
|
AC_TYPE_PID_T
|
||||||
AC_TYPE_SIZE_T
|
AC_TYPE_SIZE_T
|
||||||
AC_CHECK_MEMBERS([struct stat.st_rdev])
|
AC_CHECK_MEMBERS([struct stat.st_rdev])
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/lib/hgfsServer/hgfsServerLinux.c
|
--- a/lib/hgfsServer/hgfsServerLinux.c
|
||||||
+++ b/lib/hgfsServer/hgfsServerLinux.c
|
+++ b/lib/hgfsServer/hgfsServerLinux.c
|
||||||
@@ -105,11 +105,13 @@
|
@@ -105,11 +105,13 @@ typedef struct DirectoryEntry {
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
/*
|
/*
|
||||||
|
@ -28,5 +28,3 @@
|
||||||
#define ACCESSPERMS (S_IRWXU | S_IRWXG | S_IRWXO)
|
#define ACCESSPERMS (S_IRWXU | S_IRWXG | S_IRWXO)
|
||||||
#endif
|
#endif
|
||||||
#ifdef __ANDROID__
|
#ifdef __ANDROID__
|
||||||
|
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -912,6 +912,7 @@
|
@@ -923,6 +923,7 @@ AC_CHECK_FUNCS(
|
||||||
|
|
||||||
AC_CHECK_FUNCS([ecvt])
|
AC_CHECK_FUNCS([ecvt])
|
||||||
AC_CHECK_FUNCS([fcvt])
|
AC_CHECK_FUNCS([fcvt])
|
||||||
|
@ -8,7 +8,7 @@
|
||||||
|
|
||||||
AC_CHECK_FUNC([mkdtemp], [have_mkdtemp=yes])
|
AC_CHECK_FUNC([mkdtemp], [have_mkdtemp=yes])
|
||||||
|
|
||||||
@@ -1121,10 +1122,13 @@
|
@@ -1132,10 +1133,13 @@ fi
|
||||||
###
|
###
|
||||||
|
|
||||||
AC_CHECK_HEADERS([crypt.h])
|
AC_CHECK_HEADERS([crypt.h])
|
||||||
|
@ -38,7 +38,7 @@
|
||||||
#ifdef __APPLE__
|
#ifdef __APPLE__
|
||||||
#include <sys/socket.h>
|
#include <sys/socket.h>
|
||||||
#include <TargetConditionals.h>
|
#include <TargetConditionals.h>
|
||||||
@@ -1025,31 +1022,32 @@
|
@@ -1025,31 +1022,32 @@ Id_EndSuperUser(uid_t uid) // IN:
|
||||||
static Bool
|
static Bool
|
||||||
IdIsSetUGid(void)
|
IdIsSetUGid(void)
|
||||||
{
|
{
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/lib/asyncsocket/asyncsocket.c
|
--- a/lib/asyncsocket/asyncsocket.c
|
||||||
+++ b/lib/asyncsocket/asyncsocket.c
|
+++ b/lib/asyncsocket/asyncsocket.c
|
||||||
@@ -69,8 +69,8 @@
|
@@ -70,8 +70,8 @@
|
||||||
#else
|
#else
|
||||||
#include <stddef.h>
|
#include <stddef.h>
|
||||||
#include <ctype.h>
|
#include <ctype.h>
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/lib/asyncsocket/asyncsocket.c
|
--- a/lib/asyncsocket/asyncsocket.c
|
||||||
+++ b/lib/asyncsocket/asyncsocket.c
|
+++ b/lib/asyncsocket/asyncsocket.c
|
||||||
@@ -86,7 +86,7 @@
|
@@ -87,7 +87,7 @@
|
||||||
#include "random.h"
|
#include "random.h"
|
||||||
#include "asyncsocket.h"
|
#include "asyncsocket.h"
|
||||||
#include "asyncSocketBase.h"
|
#include "asyncSocketBase.h"
|
||||||
|
@ -11,7 +11,7 @@
|
||||||
#include "hostinfo.h"
|
#include "hostinfo.h"
|
||||||
--- a/lib/hgfsServer/hgfsServer.c
|
--- a/lib/hgfsServer/hgfsServer.c
|
||||||
+++ b/lib/hgfsServer/hgfsServer.c
|
+++ b/lib/hgfsServer/hgfsServer.c
|
||||||
@@ -49,7 +49,7 @@
|
@@ -51,7 +51,7 @@
|
||||||
#include "hgfsDirNotify.h"
|
#include "hgfsDirNotify.h"
|
||||||
#include "hgfsThreadpool.h"
|
#include "hgfsThreadpool.h"
|
||||||
#include "userlock.h"
|
#include "userlock.h"
|
||||||
|
@ -22,7 +22,7 @@
|
||||||
#include "unicodeOperations.h"
|
#include "unicodeOperations.h"
|
||||||
--- a/lib/include/asyncsocket.h
|
--- a/lib/include/asyncsocket.h
|
||||||
+++ b/lib/include/asyncsocket.h
|
+++ b/lib/include/asyncsocket.h
|
||||||
@@ -169,7 +169,7 @@ typedef struct AsyncSocket AsyncSocket;
|
@@ -171,7 +171,7 @@ typedef struct AsyncSocket AsyncSocket;
|
||||||
* Or the client can specify its favorite poll class and locking behavior.
|
* Or the client can specify its favorite poll class and locking behavior.
|
||||||
* Use of IVmdbPoll is only supported for regular sockets and for Attach.
|
* Use of IVmdbPoll is only supported for regular sockets and for Attach.
|
||||||
*/
|
*/
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/lib/err/errPosix.c
|
--- a/lib/err/errPosix.c
|
||||||
+++ b/lib/err/errPosix.c
|
+++ b/lib/err/errPosix.c
|
||||||
@@ -61,13 +61,7 @@ ErrErrno2String(Err_Number errorNumber, // IN
|
@@ -61,13 +61,7 @@ ErrErrno2String(Err_Number errorNumber,
|
||||||
char *buf, // OUT: return buffer
|
char *buf, // OUT: return buffer
|
||||||
size_t bufSize) // IN: size of buffer
|
size_t bufSize) // IN: size of buffer
|
||||||
{
|
{
|
||||||
|
|
|
@ -10,7 +10,7 @@
|
||||||
|
|
||||||
#ifdef __linux__
|
#ifdef __linux__
|
||||||
# include <net/if.h>
|
# include <net/if.h>
|
||||||
--- a/lib/nicInfo/resolv_compat.h
|
--- /dev/null
|
||||||
+++ b/lib/nicInfo/resolv_compat.h
|
+++ b/lib/nicInfo/resolv_compat.h
|
||||||
@@ -0,0 +1,29 @@
|
@@ -0,0 +1,29 @@
|
||||||
+#if !defined(__GLIBC__)
|
+#if !defined(__GLIBC__)
|
||||||
|
|
|
@ -9,7 +9,7 @@
|
||||||
uint32 sec;
|
uint32 sec;
|
||||||
uint32 nsec;
|
uint32 nsec;
|
||||||
|
|
||||||
@@ -134,7 +134,7 @@ HgfsConvertFromNtTimeNsec(struct timespec *unixTime, // OUT: Time in UNIX format
|
@@ -134,7 +134,7 @@ HgfsConvertFromNtTimeNsec(struct timespe
|
||||||
return -1;
|
return -1;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
unixTime->tv_nsec = nsec * 100;
|
unixTime->tv_nsec = nsec * 100;
|
||||||
--- a/lib/hgfsServer/hgfsServerLinux.c
|
--- a/lib/hgfsServer/hgfsServerLinux.c
|
||||||
+++ b/lib/hgfsServer/hgfsServerLinux.c
|
+++ b/lib/hgfsServer/hgfsServerLinux.c
|
||||||
@@ -2569,7 +2569,11 @@ HgfsStatToFileAttr(struct stat *stats, // IN: stat information
|
@@ -2573,8 +2573,12 @@ HgfsStatToFileAttr(struct stat *stats,
|
||||||
# define FMTTIMET "l"
|
# define FMTTIMET "l"
|
||||||
# endif
|
# endif
|
||||||
#else
|
#else
|
||||||
|
@ -28,7 +28,8 @@
|
||||||
+# define FMTTIMET __PRI64
|
+# define FMTTIMET __PRI64
|
||||||
+#else
|
+#else
|
||||||
# define FMTTIMET "l"
|
# define FMTTIMET "l"
|
||||||
+#endif
|
|
||||||
#endif
|
#endif
|
||||||
|
+#endif
|
||||||
LOG(4, "access: %"FMTTIMET"d/%"FMT64"u \nwrite: %"FMTTIMET"d/%"FMT64"u \n"
|
LOG(4, "access: %"FMTTIMET"d/%"FMT64"u \nwrite: %"FMTTIMET"d/%"FMT64"u \n"
|
||||||
"attr: %"FMTTIMET"d/%"FMT64"u\n",
|
"attr: %"FMTTIMET"d/%"FMT64"u\n",
|
||||||
|
stats->st_atime, attr->accessTime, stats->st_mtime, attr->writeTime,
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -1199,7 +1199,6 @@ AC_C_VOLATILE
|
@@ -1210,7 +1210,6 @@ AC_C_VOLATILE
|
||||||
|
|
||||||
### General flags / actions
|
### General flags / actions
|
||||||
CFLAGS="$CFLAGS -Wall"
|
CFLAGS="$CFLAGS -Wall"
|
||||||
|
|
Loading…
Reference in a new issue