libextractor: Add missing header
Fixes compilation with -Wimplicit-function-declaration
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from 0860268f22
)
This commit is contained in:
parent
fa0c3b7baa
commit
42bd3a7ef1
2 changed files with 15 additions and 2 deletions
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libextractor
|
||||
PKG_VERSION:=1.9
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
# ToDo:
|
||||
# - package missing optional dependencies: libexiv2, gsf, librpm, smf, tidy
|
||||
|
@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|||
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
||||
PKG_HASH:=f08f257d26c5e9b503f068d6753c8e55cb76f47f73a81da6ed2bba3de3fee2ff
|
||||
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
||||
|
|
13
libs/libextractor/patches/010-musl.patch
Normal file
13
libs/libextractor/patches/010-musl.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/src/common/le_architecture.h b/src/common/le_architecture.h
|
||||
index b863ddb..713acdd 100644
|
||||
--- a/src/common/le_architecture.h
|
||||
+++ b/src/common/le_architecture.h
|
||||
@@ -26,6 +26,8 @@
|
||||
|
||||
#if WINDOWS
|
||||
#include <sys/param.h> /* #define BYTE_ORDER */
|
||||
+#else
|
||||
+#include <byteswap.h>
|
||||
#endif
|
||||
|
||||
/* This is copied directly from GNUnet headers */
|
Loading…
Reference in a new issue