php5: bump to 5.6.32
Fixes since 5.6.26: - ton of bugs - CVE-2016-9933 - CVE-2016-9934 - CVE-2016-9935 - CVE-2016-10158 - CVE-2016-10167 - CVE-2016-10168 - CVE-2016-10159 - CVE-2016-10160 - CVE-2016-10161 - CVE-2017-7890 - CVE-2017-9224 - CVE-2017-9226 - CVE-2017-9227 - CVE-2017-9228 - CVE-2017-9229 - CVE-2016-1283 Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
This commit is contained in:
parent
b8a8d398de
commit
4273641178
4 changed files with 12 additions and 17 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=php
|
||||
PKG_VERSION:=5.6.26
|
||||
PKG_VERSION:=5.6.32
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>, Michael Heimpold <mhei@heimpold.de>
|
||||
|
@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=LICENSE
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||
PKG_MD5SUM:=c51e9115263b4d63ef8f68935cefd7d4
|
||||
PKG_MD5SUM:=660cd5bc0f16eaad655b7815c757aadc
|
||||
|
||||
PKG_FIXUP:=libtool autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
|
|
@ -20,9 +20,9 @@ r1: initial revision
|
|||
|
||||
--- a/ext/date/lib/parse_tz.c
|
||||
+++ b/ext/date/lib/parse_tz.c
|
||||
@@ -18,8 +18,22 @@
|
||||
|
||||
/* $Id$ */
|
||||
@@ -22,8 +22,22 @@
|
||||
* THE SOFTWARE.
|
||||
*/
|
||||
|
||||
+#ifndef PATH_MAX
|
||||
+#define PATH_MAX 4096
|
||||
|
@ -43,7 +43,7 @@ r1: initial revision
|
|||
#include <stdio.h>
|
||||
|
||||
#ifdef HAVE_LOCALE_H
|
||||
@@ -32,8 +46,12 @@
|
||||
@@ -36,8 +50,12 @@
|
||||
#include <strings.h>
|
||||
#endif
|
||||
|
||||
|
@ -56,7 +56,7 @@ r1: initial revision
|
|||
|
||||
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
|
||||
# if defined(__LITTLE_ENDIAN__)
|
||||
@@ -55,6 +73,11 @@ static int read_preamble(const unsigned
|
||||
@@ -59,6 +77,11 @@ static int read_preamble(const unsigned
|
||||
{
|
||||
uint32_t version;
|
||||
|
||||
|
@ -68,7 +68,7 @@ r1: initial revision
|
|||
/* read ID */
|
||||
version = (*tzf)[3] - '0';
|
||||
*tzf += 4;
|
||||
@@ -298,7 +321,406 @@ void timelib_dump_tzinfo(timelib_tzinfo
|
||||
@@ -302,7 +325,406 @@ void timelib_dump_tzinfo(timelib_tzinfo
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -476,7 +476,7 @@ r1: initial revision
|
|||
{
|
||||
int left = 0, right = tzdb->index_size - 1;
|
||||
#ifdef HAVE_SETLOCALE
|
||||
@@ -337,21 +759,90 @@ static int seek_to_tz_position(const uns
|
||||
@@ -341,21 +763,90 @@ static int seek_to_tz_position(const uns
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -568,7 +568,7 @@ r1: initial revision
|
|||
}
|
||||
|
||||
static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
|
||||
@@ -376,10 +867,12 @@ static void read_64bit_header(const unsi
|
||||
@@ -380,10 +871,12 @@ static void read_64bit_header(const unsi
|
||||
timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
|
||||
{
|
||||
const unsigned char *tzf;
|
||||
|
@ -582,7 +582,7 @@ r1: initial revision
|
|||
tmp = timelib_tzinfo_ctor(timezone);
|
||||
|
||||
version = read_preamble(&tzf, tmp);
|
||||
@@ -393,7 +886,34 @@ timelib_tzinfo *timelib_parse_tzfile(cha
|
||||
@@ -397,7 +890,34 @@ timelib_tzinfo *timelib_parse_tzfile(cha
|
||||
skip_64bit_types(&tzf, tmp);
|
||||
skip_posix_string(&tzf, tmp);
|
||||
}
|
||||
|
|
|
@ -18,8 +18,6 @@ Signed-off-by: Michael Heimpold <mhei@heimpold.de>
|
|||
ext/opcache/config.m4 | 122 ++-----------------------------------------------
|
||||
1 file changed, 4 insertions(+), 118 deletions(-)
|
||||
|
||||
diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
|
||||
index b7e4835..7b6c0aa 100644
|
||||
--- a/ext/opcache/config.m4
|
||||
+++ b/ext/opcache/config.m4
|
||||
@@ -11,127 +11,13 @@ if test "$PHP_OPCACHE" != "no"; then
|
||||
|
@ -154,6 +152,3 @@ index b7e4835..7b6c0aa 100644
|
|||
|
||||
AC_MSG_CHECKING(for mmap() using /dev/zero shared memory support)
|
||||
AC_TRY_RUN([
|
||||
--
|
||||
1.7.10.4
|
||||
|
||||
|
|
|
@ -55,5 +55,5 @@
|
|||
+ AC_MSG_RESULT("no")
|
||||
+])
|
||||
|
||||
if test "$flock_type" == "unknown"; then
|
||||
if test "$flock_type" = "unknown"; then
|
||||
AC_MSG_ERROR([Don't know how to define struct flock on this system[,] set --enable-opcache=no])
|
||||
|
|
Loading…
Reference in a new issue