jamvm: remove package
Java support is no longer feasible in openwrt. It's outdated, and can't be usd without classpath, which has been removed. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
This commit is contained in:
parent
b7d429c466
commit
4201a4a4fb
3 changed files with 0 additions and 166 deletions
|
@ -1,68 +0,0 @@
|
|||
#
|
||||
# Copyright (C) 2006-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=jamvm
|
||||
PKG_VERSION:=2.0.0
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_HASH:=76428e96df0ae9dd964c7a7c74c1e9a837e2f312c39e9a357fa8178f7eff80da
|
||||
|
||||
PKG_MAINTAINER:=Dana H. Myers <k6jq@comcast.net>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/jamvm
|
||||
SUBMENU:=Java
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
TITLE:=A compact Java Virtual Machine
|
||||
URL:=http://jamvm.sourceforge.net/
|
||||
DEPENDS:=+zlib +libpthread +librt +CONFIG_powerpc64:libffi @!arc @!aarch64
|
||||
endef
|
||||
|
||||
define Package/jamvm/description
|
||||
JamVM is a Java Virtual Machine which conforms to the JVM
|
||||
specification version 2 (a.k.a, 1.2). In comparison to most other VM's (free
|
||||
and commercial) it is extremely small. However, unlike other small VMs
|
||||
(e.g. KVM) it is designed to support the full specification, and includes
|
||||
support for object finalisation, Soft/Weak/Phantom References, the Java
|
||||
Native Interface (JNI) and the Reflection API.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-java-runtime-library=gnuclasspath \
|
||||
--with-classpath-install-dir=/usr \
|
||||
--disable-int-inlining \
|
||||
--disable-shared \
|
||||
--without-pic
|
||||
|
||||
MAKE_FLAGS += \
|
||||
GLIBJ_ZIP=$(STAGING_DIR)/usr/share/classpath/glibj.zip
|
||||
|
||||
define Package/jamvm/install
|
||||
$(INSTALL_DIR) $(1)/usr
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin \
|
||||
$(PKG_INSTALL_DIR)/usr/share \
|
||||
$(1)/usr/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,jamvm))
|
|
@ -1,86 +0,0 @@
|
|||
From 7152ded5219453c9ff1cd062cecbeaf4d77e4cab Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
Date: Thu, 26 May 2016 15:05:48 +0200
|
||||
Subject: [PATCH] Use <fenv.h> instead of <fpu_control.h>
|
||||
|
||||
musl libc (http://musl-libc.org lack the non-standard <fpu_control.h>
|
||||
header, which is used in src/os/linux/{i386,x86_64}/init.c files to
|
||||
setup the floating point precision. This patch makes it use the
|
||||
standard C <fenv.h> header instead.
|
||||
|
||||
Original patch at Felix Janda at
|
||||
https://sourceforge.net/p/jamvm/patches/6/.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
---
|
||||
src/os/linux/i386/init.c | 12 ++++++------
|
||||
src/os/linux/x86_64/init.c | 16 ++++++----------
|
||||
2 files changed, 12 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/src/os/linux/i386/init.c b/src/os/linux/i386/init.c
|
||||
index d9c6648..94a733e 100644
|
||||
--- a/src/os/linux/i386/init.c
|
||||
+++ b/src/os/linux/i386/init.c
|
||||
@@ -19,18 +19,18 @@
|
||||
* Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||
*/
|
||||
|
||||
-#include <fpu_control.h>
|
||||
+#include <fenv.h>
|
||||
|
||||
/* Change floating point precision to double (64-bit) from
|
||||
* the extended (80-bit) Linux default. */
|
||||
|
||||
void setDoublePrecision() {
|
||||
- fpu_control_t cw;
|
||||
+ fenv_t fenv;
|
||||
|
||||
- _FPU_GETCW(cw);
|
||||
- cw &= ~_FPU_EXTENDED;
|
||||
- cw |= _FPU_DOUBLE;
|
||||
- _FPU_SETCW(cw);
|
||||
+ fegetenv(&fenv);
|
||||
+ fenv.__control_word &= ~0x300; /* _FPU_EXTENDED */
|
||||
+ fenv.__control_word |= 0x200; /* _FPU_DOUBLE */
|
||||
+ fesetenv(&fenv);
|
||||
}
|
||||
|
||||
void initialisePlatform() {
|
||||
diff --git a/src/os/linux/x86_64/init.c b/src/os/linux/x86_64/init.c
|
||||
index 9d55229..a76a923 100644
|
||||
--- a/src/os/linux/x86_64/init.c
|
||||
+++ b/src/os/linux/x86_64/init.c
|
||||
@@ -19,9 +19,7 @@
|
||||
* Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||
*/
|
||||
|
||||
-#ifdef __linux__
|
||||
-#include <fpu_control.h>
|
||||
-#endif
|
||||
+#include <fenv.h>
|
||||
|
||||
/* Change the x87 FPU precision to double (64-bit) from the extended
|
||||
(80-bit) Linux default. Note, unlike on i386, my testcases pass
|
||||
@@ -30,14 +28,12 @@
|
||||
*/
|
||||
|
||||
void setDoublePrecision() {
|
||||
-#ifdef __linux__
|
||||
- fpu_control_t cw;
|
||||
+ fenv_t fenv;
|
||||
|
||||
- _FPU_GETCW(cw);
|
||||
- cw &= ~_FPU_EXTENDED;
|
||||
- cw |= _FPU_DOUBLE;
|
||||
- _FPU_SETCW(cw);
|
||||
-#endif
|
||||
+ fegetenv(&fenv);
|
||||
+ fenv.__control_word &= ~0x300; /*_FPU_EXTENDED */
|
||||
+ fenv.__control_word |= 0x200; /*_FPU_DOUBLE */
|
||||
+ fesetenv(&fenv);
|
||||
}
|
||||
|
||||
void initialisePlatform() {
|
||||
--
|
||||
2.7.4
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
--- a/src/os/linux/os.c
|
||||
+++ b/src/os/linux/os.c
|
||||
@@ -26,6 +26,9 @@
|
||||
#include <sys/sysinfo.h>
|
||||
|
||||
#define __USE_GNU
|
||||
+#ifndef _GNU_SOURCE
|
||||
+#define _GNU_SOURCE
|
||||
+#endif
|
||||
#include <dlfcn.h>
|
||||
#include <pthread.h>
|
||||
|
Loading…
Reference in a new issue