Merge pull request #9607 from neheb/ldap
openldap: Add static function declaration
This commit is contained in:
commit
41da27023e
2 changed files with 11 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=openldap
|
||||
PKG_VERSION:=2.4.47
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=https://gpl.savoirfairelinux.net/pub/mirrors/openldap/openldap-release/ \
|
||||
|
|
10
libs/openldap/patches/800-implicit.patch
Normal file
10
libs/openldap/patches/800-implicit.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/libraries/libldap/tls2.c
|
||||
+++ b/libraries/libldap/tls2.c
|
||||
@@ -41,6 +41,7 @@ static tls_impl *tls_imp = &ldap_int_tls_impl;
|
||||
#define HAS_TLS( sb ) ber_sockbuf_ctrl( sb, LBER_SB_OPT_HAS_IO, \
|
||||
(void *)tls_imp->ti_sbio )
|
||||
|
||||
+static int ldap_pvt_tls_check_hostname( LDAP *ld, void *s, const char *name_in );
|
||||
#endif /* HAVE_TLS */
|
||||
|
||||
#ifdef LDAP_DEVEL
|
Loading…
Reference in a new issue