Merge pull request #13058 from guidosarducci/master-fix-gcc10-netperf
netperf: fix compilation with GCC10
This commit is contained in:
commit
416dccf72a
2 changed files with 20 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=netperf
|
||||
PKG_VERSION:=2.7.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_LICENSE:=Custom
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
|
|
19
net/netperf/patches/010-gcc10_multiple_definition_fix.patch
Normal file
19
net/netperf/patches/010-gcc10_multiple_definition_fix.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- a/src/nettest_omni.c
|
||||
+++ b/src/nettest_omni.c
|
||||
@@ -454,16 +454,6 @@ static int remote_cpu_method;
|
||||
static int client_port_min = 5000;
|
||||
static int client_port_max = 65535;
|
||||
|
||||
- /* different options for the sockets */
|
||||
-
|
||||
-int
|
||||
- loc_nodelay, /* don't/do use NODELAY locally */
|
||||
- rem_nodelay, /* don't/do use NODELAY remotely */
|
||||
- loc_sndavoid, /* avoid send copies locally */
|
||||
- loc_rcvavoid, /* avoid recv copies locally */
|
||||
- rem_sndavoid, /* avoid send copies remotely */
|
||||
- rem_rcvavoid; /* avoid recv_copies remotely */
|
||||
-
|
||||
extern int
|
||||
loc_tcpcork,
|
||||
rem_tcpcork,
|
Loading…
Reference in a new issue