pdns-recursor: Build rec-5.0.1, adding Rust dependencies
also fix license variable Co-authored-by: Tianling Shen <cnsztl@gmail.com> Signed-off-by: Otto Moerbeek <otto@drijf.net> Signed-off-by: Peter van Dijk <peter.van.dijk@powerdns.com>
This commit is contained in:
parent
f9c90fce0a
commit
40efc9a4e2
2 changed files with 15 additions and 7 deletions
|
@ -1,23 +1,25 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=pdns-recursor
|
PKG_NAME:=pdns-recursor
|
||||||
PKG_VERSION:=4.9.2
|
PKG_VERSION:=5.0.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
||||||
PKG_HASH:=4cb8180458ecfb528a3d9a34ba2844b6cd2ed69ca1c461dde24a0ebd66829144
|
PKG_HASH:=70a3b0bfde350e94cdb0746b06d06e6d2f3dc0e171be3b12caef9f3c38468ca3
|
||||||
|
|
||||||
PKG_MAINTAINER:=Peter van Dijk <peter.van.dijk@powerdns.com>
|
PKG_MAINTAINER:=Peter van Dijk <peter.van.dijk@powerdns.com>
|
||||||
PKG_LICENCE:=GPL-2.0-only
|
PKG_LICENSE:=GPL-2.0-only
|
||||||
PKG_LICENCE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
PKG_CPE_ID:=cpe:/a:powerdns:recursor
|
PKG_CPE_ID:=cpe:/a:powerdns:recursor
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_BUILD_DEPENDS:=rust/host
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include ../../lang/rust/rust-values.mk
|
||||||
|
|
||||||
define Package/pdns-recursor
|
define Package/pdns-recursor
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
|
@ -52,6 +54,9 @@ CONFIGURE_ARGS += \
|
||||||
--enable-reproducible \
|
--enable-reproducible \
|
||||||
--disable-silent-rules
|
--disable-silent-rules
|
||||||
|
|
||||||
|
MAKE_VARS += RUSTC_TARGET_ARCH=$(RUSTC_TARGET_ARCH)
|
||||||
|
MAKE_VARS += RUST_TARGET=--target=$(RUSTC_TARGET_ARCH)
|
||||||
|
|
||||||
define Package/pdns-recursor/install
|
define Package/pdns-recursor/install
|
||||||
$(INSTALL_DIR) $(1)/etc/powerdns
|
$(INSTALL_DIR) $(1)/etc/powerdns
|
||||||
$(INSTALL_CONF) ./files/recursor.conf-dist $(1)/etc/powerdns/
|
$(INSTALL_CONF) ./files/recursor.conf-dist $(1)/etc/powerdns/
|
||||||
|
|
|
@ -1,14 +1,17 @@
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -507,12 +507,6 @@ $(srcdir)/effective_tld_names.dat:
|
@@ -527,15 +527,6 @@ $(srcdir)/effective_tld_names.dat:
|
||||||
pubsuffix.cc: $(srcdir)/effective_tld_names.dat
|
pubsuffix.cc: $(srcdir)/effective_tld_names.dat
|
||||||
$(AM_V_GEN)./mkpubsuffixcc
|
$(AM_V_GEN)./mkpubsuffixcc
|
||||||
|
|
||||||
-## Config file
|
-## Config file
|
||||||
-sysconf_DATA = recursor.conf-dist
|
-sysconf_DATA = recursor.conf-dist recursor.yml-dist
|
||||||
-
|
-
|
||||||
-recursor.conf-dist: pdns_recursor
|
-recursor.conf-dist: pdns_recursor
|
||||||
- $(AM_V_GEN)./pdns_recursor --config=default > $@
|
- $(AM_V_GEN)./pdns_recursor --config=default > $@
|
||||||
|
-
|
||||||
|
-recursor.yml-dist: pdns_recursor
|
||||||
|
- dir=$$(mktemp -d) && touch "$$dir/recursor.yml" && ./pdns_recursor --config-dir="$$dir" --config=default 2> /dev/null > $@ && rm "$$dir/recursor.yml" && rmdir "$$dir"
|
||||||
-
|
-
|
||||||
## Manpages
|
## Manpages
|
||||||
MANPAGES=pdns_recursor.1 \
|
MANPAGES=pdns_recursor.1 \
|
||||||
|
|
Loading…
Reference in a new issue