Merge pull request #14847 from jefferyto/python-3.9.2
python3: Update to 3.9.2, refresh patches
This commit is contained in:
commit
406a788307
3 changed files with 6 additions and 6 deletions
|
@ -8,7 +8,7 @@
|
||||||
# Note: keep in sync with setuptools & pip
|
# Note: keep in sync with setuptools & pip
|
||||||
PYTHON3_VERSION_MAJOR:=3
|
PYTHON3_VERSION_MAJOR:=3
|
||||||
PYTHON3_VERSION_MINOR:=9
|
PYTHON3_VERSION_MINOR:=9
|
||||||
PYTHON3_VERSION_MICRO:=1
|
PYTHON3_VERSION_MICRO:=2
|
||||||
|
|
||||||
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
|
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
|
||||||
|
|
||||||
|
|
|
@ -11,12 +11,12 @@ include $(TOPDIR)/rules.mk
|
||||||
include ../python3-version.mk
|
include ../python3-version.mk
|
||||||
|
|
||||||
PKG_NAME:=python3
|
PKG_NAME:=python3
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
|
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
|
||||||
|
|
||||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||||
PKG_HASH:=991c3f8ac97992f3d308fefeb03a64db462574eadbff34ce8bc5bb583d9903ff
|
PKG_HASH:=3c2034c54f811448f516668dce09d24008a0716c3a794dd8639b5388cbde247d
|
||||||
|
|
||||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||||
PKG_LICENSE:=Python/2.0
|
PKG_LICENSE:=Python/2.0
|
||||||
|
|
|
@ -10,7 +10,7 @@
|
||||||
global _config_vars
|
global _config_vars
|
||||||
--- a/Lib/sysconfig.py
|
--- a/Lib/sysconfig.py
|
||||||
+++ b/Lib/sysconfig.py
|
+++ b/Lib/sysconfig.py
|
||||||
@@ -342,6 +342,7 @@ def get_makefile_filename():
|
@@ -352,6 +352,7 @@ def get_makefile_filename():
|
||||||
|
|
||||||
|
|
||||||
def _get_sysconfigdata_name():
|
def _get_sysconfigdata_name():
|
||||||
|
@ -49,7 +49,7 @@
|
||||||
fi
|
fi
|
||||||
elif test "$cross_compiling" = maybe; then
|
elif test "$cross_compiling" = maybe; then
|
||||||
as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
|
as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
|
||||||
@@ -15441,7 +15441,7 @@ fi
|
@@ -15435,7 +15435,7 @@ fi
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
@ -69,7 +69,7 @@
|
||||||
fi
|
fi
|
||||||
elif test "$cross_compiling" = maybe; then
|
elif test "$cross_compiling" = maybe; then
|
||||||
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
|
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
|
||||||
@@ -4833,7 +4833,7 @@ fi],
|
@@ -4828,7 +4828,7 @@ fi],
|
||||||
|
|
||||||
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
||||||
AC_SUBST(PY_ENABLE_SHARED)
|
AC_SUBST(PY_ENABLE_SHARED)
|
||||||
|
|
Loading…
Reference in a new issue