postfix: version update to 3.3.0
Signed-off-by: Denis Shulyaka <Shulyaka@gmail.com>
This commit is contained in:
parent
b392ae5417
commit
405ea1976c
8 changed files with 12 additions and 31 deletions
|
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=postfix
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=3.2.4
|
||||
PKG_VERSION:=3.3.0
|
||||
PKG_SOURCE_URL:= \
|
||||
https://cdn.postfix.johnriley.me/mirrors/postfix-release/official/ \
|
||||
ftp://ftp.porcupine.org/mirrors/postfix-release/official/
|
||||
|
||||
PKG_HASH:=ec55ebaa2aa464792af8d5ee103eb68b27a42dc2b36a02fee42dafbf9740c7f6
|
||||
PKG_HASH:=7942e89721e30118d7050675b0d976955e3160e21f7898b85a79cac4f4baef39
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MAINTAINER:=Denis Shulyaka <Shulyaka@gmail.com>
|
||||
PKG_LICENSE:=IPL-1.0
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
diff -rupN postfix-2.8.1/src/smtpd/smtpd_check.c postfix-2.8.1_patched/src/smtpd/smtpd_check.c
|
||||
--- postfix-2.8.1/src/smtpd/smtpd_check.c 2011-01-04 22:03:50.000000000 +0300
|
||||
+++ postfix-2.8.1_patched/src/smtpd/smtpd_check.c 2011-03-06 19:35:39.000000000 +0300
|
||||
@@ -5302,7 +5302,7 @@ char *smtpd_check_queue(SMTPD_STATE *s
|
||||
@@ -5322,7 +5322,7 @@ char *smtpd_check_queue(SMTPD_STATE *s
|
||||
*/
|
||||
#define BLOCKS(x) ((x) / fsbuf.block_size)
|
||||
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
This patch fixes the runtime error when libmilter is used with Postfix:
|
||||
"unix_send_fd: your system has no support for file descriptor passing"
|
||||
|
||||
The issue has been fixed upstream in 20170618 update to Postfix v.3.3:
|
||||
http://postfix.1071664.n5.nabble.com/Fix-check-for-file-descriptor-passing-td90983.html
|
||||
|
||||
This patch must be removed before compiling Postfix v.3.3.*
|
||||
|
||||
--- a/src/util/sys_defs.h
|
||||
+++ b/src/util/sys_defs.h
|
||||
@@ -804,7 +804,7 @@ extern int initgroups(const char *, int)
|
||||
#define KERNEL_VERSION(a,b,c) (LINUX_VERSION_CODE + 1)
|
||||
#endif
|
||||
#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,2,0)) \
|
||||
- || (__GLIBC__ < 2)
|
||||
+ || (defined(__GLIBC__) && __GLIBC__ < 2)
|
||||
#define CANT_USE_SEND_RECV_MSG
|
||||
#define DEF_SMTP_CACHE_DEMAND 0
|
||||
#else
|
|
@ -1,7 +1,7 @@
|
|||
diff -Naur postfix-2.10.2/conf/post-install postfix-2.10.2_patched/conf/post-install
|
||||
--- postfix-2.10.2/conf/post-install 2013-06-13 18:07:46.000000000 +0400
|
||||
+++ postfix-2.10.2_patched/conf/post-install 2013-11-19 21:17:49.572820573 +0400
|
||||
@@ -361,10 +361,10 @@
|
||||
@@ -366,10 +366,10 @@
|
||||
|
||||
# Sanity checks
|
||||
|
||||
|
@ -16,7 +16,7 @@ diff -Naur postfix-2.10.2/conf/post-install postfix-2.10.2_patched/conf/post-ins
|
|||
|
||||
case $setgid_group in
|
||||
no) echo $0: Error: setgid_group no longer accepts \"no\" values. 1>&2
|
||||
@@ -372,7 +372,7 @@
|
||||
@@ -377,7 +377,7 @@
|
||||
esac
|
||||
|
||||
for path in "$daemon_directory" "$command_directory" "$queue_directory" \
|
||||
|
@ -25,7 +25,7 @@ diff -Naur postfix-2.10.2/conf/post-install postfix-2.10.2_patched/conf/post-ins
|
|||
"$meta_directory"
|
||||
do
|
||||
case "$path" in
|
||||
@@ -381,7 +381,7 @@
|
||||
@@ -386,7 +386,7 @@
|
||||
esac
|
||||
done
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/util/dict_db.c 2017-07-16 16:56:00.819659962 +0300
|
||||
+++ b/src/util/dict_db.c 2017-07-16 16:58:31.011401358 +0300
|
||||
@@ -733,8 +733,8 @@
|
||||
@@ -740,8 +740,8 @@
|
||||
msg_fatal("create DB database: %m");
|
||||
if (db == 0)
|
||||
msg_panic("db_create null result");
|
||||
|
@ -8,6 +8,6 @@
|
|||
- msg_fatal("set DB hash element count %d: %m", DICT_DB_NELM);
|
||||
+// if (type == DB_HASH && db->set_h_nelem(db, DICT_DB_NELM) != 0)
|
||||
+// msg_fatal("set DB hash element count %d: %m", DICT_DB_NELM);
|
||||
db_base_buf = vstring_alloc(100);
|
||||
#if DB_VERSION_MAJOR == 6 || DB_VERSION_MAJOR == 5 || \
|
||||
(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR > 0)
|
||||
if ((errno = db->open(db, 0, db_path, 0, type, db_flags, 0644)) != 0)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/makedefs 2016-01-28 12:30:14.444082390 -0500
|
||||
+++ b/makedefs 2016-01-28 13:44:02.092006512 -0500
|
||||
@@ -210,7 +210,7 @@ error() {
|
||||
@@ -213,7 +213,7 @@ error() {
|
||||
|
||||
case $# in
|
||||
# Officially supported usage.
|
||||
|
@ -9,7 +9,7 @@
|
|||
RELEASE=`(uname -r) 2>/dev/null`
|
||||
# No ${x%%y} support in Solaris 11 /bin/sh
|
||||
RELEASE_MAJOR=`expr "$RELEASE" : '\([0-9]*\)'` || exit 1
|
||||
@@ -224,6 +224,15 @@ case $# in
|
||||
@@ -227,6 +227,15 @@ case $# in
|
||||
esac
|
||||
|
||||
case "$SYSTEM.$RELEASE" in
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
diff -Naur postfix-2.11.1/conf/post-install postfix-2.11.1.patched/conf/post-install
|
||||
--- postfix-2.11.1/conf/post-install 2014-10-05 20:43:58.597876946 +0400
|
||||
+++ postfix-2.11.1.patched/conf/post-install 2014-10-11 16:28:01.258874097 +0400
|
||||
@@ -321,7 +321,7 @@
|
||||
@@ -326,7 +326,7 @@
|
||||
case `uname -s` in
|
||||
HP-UX*) FMT=cat;;
|
||||
SunOS*) FMT=fake_fmt;;
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
diff -Naur a/conf/post-install b/conf/post-install
|
||||
--- a/conf/post-install 2015-12-28 00:00:45.000000000 +0000
|
||||
+++ b/conf/post-install 2017-08-01 22:42:30.476896711 +0000
|
||||
@@ -561,15 +561,16 @@
|
||||
@@ -566,15 +566,16 @@
|
||||
then
|
||||
set_permission=1
|
||||
fi
|
||||
|
|
Loading…
Reference in a new issue