pdns-recursor: fix compilation with boost 1.73
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
03a27b26a4
commit
3ef692e74d
2 changed files with 22 additions and 1 deletions
net/pdns-recursor
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=pdns-recursor
|
PKG_NAME:=pdns-recursor
|
||||||
PKG_VERSION:=4.2.1
|
PKG_VERSION:=4.2.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
||||||
|
|
21
net/pdns-recursor/patches/300-boost-173.patch
Normal file
21
net/pdns-recursor/patches/300-boost-173.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
--- a/webserver.cc
|
||||||
|
+++ b/webserver.cc
|
||||||
|
@@ -36,6 +36,8 @@
|
||||||
|
#include "uuid-utils.hh"
|
||||||
|
#include <yahttp/router.hpp>
|
||||||
|
|
||||||
|
+using namespace boost::placeholders;
|
||||||
|
+
|
||||||
|
json11::Json HttpRequest::json()
|
||||||
|
{
|
||||||
|
string err;
|
||||||
|
--- a/ws-recursor.cc
|
||||||
|
+++ b/ws-recursor.cc
|
||||||
|
@@ -45,6 +45,7 @@
|
||||||
|
|
||||||
|
extern thread_local FDMultiplexer* t_fdm;
|
||||||
|
|
||||||
|
+using namespace boost::placeholders;
|
||||||
|
using json11::Json;
|
||||||
|
|
||||||
|
void productServerStatisticsFetch(map<string,string>& out)
|
Loading…
Reference in a new issue