node: upgrade to v20.9.0
node.js version 20.x is now active LTS. mipsel (pistachio) is no longer supported. Due to build difficulties, libuv shared libraries are not used. Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
This commit is contained in:
parent
2d864d2a6b
commit
3e51eef14c
14 changed files with 235 additions and 219 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=node
|
||||
PKG_VERSION:=v18.18.2
|
||||
PKG_VERSION:=v20.9.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
|
||||
PKG_HASH:=7249e2f0af943ec38599504f4b2a2bd31fb938787291b6ccca6c8badf01e3b56
|
||||
PKG_HASH:=a23d96810abf0455426b349d47ce5310f33095b7bc0571b9cc510f481c3a4519
|
||||
|
||||
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
@ -26,7 +26,6 @@ HOST_BUILD_PARALLEL:=1
|
|||
PKG_BUILD_DEPENDS:=python3/host
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_FLAGS:=no-mips16
|
||||
PKG_ASLR_PIE:=0
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
@ -38,8 +37,8 @@ define Package/node
|
|||
SUBMENU:=Node.js
|
||||
TITLE:=Node.js is a platform built on Chrome's JavaScript runtime
|
||||
URL:=https://nodejs.org/
|
||||
DEPENDS:=@HAS_FPU @(i386||x86_64||arm||aarch64||mipsel) \
|
||||
+libstdcpp +libopenssl +zlib +libnghttp2 +libuv \
|
||||
DEPENDS:=@HAS_FPU @(i386||x86_64||arm||aarch64) \
|
||||
+libstdcpp +libopenssl +zlib +libnghttp2 \
|
||||
+libcares +libatomic +NODEJS_ICU_SYSTEM:icu +NODEJS_ICU_SYSTEM:icu-full-data
|
||||
endef
|
||||
|
||||
|
@ -47,8 +46,9 @@ define Package/node/description
|
|||
Node.js® is a JavaScript runtime built on Chrome's V8 JavaScript engine. Node.js uses
|
||||
an event-driven, non-blocking I/O model that makes it lightweight and efficient. Node.js'
|
||||
package ecosystem, npm, is the largest ecosystem of open source libraries in the world.
|
||||
|
||||
*** The following preparations must be made on the host side. ***
|
||||
1. gcc 8.3 or higher is required.
|
||||
1. gcc 10.1 or higher is required.
|
||||
2. To build a 32-bit target, gcc-multilib, g++-multilib are required.
|
||||
3. Requires libatomic package. (If necessary, install the 32-bit library at the same time.)
|
||||
ex) sudo apt-get install gcc-multilib g++-multilib
|
||||
|
@ -115,7 +115,6 @@ CONFIGURE_ARGS:= \
|
|||
--shared-zlib \
|
||||
--shared-openssl \
|
||||
--shared-nghttp2 \
|
||||
--shared-libuv \
|
||||
--shared-cares \
|
||||
--with-intl=$(if $(CONFIG_NODEJS_ICU_SMALL),small-icu,$(if $(CONFIG_NODEJS_ICU_SYSTEM),system-icu,none)) \
|
||||
$(if $(findstring +neon",$(CONFIG_CPU_TYPE)),--with-arm-fpu=neon) \
|
||||
|
@ -157,7 +156,11 @@ define Package/node-npm/install
|
|||
endef
|
||||
|
||||
define Host/Install
|
||||
$(RM) -rf $(1)/lib/node_modules/npm
|
||||
rm -f $(1)/bin/npm
|
||||
rm -f $(1)/bin/npx
|
||||
rm -rf $(1)/lib/node_modules/npm
|
||||
rm -f $(1)/bin/corepack
|
||||
rm -rf $(1)/lib/node_modules/corepack
|
||||
$(call Host/Install/Default)
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/internal/modules/cjs/loader.js
|
||||
+++ b/lib/internal/modules/cjs/loader.js
|
||||
@@ -1391,7 +1391,8 @@ Module._initPaths = function() {
|
||||
@@ -1378,7 +1378,8 @@ Module._initPaths = function() {
|
||||
path.resolve(process.execPath, '..') :
|
||||
path.resolve(process.execPath, '..', '..');
|
||||
|
||||
|
|
|
@ -20,7 +20,7 @@
|
|||
result = clock_gettime(CLOCK_MONOTONIC, &ts);
|
||||
--- a/deps/v8/src/base/platform/platform-posix.cc
|
||||
+++ b/deps/v8/src/base/platform/platform-posix.cc
|
||||
@@ -1066,7 +1066,7 @@ bool Thread::Start() {
|
||||
@@ -1147,7 +1147,7 @@ bool Thread::Start() {
|
||||
#if V8_OS_DARWIN
|
||||
// Default on Mac OS X is 512kB -- bump up to 1MB
|
||||
stack_size = 1 * 1024 * 1024;
|
||||
|
|
10
lang/node/patches/200-uv_gyp.patch
Normal file
10
lang/node/patches/200-uv_gyp.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/deps/uv/uv.gyp
|
||||
+++ b/deps/uv/uv.gyp
|
||||
@@ -155,6 +155,7 @@
|
||||
'target_name': 'libuv',
|
||||
'toolsets': ['host', 'target'],
|
||||
'type': '<(uv_library)',
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'include',
|
||||
'src/',
|
10
lang/node/patches/201-zlib_gyp.patch
Normal file
10
lang/node/patches/201-zlib_gyp.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/deps/zlib/zlib.gyp
|
||||
+++ b/deps/zlib/zlib.gyp
|
||||
@@ -9,6 +9,7 @@
|
||||
'arm_fpu%': '',
|
||||
'llvm_version%': '0.0',
|
||||
},
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'conditions': [
|
||||
['use_system_zlib==0', {
|
||||
'targets': [
|
10
lang/node/patches/202-node_gyp.patch
Normal file
10
lang/node/patches/202-node_gyp.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/node.gyp
|
||||
+++ b/node.gyp
|
||||
@@ -1193,6 +1193,7 @@
|
||||
'dependencies': [
|
||||
'deps/simdutf/simdutf.gyp:simdutf#host',
|
||||
],
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'include_dirs': [
|
||||
'tools'
|
||||
],
|
|
@ -72,3 +72,35 @@
|
|||
'include_dirs': [
|
||||
'<(icu_path)/source/common',
|
||||
'<(icu_path)/source/i18n',
|
||||
@@ -418,6 +427,7 @@
|
||||
'target_name': 'genrb',
|
||||
'type': 'executable',
|
||||
'toolsets': [ 'host' ],
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools', 'icu_implementation' ],
|
||||
'sources': [
|
||||
'<@(icu_src_genrb)'
|
||||
@@ -440,6 +450,7 @@
|
||||
'target_name': 'iculslocs',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'iculslocs.cc',
|
||||
@@ -458,6 +469,7 @@
|
||||
'target_name': 'icupkg',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'<@(icu_src_icupkg)',
|
||||
@@ -475,6 +487,7 @@
|
||||
'target_name': 'genccode',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'<@(icu_src_genccode)',
|
158
lang/node/patches/204-v8_gyp.patch
Normal file
158
lang/node/patches/204-v8_gyp.patch
Normal file
|
@ -0,0 +1,158 @@
|
|||
--- a/tools/v8_gypfiles/v8.gyp
|
||||
+++ b/tools/v8_gypfiles/v8.gyp
|
||||
@@ -73,6 +73,7 @@
|
||||
],
|
||||
'hard_dependency': 1,
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
],
|
||||
@@ -194,6 +195,7 @@
|
||||
'<@(torque_outputs_cc)',
|
||||
'<@(torque_outputs_inc)',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
],
|
||||
@@ -215,6 +217,7 @@
|
||||
'sources': [
|
||||
'<(generate_bytecode_builtins_list_output)',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(generate_bytecode_output_root)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
@@ -252,6 +255,7 @@
|
||||
'sources': [
|
||||
'<(V8_ROOT)/src/init/setup-isolate-full.cc',
|
||||
],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
}, # v8_init
|
||||
{
|
||||
'target_name': 'v8_initializers',
|
||||
@@ -263,9 +267,11 @@
|
||||
'v8_shared_internal_headers',
|
||||
'v8_pch',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
'<(generate_bytecode_output_root)',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
'sources': [
|
||||
'<!@pymod_do_main(GN-scraper "<(V8_ROOT)/BUILD.gn" "\\"v8_initializers.*?sources = ")',
|
||||
@@ -689,6 +695,7 @@
|
||||
'toolsets': ['host', 'target'],
|
||||
'direct_dependent_settings': {
|
||||
'sources': ['<!@pymod_do_main(GN-scraper "<(V8_ROOT)/BUILD.gn" "v8_compiler_sources = ")'],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'conditions': [
|
||||
['v8_target_arch=="ia32"', {
|
||||
'sources': [
|
||||
@@ -797,6 +804,8 @@
|
||||
'target_name': 'v8_turboshaft',
|
||||
'type': 'static_library',
|
||||
'toolsets': ['host', 'target'],
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'dependencies': [
|
||||
'generate_bytecode_builtins_list',
|
||||
'run_torque',
|
||||
@@ -821,6 +830,7 @@
|
||||
'run_torque',
|
||||
'v8_maybe_icu',
|
||||
],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'conditions': [
|
||||
['(is_component_build and not v8_optimized_debug and v8_enable_fast_mksnapshot) or v8_enable_turbofan==0', {
|
||||
'dependencies': [
|
||||
@@ -861,6 +871,7 @@
|
||||
],
|
||||
'includes': ['inspector.gypi'],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(generate_bytecode_output_root)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
@@ -1474,6 +1485,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1494,6 +1506,7 @@
|
||||
{
|
||||
'target_name': 'bytecode_builtins_list_generator',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1522,6 +1535,9 @@
|
||||
{
|
||||
'target_name': 'mksnapshot',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'dependencies': [
|
||||
'v8_base_without_compiler',
|
||||
'v8_compiler_for_mksnapshot',
|
||||
@@ -1549,6 +1565,7 @@
|
||||
{
|
||||
'target_name': 'torque',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [
|
||||
'torque_base',
|
||||
# "build/win:default_exe_manifest",
|
||||
@@ -1591,6 +1608,7 @@
|
||||
{
|
||||
'target_name': 'torque-language-server',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1622,6 +1640,8 @@
|
||||
{
|
||||
'target_name': 'gen-regexp-special-case',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
|
||||
'dependencies': [
|
||||
'v8_libbase',
|
||||
# "build/win:default_exe_manifest",
|
||||
@@ -1840,6 +1860,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1961,15 +1982,19 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/third_party/zlib',
|
||||
'<(V8_ROOT)/third_party/zlib/google',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
},
|
||||
'defines': [ 'ZLIB_IMPLEMENTATION' ],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/third_party/zlib',
|
||||
'<(V8_ROOT)/third_party/zlib/google',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
'sources': [
|
||||
'<(V8_ROOT)/third_party/zlib/adler32.c',
|
|
@ -1,78 +0,0 @@
|
|||
--- a/tools/icu/icu-generic.gyp
|
||||
+++ b/tools/icu/icu-generic.gyp
|
||||
@@ -418,6 +418,7 @@
|
||||
'target_name': 'genrb',
|
||||
'type': 'executable',
|
||||
'toolsets': [ 'host' ],
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools', 'icu_implementation' ],
|
||||
'sources': [
|
||||
'<@(icu_src_genrb)'
|
||||
@@ -440,6 +441,7 @@
|
||||
'target_name': 'iculslocs',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'iculslocs.cc',
|
||||
@@ -458,6 +460,7 @@
|
||||
'target_name': 'icupkg',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'<@(icu_src_icupkg)',
|
||||
@@ -475,6 +478,7 @@
|
||||
'target_name': 'genccode',
|
||||
'toolsets': [ 'host' ],
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'<@(icu_src_genccode)',
|
||||
--- a/tools/v8_gypfiles/v8.gyp
|
||||
+++ b/tools/v8_gypfiles/v8.gyp
|
||||
@@ -1397,6 +1397,7 @@
|
||||
{
|
||||
'target_name': 'bytecode_builtins_list_generator',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1425,6 +1426,8 @@
|
||||
{
|
||||
'target_name': 'mksnapshot',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
|
||||
'dependencies': [
|
||||
'v8_base_without_compiler',
|
||||
'v8_compiler_for_mksnapshot',
|
||||
@@ -1458,6 +1461,7 @@
|
||||
{
|
||||
'target_name': 'torque',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'dependencies': [
|
||||
'torque_base',
|
||||
# "build/win:default_exe_manifest",
|
||||
@@ -1500,6 +1504,7 @@
|
||||
{
|
||||
'target_name': 'torque-language-server',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1531,6 +1536,8 @@
|
||||
{
|
||||
'target_name': 'gen-regexp-special-case',
|
||||
'type': 'executable',
|
||||
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
+ 'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
|
||||
'dependencies': [
|
||||
'v8_libbase',
|
||||
# "build/win:default_exe_manifest",
|
|
@ -1,92 +0,0 @@
|
|||
--- a/deps/zlib/zlib.gyp
|
||||
+++ b/deps/zlib/zlib.gyp
|
||||
@@ -9,6 +9,7 @@
|
||||
'arm_fpu%': '',
|
||||
'llvm_version%': '0.0',
|
||||
},
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'conditions': [
|
||||
['use_system_zlib==0', {
|
||||
'targets': [
|
||||
--- a/tools/v8_gypfiles/v8.gyp
|
||||
+++ b/tools/v8_gypfiles/v8.gyp
|
||||
@@ -60,6 +60,7 @@
|
||||
],
|
||||
'hard_dependency': 1,
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
],
|
||||
@@ -181,6 +182,7 @@
|
||||
'<@(torque_outputs_cc)',
|
||||
'<@(torque_outputs_inc)',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
],
|
||||
@@ -202,6 +204,7 @@
|
||||
'sources': [
|
||||
'<(generate_bytecode_builtins_list_output)',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(generate_bytecode_output_root)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
@@ -249,9 +252,11 @@
|
||||
'v8_base_without_compiler',
|
||||
'v8_shared_internal_headers',
|
||||
],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
'<(generate_bytecode_output_root)',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
'sources': [
|
||||
'<!@pymod_do_main(GN-scraper "<(V8_ROOT)/BUILD.gn" "\\"v8_initializers.*?sources = ")',
|
||||
@@ -769,6 +774,7 @@
|
||||
],
|
||||
'includes': ['inspector.gypi'],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(generate_bytecode_output_root)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
@@ -1377,6 +1383,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1761,6 +1768,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1941,15 +1949,19 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/third_party/zlib',
|
||||
'<(V8_ROOT)/third_party/zlib/google',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
},
|
||||
'defines': [ 'ZLIB_IMPLEMENTATION' ],
|
||||
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
|
||||
'include_dirs': [
|
||||
'<(V8_ROOT)/third_party/zlib',
|
||||
'<(V8_ROOT)/third_party/zlib/google',
|
||||
+ '<!@(echo "$STAGING_DIR"/usr/../usr/include)',
|
||||
],
|
||||
'sources': [
|
||||
'<(V8_ROOT)/third_party/zlib/adler32.c',
|
|
@ -1,26 +0,0 @@
|
|||
--- a/tools/v8_gypfiles/v8.gyp
|
||||
+++ b/tools/v8_gypfiles/v8.gyp
|
||||
@@ -242,6 +242,7 @@
|
||||
'sources': [
|
||||
'<(V8_ROOT)/src/init/setup-isolate-full.cc',
|
||||
],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
}, # v8_init
|
||||
{
|
||||
'target_name': 'v8_initializers',
|
||||
@@ -714,6 +715,7 @@
|
||||
'v8_shared_internal_headers',
|
||||
],
|
||||
'sources': ['<@(v8_compiler_sources)'],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'conditions': [
|
||||
['OS=="win"', {
|
||||
'msvs_precompiled_header': '<(V8_ROOT)/../../tools/msvs/pch/v8_pch.h',
|
||||
@@ -1435,6 +1437,7 @@
|
||||
'type': 'executable',
|
||||
'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
|
||||
'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
|
||||
+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
|
||||
'dependencies': [
|
||||
'v8_base_without_compiler',
|
||||
'v8_compiler_for_mksnapshot',
|
|
@ -1,11 +0,0 @@
|
|||
--- a/deps/v8/src/compiler/backend/mips/code-generator-mips.cc
|
||||
+++ b/deps/v8/src/compiler/backend/mips/code-generator-mips.cc
|
||||
@@ -4101,7 +4101,7 @@ void CodeGenerator::AssembleReturn(Instr
|
||||
} else if (FLAG_debug_code) {
|
||||
__ Assert(eq, AbortReason::kUnexpectedAdditionalPopValue,
|
||||
g.ToRegister(additional_pop_count),
|
||||
- Operand(static_cast<int64_t>(0)));
|
||||
+ Operand(static_cast<int32_t>(0)));
|
||||
}
|
||||
}
|
||||
// Functions with JS linkage have at least one parameter (the receiver).
|
|
@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
|
|||
//
|
||||
// Permission is hereby granted, free of charge, to any person obtaining a
|
||||
// copy of this software and associated documentation files (the
|
||||
@@ -1321,13 +1322,6 @@ function lookupAndConnect(self, options)
|
||||
@@ -1330,13 +1331,6 @@ function lookupAndConnect(self, options)
|
||||
hints: options.hints || 0,
|
||||
};
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -1291,7 +1291,6 @@ def configure_node(o):
|
||||
@@ -1270,7 +1270,6 @@ def configure_node(o):
|
||||
|
||||
# Enable branch protection for arm64
|
||||
if target_arch == 'arm64':
|
||||
|
|
Loading…
Reference in a new issue