Merge pull request #8394 from EricLuehrsen/unbound_191
unbound: update to 1.9.1 and remove upstream patches
This commit is contained in:
commit
3e469f33e1
3 changed files with 2 additions and 75 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=unbound
|
||||
PKG_VERSION:=1.9.0
|
||||
PKG_VERSION:=1.9.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
@ -17,7 +17,7 @@ PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@gmail.com>
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.unbound.net/downloads
|
||||
PKG_HASH:=415af94b8392bc6b2c52e44ac8f17935cc6ddf2cc81edfb47c5be4ad205ab917
|
||||
PKG_HASH:=c3c0bf9b86ccba4ca64f93dd4fe7351308ab54293f297a67de5a8914c1dc59c5
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
--- a/util/net_help.c
|
||||
+++ b/util/net_help.c
|
||||
@@ -1049,10 +1049,10 @@ void* outgoing_ssl_fd(void* sslctx, int
|
||||
static lock_basic_type *ub_openssl_locks = NULL;
|
||||
|
||||
/** callback that gets thread id for openssl */
|
||||
-static unsigned long
|
||||
-ub_crypto_id_cb(void)
|
||||
+static void
|
||||
+ub_crypto_id_cb(CRYPTO_THREADID *id)
|
||||
{
|
||||
- return (unsigned long)log_thread_get();
|
||||
+ CRYPTO_THREADID_set_numeric(id, (unsigned long)log_thread_get());
|
||||
}
|
||||
|
||||
static void
|
||||
@@ -1078,7 +1078,7 @@ int ub_openssl_lock_init(void)
|
||||
for(i=0; i<CRYPTO_num_locks(); i++) {
|
||||
lock_basic_init(&ub_openssl_locks[i]);
|
||||
}
|
||||
- CRYPTO_set_id_callback(&ub_crypto_id_cb);
|
||||
+ CRYPTO_THREADID_set_callback(&ub_crypto_id_cb);
|
||||
CRYPTO_set_locking_callback(&ub_crypto_lock_cb);
|
||||
#endif /* OPENSSL_THREADS */
|
||||
return 1;
|
||||
@@ -1090,7 +1090,7 @@ void ub_openssl_lock_delete(void)
|
||||
int i;
|
||||
if(!ub_openssl_locks)
|
||||
return;
|
||||
- CRYPTO_set_id_callback(NULL);
|
||||
+ CRYPTO_THREADID_set_callback(NULL);
|
||||
CRYPTO_set_locking_callback(NULL);
|
||||
for(i=0; i<CRYPTO_num_locks(); i++) {
|
||||
lock_basic_destroy(&ub_openssl_locks[i]);
|
|
@ -1,39 +0,0 @@
|
|||
Index: daemon/remote.c
|
||||
===================================================================
|
||||
--- a/daemon/remote.c (revision 5105)
|
||||
+++ b/daemon/remote.c (working copy)
|
||||
@@ -1987,7 +1987,7 @@
|
||||
return NULL;
|
||||
}
|
||||
} else {
|
||||
-#ifndef HAVE_SSL_SET1_HOST
|
||||
+#if ! defined(HAVE_SSL_SET1_HOST) && ! defined(HAVE_X509_VERIFY_PARAM_SET1_HOST)
|
||||
if(auth_name)
|
||||
log_err("no name verification functionality in "
|
||||
"ssl library, ignored name for %s", todo);
|
||||
Index: iterator/iter_fwd.c
|
||||
===================================================================
|
||||
--- a/iterator/iter_fwd.c (revision 5105)
|
||||
+++ b/iterator/iter_fwd.c (working copy)
|
||||
@@ -239,7 +239,7 @@
|
||||
s->name, p->str);
|
||||
return 0;
|
||||
}
|
||||
-#ifndef HAVE_SSL_SET1_HOST
|
||||
+#if ! defined(HAVE_SSL_SET1_HOST) && ! defined(HAVE_X509_VERIFY_PARAM_SET1_HOST)
|
||||
if(tls_auth_name)
|
||||
log_err("no name verification functionality in "
|
||||
"ssl library, ignored name for %s", p->str);
|
||||
Index: iterator/iter_hints.c
|
||||
===================================================================
|
||||
--- a/iterator/iter_hints.c (revision 5105)
|
||||
+++ b/iterator/iter_hints.c (working copy)
|
||||
@@ -252,7 +252,7 @@
|
||||
s->name, p->str);
|
||||
return 0;
|
||||
}
|
||||
-#ifndef HAVE_SSL_SET1_HOST
|
||||
+#if ! defined(HAVE_SSL_SET1_HOST) && ! defined(HAVE_X509_VERIFY_PARAM_SET1_HOST)
|
||||
if(auth_name)
|
||||
log_err("no name verification functionality in "
|
||||
"ssl library, ignored name for %s", p->str);
|
Loading…
Reference in a new issue