shadowsocks-libev: fix compilation with GCC10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
371d7b3892
commit
3d9618c61b
2 changed files with 21 additions and 1 deletions
|
@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
|
||||||
#
|
#
|
||||||
PKG_NAME:=shadowsocks-libev
|
PKG_NAME:=shadowsocks-libev
|
||||||
PKG_VERSION:=3.3.4
|
PKG_VERSION:=3.3.4
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=4
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
|
||||||
|
|
20
net/shadowsocks-libev/patches/010-gcc10.patch
Normal file
20
net/shadowsocks-libev/patches/010-gcc10.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
--- a/src/http.h
|
||||||
|
+++ b/src/http.h
|
||||||
|
@@ -29,6 +29,6 @@
|
||||||
|
#include <stdio.h>
|
||||||
|
#include "protocol.h"
|
||||||
|
|
||||||
|
-const protocol_t *const http_protocol;
|
||||||
|
+extern const protocol_t *const http_protocol;
|
||||||
|
|
||||||
|
#endif
|
||||||
|
--- a/src/tls.h
|
||||||
|
+++ b/src/tls.h
|
||||||
|
@@ -28,6 +28,6 @@
|
||||||
|
|
||||||
|
#include "protocol.h"
|
||||||
|
|
||||||
|
-const protocol_t *const tls_protocol;
|
||||||
|
+extern const protocol_t *const tls_protocol;
|
||||||
|
|
||||||
|
#endif
|
Loading…
Reference in a new issue