Merge pull request #6111 from cotequeiroz/nail_openssl-1.1
nail: add compatibility with openssl 1.1
This commit is contained in:
commit
3d266d27df
3 changed files with 16 additions and 2 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=nail
|
||||
PKG_VERSION:=12.5
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
|
||||
PKG_SOURCE:=heirloom-mailx_$(PKG_VERSION).orig.tar.gz
|
||||
|
|
|
@ -4,7 +4,7 @@
|
|||
|
||||
cp = ssl_method_string(uhp);
|
||||
if (cp != NULL) {
|
||||
+#ifndef OPENSSL_NO_SSL2
|
||||
+#if !defined(OPENSSL_NO_SSL2) && !OPENSSL_VERSION_NUMBER >= 0x10100000L
|
||||
if (equal(cp, "ssl2"))
|
||||
method = SSLv2_client_method();
|
||||
- else if (equal(cp, "ssl3"))
|
||||
|
|
14
mail/nail/patches/200-handle-openssl-no-egd.patch
Normal file
14
mail/nail/patches/200-handle-openssl-no-egd.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/openssl.c
|
||||
+++ b/openssl.c
|
||||
@@ -137,7 +137,11 @@ ssl_rand_init(void)
|
||||
|
||||
if ((cp = value("ssl-rand-egd")) != NULL) {
|
||||
cp = expand(cp);
|
||||
+#ifndef OPENSSL_NO_EGD
|
||||
if (RAND_egd(cp) == -1) {
|
||||
+#else
|
||||
+ if (1) {
|
||||
+#endif
|
||||
fprintf(stderr, catgets(catd, CATSET, 245,
|
||||
"entropy daemon at \"%s\" not available\n"),
|
||||
cp);
|
Loading…
Reference in a new issue