Merge pull request #12503 from Andy2244/samba-4.11.9-(19-07)
[19.07] samba4: update to 4.11.9
This commit is contained in:
commit
3ca5acd880
3 changed files with 8 additions and 26 deletions
|
@ -2,7 +2,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=samba
|
||||
PKG_VERSION:=4.11.6
|
||||
PKG_VERSION:=4.11.9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -13,7 +13,7 @@ PKG_SOURCE_URL:= \
|
|||
http://www.nic.funet.fi/index/samba/pub/samba/stable/ \
|
||||
http://samba.mirror.bit.nl/samba/ftp/stable/ \
|
||||
https://download.samba.org/pub/samba/stable/
|
||||
PKG_HASH:=91438f4d7b71f673421435fa7f26b03b613f214139636ce50af35bc2ff09ef38
|
||||
PKG_HASH:=ad8cef354cf3f3a8835b04c896906b839270bee763d941db52af037ab5ec8dcc
|
||||
|
||||
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0-only
|
||||
|
@ -21,8 +21,8 @@ PKG_LICENSE_FILES:=COPYING
|
|||
PKG_CPE_ID:=cpe:/a:samba:samba
|
||||
|
||||
# samba4=(asn1_compile,compile_et) rpcsvc-proto=(rpcgen)
|
||||
HOST_BUILD_DEPENDS:=python3/host perl/host
|
||||
PKG_BUILD_DEPENDS:=samba4/host libtasn1/host rpcsvc-proto/host
|
||||
HOST_BUILD_DEPENDS:=python3/host rpcsvc-proto/host perl/host
|
||||
PKG_BUILD_DEPENDS:=samba4/host libtasn1/host
|
||||
|
||||
PKG_CONFIG_DEPENDS:= \
|
||||
CONFIG_SAMBA4_SERVER_NETBIOS \
|
||||
|
@ -33,12 +33,13 @@ PKG_CONFIG_DEPENDS:= \
|
|||
CONFIG_PACKAGE_kmod-fs-btrfs \
|
||||
CONFIG_PACKAGE_kmod-fs-xfs
|
||||
|
||||
PYTHON3_PKG_BUILD:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
include $(INCLUDE_DIR)/version.mk
|
||||
include ../../lang/python/python3-host.mk
|
||||
#include ../../lang/python/python-package.mk
|
||||
include ../../lang/python/python3-package.mk
|
||||
|
||||
define Package/samba4/Default
|
||||
|
|
|
@ -50,6 +50,8 @@ smb_header() {
|
|||
printf "\n######### Dynamic written config options #########\n"
|
||||
if [ "$DISABLE_NETBIOS" -eq 1 ] || [ ! -x /usr/sbin/nmbd ]; then
|
||||
printf "\tdisable netbios = yes\n"
|
||||
# note: samba opens port 139 even if netbios is disabled via option above, so adjust listening ports
|
||||
printf "\tsmb ports = 445\n"
|
||||
fi
|
||||
|
||||
if [ "$DISABLE_ASYNC_IO" -eq 1 ]; then
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- a/source3/modules/vfs_fruit.c 2019-07-09
|
||||
+++ b/source3/modules/vfs_fruit.c 2019-07-09
|
||||
@@ -6995,12 +6995,12 @@ static bool fruit_tmsize_do_dirent(vfs_h
|
||||
return true;
|
||||
}
|
||||
|
||||
- if (bandsize > SIZE_MAX/nbands) {
|
||||
- DBG_ERR("tmsize overflow: bandsize [%zu] nbands [%zu]\n",
|
||||
- bandsize, nbands);
|
||||
- return false;
|
||||
- }
|
||||
- tm_size = bandsize * nbands;
|
||||
+ // if (bandsize > SIZE_MAX/nbands) {
|
||||
+ // DBG_ERR("tmsize overflow: bandsize [%zu] nbands [%zu]\n",
|
||||
+ // bandsize, nbands);
|
||||
+ // return false;
|
||||
+ // }
|
||||
+ tm_size = (off_t)bandsize * (off_t)nbands;
|
||||
|
||||
if (state->total_size + tm_size < state->total_size) {
|
||||
DBG_ERR("tmsize overflow: bandsize [%zu] nbands [%zu]\n",
|
Loading…
Reference in a new issue