Merge pull request #8645 from sartura/protobuf-c-x86-build-fail-fix
protobuf-c: fix x86 build fail
This commit is contained in:
commit
3bd227ab21
2 changed files with 14 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libprotobuf-c
|
PKG_NAME:=libprotobuf-c
|
||||||
PKG_VERSION:=1.3.1
|
PKG_VERSION:=1.3.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)
|
||||||
|
|
|
@ -0,0 +1,13 @@
|
||||||
|
Index: protobuf-c-1.3.1/t/generated-code2/cxx-generate-packed-data.cc
|
||||||
|
===================================================================
|
||||||
|
--- protobuf-c-1.3.1.orig/t/generated-code2/cxx-generate-packed-data.cc
|
||||||
|
+++ protobuf-c-1.3.1/t/generated-code2/cxx-generate-packed-data.cc
|
||||||
|
@@ -998,7 +998,7 @@ static void dump_test_packed_repeated_en
|
||||||
|
static void dump_test_unknown_fields (void)
|
||||||
|
{
|
||||||
|
EmptyMess mess;
|
||||||
|
- const google::protobuf::Message::Reflection *reflection = mess.GetReflection();
|
||||||
|
+ const google::protobuf::Reflection *reflection = mess.GetReflection();
|
||||||
|
google::protobuf::UnknownFieldSet *fs = reflection->MutableUnknownFields(&mess);
|
||||||
|
|
||||||
|
#if GOOGLE_PROTOBUF_VERSION >= 2001000
|
Loading…
Reference in a new issue