minizip: update to 3.0.0
Switch to new upstream and switch package name. Further disable features to avoid extra dependencies. Build with PIC to avoid build failures with mips16. Remove no longer needed patch. Upstream fixed it differently. Use AUTORELEASE for simplicity. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
937a733854
commit
3b812f93d6
2 changed files with 13 additions and 57 deletions
|
@ -6,13 +6,13 @@
|
|||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=minizip
|
||||
PKG_VERSION:=2.9.3
|
||||
PKG_RELEASE:=3
|
||||
PKG_NAME:=minizip-ng
|
||||
PKG_VERSION:=3.0.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/nmoinvaz/minizip/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=f64b2d228a03673a8ec36a53402e2108437226fd9170d49b7f0c0bca94708b93
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/zlib-ng/minizip-ng/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=13b4afd96fbf2456f441a32dc9f5d3c983a5ece9e6a3903fc9322c8ad5518546
|
||||
|
||||
PKG_MAINTAINER:=David Woodhouse <dwmw2@infradead.org>
|
||||
PKG_LICENSE:=Zlib
|
||||
|
@ -24,11 +24,17 @@ include $(INCLUDE_DIR)/package.mk
|
|||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
||||
CMAKE_OPTIONS += \
|
||||
-DCMAKE_POSITION_INDEPENDENT_CODE=ON \
|
||||
-DINSTALL_INC_DIR=/usr/include/minizip \
|
||||
-DBUILD_SHARED_LIBS=ON \
|
||||
-DMZ_BZIP2=OFF \
|
||||
-DMZ_LIBBSD=OFF
|
||||
|
||||
-DMZ_COMPAT=OFF \
|
||||
-DMZ_ICONV=OFF \
|
||||
-DMZ_LIBBSD=OFF \
|
||||
-DMZ_LZMA=OFF \
|
||||
-DMZ_OPENSSL=OFF \
|
||||
-DMZ_PKCRYPT=OFF \
|
||||
-DMZ_ZSTD=OFF
|
||||
|
||||
define Package/minizip
|
||||
TITLE:=Fork of the popular zip manipulation library found in the zlib distribution
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
From 3d94e052f987bc35452592acf9f6fcb0d4ee4db4 Mon Sep 17 00:00:00 2001
|
||||
From: David Woodhouse <dwmw2@infradead.org>
|
||||
Date: Wed, 10 Jun 2020 11:39:17 +0100
|
||||
Subject: [PATCH] Allow libbsd to be explicitly disabled
|
||||
|
||||
When building for a minimal environment like OpenWRT we want to avoid the
|
||||
dependency on libbsd even if it did happen to be built and available in
|
||||
the buildroot at the time minizip is compiled.
|
||||
|
||||
https://github.com/openwrt/packages/issues/12471
|
||||
---
|
||||
CMakeLists.txt | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -17,6 +17,7 @@ option(MZ_PKCRYPT "Enables PKWARE tradit
|
||||
option(MZ_WZAES "Enables WinZIP AES encryption" ON)
|
||||
option(MZ_LIBCOMP "Enables Apple compression" OFF)
|
||||
option(MZ_OPENSSL "Enables OpenSSL for encryption" OFF)
|
||||
+option(MZ_LIBBSD "Enable libbsd random functionality" ON)
|
||||
option(MZ_BRG "Enables Brian Gladman's encryption library" OFF)
|
||||
option(MZ_SIGNING "Enables zip signing support" ON)
|
||||
option(MZ_COMPRESS_ONLY "Only support compression" OFF)
|
||||
@@ -298,7 +299,7 @@ if(UNIX)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
- if(NOT HAVE_ARC4RANDOM_BUF)
|
||||
+ if(MZ_LIBBSD AND NOT HAVE_ARC4RANDOM_BUF)
|
||||
find_package(PkgConfig REQUIRED)
|
||||
|
||||
pkg_check_modules(LIBBSD libbsd)
|
||||
@@ -311,6 +312,8 @@ if(UNIX)
|
||||
list(APPEND MINIZIP_INC ${LIBBSD_INCLUDE_DIRS})
|
||||
link_directories(${LIBBSD_LIBRARY_DIRS})
|
||||
endif()
|
||||
+ else()
|
||||
+ set(MZ_LIBBSD FALSE)
|
||||
endif()
|
||||
endif()
|
||||
endif()
|
||||
@@ -943,6 +946,7 @@ add_feature_info(MZ_PKCRYPT MZ_PKCRYPT "
|
||||
add_feature_info(MZ_WZAES MZ_WZAES "Enables WinZIP AES encryption")
|
||||
add_feature_info(MZ_LIBCOMP MZ_LIBCOMP "Enables Apple compression")
|
||||
add_feature_info(MZ_OPENSSL MZ_OPENSSL "Enables OpenSSL for encryption")
|
||||
+add_feature_info(MZ_LIBBSD MZ_LIBBSD "Build with libbsd for random functionality")
|
||||
add_feature_info(MZ_BRG MZ_BRG "Enables Brian Gladman's encryption library")
|
||||
add_feature_info(MZ_SIGNING MZ_SIGNING "Enables zip signing support")
|
||||
add_feature_info(MZ_COMPRESS_ONLY MZ_COMPRESS_ONLY "Only support compression")
|
Loading…
Reference in a new issue