quasselc: fix compilation with newer glib2
Needed to fix LDFLAGS variable.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 030cc5570c
)
This commit is contained in:
parent
2c6155c9c3
commit
3b285bfaaa
2 changed files with 17 additions and 2 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=quasselc
|
||||
PKG_SOURCE_DATE:=2017-01-11
|
||||
PKG_SOURCE_VERSION:=a0a1e6bd87d3eac68b5369972d1c2035cfe47e94
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/phhusson/QuasselC/tar.gz/$(PKG_SOURCE_VERSION)?
|
||||
|
@ -43,6 +43,8 @@ define Package/quasselc/description
|
|||
An implementation of the Quassel protocol in pure C.
|
||||
endef
|
||||
|
||||
TARGET_LDFLAGS += -liconv
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/quasselc
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/quasselc/* $(1)/usr/include/quasselc/
|
||||
|
|
|
@ -10,7 +10,20 @@
|
|||
VERSION = 0
|
||||
INSTALL = install
|
||||
-LDLIBS:=$(shell pkg-config glib-2.0 --libs) -lz
|
||||
+LDLIBS+=$(shell pkg-config glib-2.0 --libs) -lz
|
||||
+LDFLAGS+=$(shell pkg-config glib-2.0 --libs) -lz
|
||||
|
||||
BOTLIBS := -Wl,-rpath,.
|
||||
|
||||
@@ -15,10 +15,10 @@ lib_objects=setters.o getters.o main.o cmds.o negotiation.o io.o symbols.o
|
||||
all: bot libquasselc.so.$(VERSION) quasselc.pc
|
||||
|
||||
libquasselc.so.$(VERSION): $(lib_objects)
|
||||
- $(CC) -shared -o $@ -Wl,-soname,libquasselc.so.$(SO_VERSION) $^ $(LDLIBS)
|
||||
+ $(CC) -shared -o $@ -Wl,-soname,libquasselc.so.$(SO_VERSION) $^ $(LDFLAGS)
|
||||
|
||||
bot: bot.o display.o libquasselc.so.$(VERSION)
|
||||
- $(CC) -o $@ $^ $(LDLIBS) $(BOTLIBS)
|
||||
+ $(CC) -o $@ $^ $(LDFLAGS) $(BOTLIBS)
|
||||
|
||||
clean:
|
||||
rm -f *.o bot libquasselc.so.$(VERSION) quasselc.pc
|
||||
|
|
Loading…
Reference in a new issue