lvm2: update to version 2.03.14
Drop two local patches which were replaced by upstream commits.
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit 74969337cf
)
This commit is contained in:
parent
bc5bb12547
commit
3b0f19d6d2
4 changed files with 6 additions and 52 deletions
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=LVM2
|
||||
PKG_VERSION:=2.03.13
|
||||
PKG_VERSION:=2.03.14
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=https://sourceware.org/pub/lvm2
|
||||
PKG_HASH:=296b9c8769e6b5b8e81128a1c0aeb58e6da1f0fcf97dba90ad3f005ece53a568
|
||||
PKG_HASH:=4a63bc8a084a8ae3c7bc5e6530cac264139d218575c64416c8b99e3fe039a05c
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/lvm2-$(BUILD_VARIANT)/$(PKG_NAME).$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/commands/toolcontext.c
|
||||
+++ b/lib/commands/toolcontext.c
|
||||
@@ -1627,7 +1627,7 @@ struct cmd_context *create_toolcontext(u
|
||||
@@ -1677,7 +1677,7 @@ struct cmd_context *create_toolcontext(u
|
||||
/* FIXME Make this configurable? */
|
||||
reset_lvm_errno(1);
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
/* Set in/out stream buffering before glibc */
|
||||
if (set_buffering
|
||||
#ifdef SYS_gettid
|
||||
@@ -2014,7 +2014,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
@@ -2064,7 +2064,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
|
||||
if (cmd->pending_delete_mem)
|
||||
dm_pool_destroy(cmd->pending_delete_mem);
|
||||
|
@ -20,7 +20,7 @@
|
|||
if (is_valid_fd(STDIN_FILENO) &&
|
||||
--- a/tools/lvmcmdline.c
|
||||
+++ b/tools/lvmcmdline.c
|
||||
@@ -3349,6 +3349,7 @@ int lvm_split(char *str, int *argc, char
|
||||
@@ -3381,6 +3381,7 @@ int lvm_split(char *str, int *argc, char
|
||||
/* Make sure we have always valid filedescriptors 0,1,2 */
|
||||
static int _check_standard_fds(void)
|
||||
{
|
||||
|
@ -28,7 +28,7 @@
|
|||
int err = is_valid_fd(STDERR_FILENO);
|
||||
|
||||
if (!is_valid_fd(STDIN_FILENO) &&
|
||||
@@ -3375,6 +3376,12 @@ static int _check_standard_fds(void)
|
||||
@@ -3407,6 +3408,12 @@ static int _check_standard_fds(void)
|
||||
strerror(errno));
|
||||
return 0;
|
||||
}
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
From a887fe76be459d32a638d0abde96cc715632c8d5 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Golle <daniel@makrotopia.org>
|
||||
Date: Fri, 20 May 2016 06:31:15 +0200
|
||||
Subject: [PATCH] device: include goto lable as well
|
||||
To: lvm-devel@redhat.com
|
||||
|
||||
commit b5314c2a6ae5fe4f802e82a4f31cf2fad398ded9
|
||||
device: Retry open without O_NOATIME if it fails.
|
||||
|
||||
makes use of goto lable 'opened:' but that might not be defined, e.g.
|
||||
on standard C libraries without O_DIRECT_SUPPORT.
|
||||
---
|
||||
lib/device/dev-io.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/lib/device/dev-io.c
|
||||
+++ b/lib/device/dev-io.c
|
||||
@@ -380,7 +380,7 @@ int dev_open_flags(struct device *dev, i
|
||||
return 0;
|
||||
}
|
||||
|
||||
-#ifdef O_DIRECT_SUPPORT
|
||||
+#if defined(O_DIRECT_SUPPORT) || defined(O_NOATIME)
|
||||
opened:
|
||||
if (direct)
|
||||
dev->flags |= DEV_O_DIRECT_TESTED;
|
|
@ -1,20 +0,0 @@
|
|||
--- a/lib/device/dev-cache.c
|
||||
+++ b/lib/device/dev-cache.c
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <unistd.h>
|
||||
#include <dirent.h>
|
||||
#include <locale.h>
|
||||
+#include <sys/file.h>
|
||||
|
||||
struct dev_iter {
|
||||
struct btree_iter *current;
|
||||
--- a/tools/lvmdevices.c
|
||||
+++ b/tools/lvmdevices.c
|
||||
@@ -16,6 +16,7 @@
|
||||
#include "lib/cache/lvmcache.h"
|
||||
#include "lib/device/device_id.h"
|
||||
#include "lib/device/dev-type.h"
|
||||
+#include <sys/file.h>
|
||||
|
||||
static void _search_devs_for_pvids(struct cmd_context *cmd, struct dm_list *search_pvids, struct dm_list *found_devs)
|
||||
{
|
Loading…
Reference in a new issue