Merge pull request #11724 from jefferyto/python2-remove-plugins
treewide: Remove Python 2 plugin/bindings/etc from non-Python packages
This commit is contained in:
commit
3ad79d83d7
11 changed files with 15 additions and 219 deletions
|
@ -64,7 +64,6 @@ This package provides the following run-time libraries:
|
|||
- log
|
||||
- math
|
||||
- program_options
|
||||
- python
|
||||
- python3
|
||||
- random
|
||||
- regex
|
||||
|
@ -80,10 +79,7 @@ There are many more header-only libraries supported by Boost.
|
|||
See more at http://www.boost.org/doc/libs/1_72_0/
|
||||
endef
|
||||
|
||||
PKG_BUILD_DEPENDS:=boost/host PACKAGE_python:python PACKAGE_python3:python3
|
||||
|
||||
include ../../lang/python/python-version.mk
|
||||
BOOST_PYTHON_VER=$(PYTHON_VERSION)
|
||||
PKG_BUILD_DEPENDS:=boost/host PACKAGE_python3:python3
|
||||
|
||||
include ../../lang/python/python3-version.mk
|
||||
BOOST_PYTHON3_VER=$(PYTHON3_VERSION)
|
||||
|
@ -283,10 +279,10 @@ define Package/boost/config
|
|||
|
||||
$(foreach lib,$(BOOST_LIBS), \
|
||||
config PACKAGE_boost-$(lib)
|
||||
prompt "Boost $(lib) $(if $(findstring python,$(lib)),$(paren_left)v$(if $(findstring 3,$(lib)),$(BOOST_PYTHON3_VER),$(BOOST_PYTHON_VER))$(paren_right) ,)library."
|
||||
prompt "Boost $(lib) $(if $(findstring python3,$(lib)),$(paren_left)v$(BOOST_PYTHON3_VER)$(paren_right) ,)library."
|
||||
default m if ALL
|
||||
$(if $(findstring locale,$(lib)),depends on BUILD_NLS,)\
|
||||
$(if $(findstring python,$(lib)),depends on PACKAGE_$(lib),)\
|
||||
$(if $(findstring python3,$(lib)),depends on PACKAGE_python3,)\
|
||||
$(if $(findstring fiber,$(lib)),depends on !boost-fiber-exclude,)\
|
||||
$(if $(findstring context,$(lib)),depends on !boost-context-exclude,)
|
||||
$(if $(findstring coroutine,$(lib)),depends on !boost-coroutine-exclude,)
|
||||
|
@ -346,7 +342,6 @@ $(eval $(call DefineBoostLibrary,log,system chrono date_time thread filesystem r
|
|||
$(eval $(call DefineBoostLibrary,math))
|
||||
#$(eval $(call DefineBoostLibrary,mpi,,)) # OpenMPI does no exist in OpenWRT at this time.
|
||||
$(eval $(call DefineBoostLibrary,program_options))
|
||||
$(eval $(call DefineBoostLibrary,python,,,PACKAGE_python))
|
||||
$(eval $(call DefineBoostLibrary,python3,,,PACKAGE_python3))
|
||||
$(eval $(call DefineBoostLibrary,random,system))
|
||||
$(eval $(call DefineBoostLibrary,regex))
|
||||
|
@ -425,7 +420,7 @@ define Build/Compile
|
|||
$(if $(CONFIG_PACKAGE_boost-test),,--without-test) \
|
||||
--without-python \
|
||||
$(foreach lib,$(BOOST_LIBS), \
|
||||
$(if $(findstring python,$(lib)),, \
|
||||
$(if $(findstring python3,$(lib)),, \
|
||||
$(if $(CONFIG_PACKAGE_boost-$(lib)),, \
|
||||
$(if $(findstring wserialization,$(lib)),,--without-$(lib)) \
|
||||
) \
|
||||
|
@ -437,32 +432,6 @@ define Build/Compile
|
|||
$(if $(CONFIG_PACKAGE_boost-iostreams),-sNO_BZIP2=1 -sZLIB_INCLUDE=$(STAGING_DIR)/usr/include \
|
||||
-sZLIB_LIBPATH=$(STAGING_DIR)/usr/lib) \
|
||||
install ;\
|
||||
$(if $(CONFIG_PACKAGE_boost-python), \
|
||||
echo "using gcc : $(GCC_VERSION) : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/python$(BOOST_PYTHON_VER)/ \" <cxxflags>\"$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > \
|
||||
tools/build/src/user-config.jam ; \
|
||||
echo "using python : $(BOOST_PYTHON_VER) : : $(STAGING_DIR)/usr/include/python$(BOOST_PYTHON_VER)/ : $(STAGING_DIR)/usr/lib/libpython$(BOOST_PYTHON_VER).so ;" >> \
|
||||
tools/build/src/user-config.jam; \
|
||||
b2 -a \
|
||||
$(CONFIGURE_ARGS) \
|
||||
--ignore-site-config \
|
||||
--toolset=gcc abi=$(BOOST_ABI) \
|
||||
--disable-long-double \
|
||||
$(if $(CONFIG_boost-variant-release), variant=release,) \
|
||||
$(if $(CONFIG_boost-variant-debug), variant=debug,) \
|
||||
$(if $(CONFIG_boost-variant-profile), variant=profile,) \
|
||||
$(if $(CONFIG_boost-use-name-tags),--layout=tagged,--layout=system) \
|
||||
$(if $(CONFIG_boost-build-type-complete),--build-type=complete,--build-type=minimal) \
|
||||
$(if $(CONFIG_boost-shared-libs),link=shared,) \
|
||||
$(if $(CONFIG_boost-static-libs),link=static,) \
|
||||
$(if $(CONFIG_boost-static-and-shared-libs),link=static$(comma)shared,) \
|
||||
$(if $(CONFIG_boost-runtime-shared),runtime-link=shared,) \
|
||||
$(if $(CONFIG_boost-runtime-static),runtime-link=static,) \
|
||||
$(if $(CONFIG_boost-runtime-static-and-shared),runtime-link=shared$(comma)static,) \
|
||||
$(if $(CONFIG_boost-single-thread),threading=single,) \
|
||||
threading=multi \
|
||||
--with-python \
|
||||
install ;\
|
||||
,) \
|
||||
$(if $(CONFIG_PACKAGE_boost-python3), \
|
||||
echo "using gcc : $(GCC_VERSION) : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/python$(BOOST_PYTHON3_VER)/ \" <cxxflags>\"$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > \
|
||||
tools/build/src/user-config.jam ; \
|
||||
|
@ -513,10 +482,7 @@ endef
|
|||
|
||||
define Package/boost/Default/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(if $(findstring python,$(2)), $(if $(findstring 3,$(2)), \
|
||||
$(CP) $(PKG_INSTALL_DIR)/lib/libboost_python3*.so* $(1)/usr/lib/ , \
|
||||
$(CP) $(PKG_INSTALL_DIR)/lib/libboost_python2*.so* $(1)/usr/lib/ ), \
|
||||
$(CP) $(PKG_INSTALL_DIR)/lib/libboost_$(2)*.so* $(1)/usr/lib/ )
|
||||
$(CP) $(PKG_INSTALL_DIR)/lib/libboost_$(2)*.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/boost-test/install
|
||||
|
|
|
@ -15,7 +15,7 @@ PKG_NAME:=elektra
|
|||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE.md
|
||||
PKG_VERSION:=0.8.21
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
# Use this for official releasees
|
||||
PKG_HASH:=51892570f18d1667d0da4d0908a091e41b41c20db9835765677109a3d150cd26
|
||||
|
@ -234,19 +234,6 @@ $(call Package/libelektra/Default-description)
|
|||
This package contains support for storing the key database as yaml files.
|
||||
endef
|
||||
|
||||
|
||||
define Package/libelektra-python2
|
||||
$(call Package/libelektra/Default)
|
||||
TITLE:=Elektra python2 plugin
|
||||
DEPENDS:=+libelektra-core +python-light +libstdcpp
|
||||
endef
|
||||
|
||||
define Package/libelektra-python2/description
|
||||
$(call Package/libelektra/Default-description)
|
||||
|
||||
This package adds python2 support to elektra.
|
||||
endef
|
||||
|
||||
define Package/libelektra-python3
|
||||
$(call Package/libelektra/Default)
|
||||
TITLE:=Elektra python3 plugin
|
||||
|
@ -304,7 +291,7 @@ CMAKE_OPTIONS = \
|
|||
-DKDB_DEFAULT_RESOLVER=resolver_fm_pb_b \
|
||||
-DKDB_DEFAULT_STORAGE=ini \
|
||||
-DENABLE_OPTIMIZATIONS=OFF \
|
||||
-DPLUGINS="ALL;-multifile" \
|
||||
-DPLUGINS="ALL;-multifile;-python2" \
|
||||
-DICONV_FIND_REQUIRED=ON \
|
||||
-DICONV_INCLUDE_DIR="$(ICONV_PREFIX)/include" \
|
||||
-DICONV_LIBRARY="$(ICONV_PREFIX)/lib"
|
||||
|
@ -409,11 +396,6 @@ define Package/libelektra-yamlcpp/install
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-yamlcpp.so $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libelektra-python2/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-python2.so $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libelektra-python3/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-python.so $(1)/usr/lib/
|
||||
|
@ -451,7 +433,6 @@ $(eval $(call BuildPackage,libelektra-xerces))
|
|||
$(eval $(call BuildPackage,libelektra-yamlcpp))
|
||||
$(eval $(call BuildPackage,libelektra-xml))
|
||||
$(eval $(call BuildPackage,libelektra-yajl))
|
||||
$(eval $(call BuildPackage,libelektra-python2))
|
||||
$(eval $(call BuildPackage,libelektra-python3))
|
||||
$(eval $(call BuildPackage,libelektra-lua))
|
||||
$(eval $(call BuildPackage,libelektra-extra))
|
||||
|
|
|
@ -26,7 +26,6 @@ PKG_USE_MIPS16:=0
|
|||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
|
||||
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
|
||||
|
||||
CMAKE_OPTIONS=-DENABLEEXAMPLES=0 \
|
||||
|
@ -74,18 +73,6 @@ $(call Package/libmraa/Default/description)
|
|||
This package contains the Node.js libraries.
|
||||
endef
|
||||
|
||||
define Package/libmraa-python
|
||||
$(call Package/libmraa/Default)
|
||||
TITLE:=Eclipse MRAA lowlevel IO Python library
|
||||
DEPENDS:=+libmraa +python-light
|
||||
endef
|
||||
|
||||
define Package/libmraa-python/description
|
||||
$(call Package/libmraa/Default/description)
|
||||
|
||||
This package contains the Python libraries.
|
||||
endef
|
||||
|
||||
define Package/libmraa-python3
|
||||
$(call Package/libmraa/Default)
|
||||
TITLE:=Eclipse MRAA lowlevel IO Python3 library
|
||||
|
@ -110,12 +97,6 @@ define Package/libmraa-node/install
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/mraa/* $(1)/usr/lib/node/mraa/
|
||||
endef
|
||||
|
||||
define Package/libmraa-python/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/site-packages
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/site-packages/* \
|
||||
$(1)/usr/lib/python$(PYTHON_VERSION)/site-packages/
|
||||
endef
|
||||
|
||||
define Package/libmraa-python3/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON3_VERSION)/site-packages
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON3_VERSION)/site-packages/* \
|
||||
|
@ -124,5 +105,4 @@ endef
|
|||
|
||||
$(eval $(call BuildPackage,libmraa))
|
||||
$(eval $(call BuildPackage,libmraa-node))
|
||||
$(eval $(call BuildPackage,libmraa-python))
|
||||
$(eval $(call BuildPackage,libmraa-python3))
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libsearpc
|
||||
PKG_VERSION:=3.2.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/libsearpc/tar.gz/v$(PKG_VERSION)?
|
||||
|
@ -25,7 +25,6 @@ PKG_INSTALL:=1
|
|||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../lang/python/python-package.mk
|
||||
include ../../lang/python/python3-package.mk
|
||||
|
||||
define Package/libsearpc
|
||||
|
@ -70,13 +69,9 @@ define Build/InstallDev
|
|||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/searpc-codegen.py $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
# Include Python 2 bindings in this package to maintain compatibility with previous versions
|
||||
define Package/libsearpc/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/pysearpc
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsearpc.so* $(1)/usr/lib/
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/pysearpc/*.py $(1)$(PYTHON_PKG_DIR)/pysearpc/
|
||||
rm -f $(1)$(PYTHON_PKG_DIR)/pysearpc/{pygencode,test_pysearpc}.py
|
||||
endef
|
||||
|
||||
define Py3Build/Compile
|
||||
|
|
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=talloc
|
||||
PKG_VERSION:=2.3.1
|
||||
MAJOR_VERSION:=2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.samba.org/ftp/talloc
|
||||
|
@ -19,8 +19,6 @@ PKG_LICENSE:=LGPL-3.0-or-later
|
|||
|
||||
PKG_BUILD_PARALLEL:=0
|
||||
|
||||
HOST_BUILD_DEPENDS:=python/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
|
|
|
@ -27,7 +27,6 @@ PKG_BUILD_PARALLEL:=1
|
|||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
|
||||
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
|
||||
|
||||
UPM_MODULES:= \
|
||||
|
@ -75,7 +74,6 @@ define Package/libupm
|
|||
DEPENDS+=+libjpeg +libmodbus +openzwave
|
||||
DEPENDS+= $(foreach module, $(UPM_MODULES), +libupm-$(module))
|
||||
DEPENDS+= $(foreach module, $(UPM_MODULES), +libupm-$(module)-node)
|
||||
DEPENDS+= $(foreach module, $(UPM_MODULES), +libupm-$(module)-python)
|
||||
DEPENDS+= $(foreach module, $(UPM_MODULES), +libupm-$(module)-python3)
|
||||
endef
|
||||
|
||||
|
@ -95,14 +93,6 @@ define Package/libupm/install/Default-node
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/jsupm_$(2) $(1)/usr/lib/node/ ;
|
||||
endef
|
||||
|
||||
define Package/libupm/install/Default-python
|
||||
$(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/site-packages/upm
|
||||
$(CP) $(CMAKE_BINARY_DIR)/$(if $(filter interfaces, $(2)),,src/)$(2)/python$(PYTHON_VERSION)/pyupm_$(2).py \
|
||||
$(1)/usr/lib/python$(PYTHON_VERSION)/site-packages/upm/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/site-packages/upm/_pyupm_$(2).so \
|
||||
$(1)/usr/lib/python$(PYTHON_VERSION)/site-packages/upm/ ;
|
||||
endef
|
||||
|
||||
define Package/libupm/install/Default-python3
|
||||
$(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON3_VERSION)/site-packages/upm
|
||||
$(CP) $(CMAKE_BINARY_DIR)/$(if $(filter interfaces, $(2)),,src/)$(2)/python$(PYTHON3_VERSION)/pyupm_$(2).py \
|
||||
|
@ -115,7 +105,6 @@ define Package/libupm/install
|
|||
$(foreach module, $(UPM_MODULES), \
|
||||
$(call Package/libupm/install/Default,$(1),$(module)) \
|
||||
$(call Package/libupm/install/Default-node,$(1),$(module)) \
|
||||
$(call Package/libupm/install/Default-python,$(1),$(module)) \
|
||||
$(call Package/libupm/install/Default-python3,$(1),$(module)))
|
||||
endef
|
||||
|
||||
|
@ -364,19 +353,6 @@ $(call Package/libupm/Default/description)
|
|||
This package contains $(1) sensor Node.js library
|
||||
endef
|
||||
|
||||
define Package/libupm-$(1)-python
|
||||
$(call Package/libupm/Default)
|
||||
$(call UpmPackage/depends,$(1))
|
||||
TITLE:=$(1) Python library
|
||||
DEPENDS+=+libupm-$(1) +libmraa-python +python-light
|
||||
endef
|
||||
|
||||
define Package/libupm-$(1)-python/description
|
||||
$(call Package/libupm/Default/description)
|
||||
|
||||
This package contains $(1) sensor Python library
|
||||
endef
|
||||
|
||||
define Package/libupm-$(1)-python3
|
||||
$(call Package/libupm/Default)
|
||||
$(call UpmPackage/depends,$(1))
|
||||
|
@ -396,9 +372,6 @@ endef
|
|||
define Package/libupm-$(1)-node/install
|
||||
$(call Package/libupm/install/Default-node,$$(1),$(1))
|
||||
endef
|
||||
define Package/libupm-$(1)-python/install
|
||||
$(call Package/libupm/install/Default-python,$$(1),$(1))
|
||||
endef
|
||||
define Package/libupm-$(1)-python3/install
|
||||
$(call Package/libupm/install/Default-python3,$$(1),$(1))
|
||||
endef
|
||||
|
@ -409,5 +382,4 @@ $(foreach module, $(UPM_MODULES), \
|
|||
$(eval $(call UpmPackage,$(module))) \
|
||||
$(eval $(call BuildPackage,libupm-$(module))) \
|
||||
$(eval $(call BuildPackage,libupm-$(module)-node)) \
|
||||
$(eval $(call BuildPackage,libupm-$(module)-python)) \
|
||||
$(eval $(call BuildPackage,libupm-$(module)-python3)))
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=freeradius3
|
||||
PKG_VERSION:=release_3_0_20
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/FreeRADIUS/freeradius-server/archive
|
||||
|
@ -30,7 +30,6 @@ PKG_CONFIG_DEPENDS := \
|
|||
CFLAGS += $(FPIC)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
|
||||
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
|
||||
|
||||
define Package/freeradius3/config
|
||||
|
@ -342,16 +341,6 @@ define Package/freeradius3-mod-preprocess/conffiles
|
|||
/etc/freeradius3/mods-enabled/preprocess
|
||||
endef
|
||||
|
||||
define Package/freeradius3-mod-python
|
||||
$(call Package/freeradius3/Default)
|
||||
DEPENDS:=freeradius3 +python
|
||||
TITLE:=Python module
|
||||
endef
|
||||
|
||||
define Package/freeradius3-mod-python/conffiles
|
||||
/etc/freeradius3/mods-available/python
|
||||
endef
|
||||
|
||||
define Package/freeradius3-mod-python3
|
||||
$(call Package/freeradius3/Default)
|
||||
DEPENDS:=freeradius3 +python3
|
||||
|
@ -512,6 +501,7 @@ CONFIGURE_ARGS+= \
|
|||
--without-rlm_opendirectory \
|
||||
--without-rlm_pam \
|
||||
--without-rlm_perl \
|
||||
--without-rlm_python \
|
||||
--without-rlm_redis \
|
||||
--without-rlm_rediswho \
|
||||
--without-rlm_rest \
|
||||
|
@ -577,19 +567,6 @@ else
|
|||
CONFIGURE_ARGS+= --without-rlm_eap_pwd
|
||||
endif
|
||||
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius3-mod-python),)
|
||||
CFLAGS+= -fPIC
|
||||
CONFIGURE_ARGS+= \
|
||||
--with-rlm_python \
|
||||
--with-rlm-python-include-dir="$(PYTHON_INC_DIR)" \
|
||||
--with-rlm-python-lib-dir="$(PYTHON_LIB_DIR)"
|
||||
CONFIGURE_VARS+= \
|
||||
OPENWRTTARGET_PY_PREFIX="$(PYTHON_DIR)" \
|
||||
OPENWRTTARGET_PY_SYS_VERSION="$(PYTHON_VERSION)"
|
||||
else
|
||||
CONFIGURE_ARGS+= --without-rlm_python
|
||||
endif
|
||||
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius3-mod-python3),)
|
||||
CFLAGS+= -fPIC
|
||||
CONFIGURE_ARGS+= \
|
||||
|
@ -789,8 +766,6 @@ $(eval $(call BuildPlugin,freeradius3-mod-mschap,rlm_mschap,))
|
|||
$(eval $(call BuildPlugin,freeradius3-mod-pap,rlm_pap,))
|
||||
$(eval $(call BuildPlugin,freeradius3-mod-passwd,rlm_passwd,))
|
||||
$(eval $(call BuildPlugin,freeradius3-mod-preprocess,rlm_preprocess,))
|
||||
$(eval $(call PyPackage,freeradius3-mod-python))
|
||||
$(eval $(call BuildPlugin,freeradius3-mod-python,rlm_python,))
|
||||
$(eval $(call Py3Package,freeradius3-mod-python3))
|
||||
$(eval $(call BuildPlugin,freeradius3-mod-python3,rlm_python3,))
|
||||
$(eval $(call BuildPlugin,freeradius3-mod-radutmp,rlm_radutmp,))
|
||||
|
|
|
@ -1,43 +1,3 @@
|
|||
--- a/src/modules/rlm_python/configure
|
||||
+++ b/src/modules/rlm_python/configure
|
||||
@@ -2928,15 +2928,15 @@ fi
|
||||
|
||||
|
||||
if test x$fail = x; then
|
||||
- PY_PREFIX=`${PYTHON_BIN} -c 'import sys ; print(sys.prefix)'`
|
||||
+ PY_PREFIX="$OPENWRTTARGET_PY_PREFIX"
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Python sys.prefix \"${PY_PREFIX}\"" >&5
|
||||
$as_echo "$as_me: Python sys.prefix \"${PY_PREFIX}\"" >&6;}
|
||||
|
||||
- PY_EXEC_PREFIX=`${PYTHON_BIN} -c 'import sys ; print(sys.exec_prefix)'`
|
||||
+ PY_EXEC_PREFIX="$OPENWRTTARGET_PY_PREFIX"
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Python sys.exec_prefix \"${PY_EXEC_PREFIX}\"" >&5
|
||||
$as_echo "$as_me: Python sys.exec_prefix \"${PY_EXEC_PREFIX}\"" >&6;}
|
||||
|
||||
- PY_SYS_VERSION=`${PYTHON_BIN} -c 'import sys ; print(sys.version[0:3])'`
|
||||
+ PY_SYS_VERSION="$OPENWRTTARGET_PY_SYS_VERSION"
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Python sys.version \"${PY_SYS_VERSION}\"" >&5
|
||||
$as_echo "$as_me: Python sys.version \"${PY_SYS_VERSION}\"" >&6;}
|
||||
|
||||
--- a/src/modules/rlm_python/configure.ac
|
||||
+++ b/src/modules/rlm_python/configure.ac
|
||||
@@ -65,13 +65,13 @@ if test x$with_[]modname != xno; then
|
||||
)
|
||||
|
||||
if test x$fail = x; then
|
||||
- PY_PREFIX=`${PYTHON_BIN} -c 'import sys ; print(sys.prefix)'`
|
||||
+ PY_PREFIX="$OPENWRTTARGET_PY_PREFIX"
|
||||
AC_MSG_NOTICE([Python sys.prefix \"${PY_PREFIX}\"])
|
||||
|
||||
- PY_EXEC_PREFIX=`${PYTHON_BIN} -c 'import sys ; print(sys.exec_prefix)'`
|
||||
+ PY_EXEC_PREFIX="$OPENWRTTARGET_PY_PREFIX"
|
||||
AC_MSG_NOTICE([Python sys.exec_prefix \"${PY_EXEC_PREFIX}\"])
|
||||
|
||||
- PY_SYS_VERSION=`${PYTHON_BIN} -c 'import sys ; print(sys.version[[0:3]])'`
|
||||
+ PY_SYS_VERSION="$OPENWRTTARGET_PY_SYS_VERSION"
|
||||
AC_MSG_NOTICE([Python sys.version \"${PY_SYS_VERSION}\"])
|
||||
|
||||
if test "x$PY_LIB_DIR" = "x"; then
|
||||
--- a/src/modules/rlm_python3/configure
|
||||
+++ b/src/modules/rlm_python3/configure
|
||||
@@ -2928,15 +2928,15 @@ fi
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=seafile-ccnet
|
||||
PKG_VERSION:=7.1.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/ccnet-server/tar.gz/v$(PKG_VERSION)-server?
|
||||
|
@ -28,7 +28,6 @@ PKG_INSTALL:=1
|
|||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../lang/python/python-package.mk
|
||||
include ../../lang/python/python3-package.mk
|
||||
|
||||
define Package/seafile-ccnet
|
||||
|
@ -74,12 +73,9 @@ CONFIGURE_ARGS += \
|
|||
--enable-python \
|
||||
--with-mysql="$(STAGING_DIR)/usr/bin/mysql_config"
|
||||
|
||||
# Include Python 2 bindings in this package to maintain compatibility with previous versions
|
||||
define Package/seafile-ccnet/install
|
||||
$(INSTALL_DIR) $(1)/usr/{lib,libexec}
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/ccnet
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/libexec/
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/python/ccnet/*.py $(1)$(PYTHON_PKG_DIR)/ccnet/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libccnet.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=seafile-server
|
||||
PKG_VERSION:=7.1.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seafile-server/tar.gz/v$(PKG_VERSION)-server?
|
||||
|
@ -28,7 +28,6 @@ PKG_INSTALL:=1
|
|||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../lang/python/python-package.mk
|
||||
include ../../lang/python/python3-package.mk
|
||||
|
||||
# Check that the actual Makefile version-relase match the above.
|
||||
|
@ -127,7 +126,7 @@ CONFIGURE_ARGS += \
|
|||
--enable-python \
|
||||
--with-mysql="$(STAGING_DIR)/usr/bin/mysql_config"
|
||||
|
||||
# This is required as python[3]-package.mk overrides the default setting of having interlinking enabled
|
||||
# This is required as python3-package.mk overrides the default setting of having interlinking enabled
|
||||
ifdef CONFIG_USE_MIPS16
|
||||
TARGET_CFLAGS += -minterlink-mips16
|
||||
endif
|
||||
|
@ -162,10 +161,8 @@ SEAFILE_SERVER_PYTHON_SCRIPTS:= \
|
|||
setup-seafile-mysql.py \
|
||||
sqlite2mysql.py
|
||||
|
||||
# Include Python 2 bindings in this package to maintain compatibility with previous versions
|
||||
define Package/seafile-server/install
|
||||
$(INSTALL_DIR) $(1)/usr/{bin,libexec}
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/{seafile,seaserv}
|
||||
$(INSTALL_DIR) $(1)/usr/share/seafile/seafile-server
|
||||
$(INSTALL_DIR) $(1)/etc/{config,init.d,seafile}
|
||||
$(INSTALL_DIR) $(1)/lib/upgrade/keep.d
|
||||
|
@ -174,9 +171,6 @@ define Package/seafile-server/install
|
|||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$$$$bin $(1)/usr/libexec/ ; \
|
||||
done
|
||||
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/python/seafile/*.py $(1)$(PYTHON_PKG_DIR)/seafile/
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/python/seaserv/*.py $(1)$(PYTHON_PKG_DIR)/seaserv/
|
||||
|
||||
for sh in $(SEAFILE_SERVER_SHELL_SCRIPTS) ; do \
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/$$$$sh $(1)/usr/bin/$$$${sh%.sh} ; \
|
||||
done
|
||||
|
@ -201,7 +195,6 @@ endef
|
|||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/seafile
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/seafile/*.h $(1)/usr/include/seafile/
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libseafile.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
|
|
@ -23,7 +23,6 @@ PKG_BUILD_PARALLEL:=1
|
|||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-i2c-tools-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../../lang/python/python-package.mk
|
||||
include ../../lang/python/python3-package.mk
|
||||
|
||||
PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xJf $(DL_DIR)/$(PKG_SOURCE)
|
||||
|
@ -50,23 +49,13 @@ define Package/i2c-tools
|
|||
VARIANT:=bin
|
||||
endef
|
||||
|
||||
define Package/python-smbus
|
||||
$(call Package/i2c/Default)
|
||||
SUBMENU:=Python
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
TITLE:=Python bindings for the SMBUS
|
||||
DEPENDS:=+PACKAGE_python-smbus:libi2c +PACKAGE_python-smbus:python-light
|
||||
VARIANT:=python
|
||||
endef
|
||||
|
||||
define Package/python3-smbus
|
||||
$(call Package/i2c/Default)
|
||||
SUBMENU:=Python
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
TITLE:=Python bindings for the SMBUS
|
||||
DEPENDS:=+PACKAGE_python3-smbus:libi2c +PACKAGE_python3-smbus:python3-light
|
||||
DEPENDS:=+libi2c +python3-light
|
||||
VARIANT:=python3
|
||||
endef
|
||||
|
||||
|
@ -79,10 +68,6 @@ define Package/i2c-tools/description
|
|||
were originally part of the lm-sensors package.
|
||||
endef
|
||||
|
||||
define Package/python-smbus/description
|
||||
This package contain the python bindings for Linux SMBus access through i2c-dev.
|
||||
endef
|
||||
|
||||
define Package/python3-smbus/description
|
||||
This package contain the Python3 bindings for Linux SMBus access through i2c-dev.
|
||||
endef
|
||||
|
@ -106,10 +91,7 @@ endef
|
|||
|
||||
endif # ifeq
|
||||
|
||||
PYTHON_PKG_SETUP_ARGS:=
|
||||
PYTHON3_PKG_SETUP_ARGS:=
|
||||
|
||||
PYTHON_PKG_SETUP_DIR:=py-smbus
|
||||
PYTHON3_PKG_SETUP_DIR:=py-smbus
|
||||
|
||||
define Package/libi2c/install
|
||||
|
@ -128,7 +110,5 @@ endef
|
|||
|
||||
$(eval $(call BuildPackage,libi2c))
|
||||
$(eval $(call BuildPackage,i2c-tools))
|
||||
$(eval $(call PyPackage,python-smbus))
|
||||
$(eval $(call BuildPackage,python-smbus))
|
||||
$(eval $(call Py3Package,python3-smbus))
|
||||
$(eval $(call BuildPackage,python3-smbus))
|
||||
|
|
Loading…
Reference in a new issue