squashfs-tools: bump to version 4.5
Drop GCC 10 build patch Adds 2 more utilities which are symlinks to mksquashfs,unsquashfs. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
This commit is contained in:
parent
3995ad1e51
commit
399bb7f992
2 changed files with 5 additions and 44 deletions
|
@ -8,8 +8,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=squashfs-tools
|
||||
PKG_VERSION:=4.4
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=4.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -18,7 +18,7 @@ PKG_CPE_ID:=cpe:/a:phillip_lougher:squashfs
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/plougher/squashfs-tools/tar.gz/${PKG_VERSION}?
|
||||
PKG_HASH:=a7fa4845e9908523c38d4acf92f8a41fdfcd19def41bd5090d7ad767a6dc75c3
|
||||
PKG_HASH:=b9e16188e6dc1857fe312633920f7d71cc36b0162eb50f3ecb1f0040f02edddd
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -83,11 +83,13 @@ endef
|
|||
define Package/squashfs-tools-mksquashfs/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/squashfs-tools/mksquashfs $(1)/usr/sbin/mksquashfs
|
||||
$(LN) mksquashfs $(1)/usr/sbin/sqfstar
|
||||
endef
|
||||
|
||||
define Package/squashfs-tools-unsquashfs/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/squashfs-tools/unsquashfs $(1)/usr/sbin/unsquashfs
|
||||
$(LN) unsquashfs $(1)/usr/sbin/sqfscat
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,squashfs-tools-mksquashfs))
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
From fe2f5da4b0f8994169c53e84b7cb8a0feefc97b5 Mon Sep 17 00:00:00 2001
|
||||
From: Sergei Trofimovich <slyfox@gentoo.org>
|
||||
Date: Sun, 26 Jan 2020 18:35:13 +0000
|
||||
Subject: [PATCH] squashfs-tools: fix build failure against gcc-10
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
On gcc-10 (and gcc-9 -fno-common) build fails as:
|
||||
|
||||
```
|
||||
cc ... -o mksquashfs
|
||||
ld: read_fs.o:(.bss+0x0):
|
||||
multiple definition of `fwriter_buffer'; mksquashfs.o:(.bss+0x400c90): first defined here
|
||||
ld: read_fs.o:(.bss+0x8):
|
||||
multiple definition of `bwriter_buffer'; mksquashfs.o:(.bss+0x400c98): first defined here
|
||||
```
|
||||
|
||||
gcc-10 will change the default from -fcommon to fno-common:
|
||||
https://gcc.gnu.org/PR85678.
|
||||
|
||||
The error also happens if CFLAGS=-fno-common passed explicitly.
|
||||
|
||||
Reported-by: Toralf Förster
|
||||
Bug: https://bugs.gentoo.org/706456
|
||||
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
|
||||
---
|
||||
squashfs-tools/mksquashfs.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/squashfs-tools/mksquashfs.h
|
||||
+++ b/squashfs-tools/mksquashfs.h
|
||||
@@ -143,7 +143,7 @@ struct append_file {
|
||||
#endif
|
||||
|
||||
extern struct cache *reader_buffer, *fragment_buffer, *reserve_cache;
|
||||
-struct cache *bwriter_buffer, *fwriter_buffer;
|
||||
+extern struct cache *bwriter_buffer, *fwriter_buffer;
|
||||
extern struct queue *to_reader, *to_deflate, *to_writer, *from_writer,
|
||||
*to_frag, *locked_fragment, *to_process_frag;
|
||||
extern struct append_file **file_mapping;
|
Loading…
Reference in a new issue