Merge branch 'openwrt:master' into master
This commit is contained in:
commit
39669ff1d5
12 changed files with 152 additions and 61 deletions
|
@ -8,18 +8,16 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-bidict
|
||||
PKG_VERSION:=0.21.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.22.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PYPI_NAME:=bidict
|
||||
PKG_HASH:=4fa46f7ff96dc244abfc437383d987404ae861df797e2fd5b190e233c302be09
|
||||
PKG_HASH:=1e0f7f74e4860e6d0943a05d4134c63a2fad86f3d4732fb265bd79e4e856d81d
|
||||
|
||||
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
|
||||
PKG_LICENSE:=MPL-2.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_BUILD_DEPENDS:=python-setuptools-scm/host
|
||||
|
||||
include ../pypi.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../python3-package.mk
|
||||
|
@ -28,8 +26,8 @@ define Package/python3-bidict
|
|||
SUBMENU:=Python
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
TITLE:=The bidirectional mapping library
|
||||
URL:=https://github.com/jab/bidict
|
||||
TITLE:=Bidirectional mapping library
|
||||
URL:=https://bidict.readthedocs.io/
|
||||
DEPENDS:= \
|
||||
+python3-light
|
||||
endef
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
#
|
||||
# Copyright (C) 2022 Julien Malik <julien.malik@paraiso.me>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-exceptiongroup
|
||||
PKG_VERSION:=1.1.1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PYPI_NAME:=exceptiongroup
|
||||
PKG_HASH:=d484c3090ba2889ae2928419117447a14daf3c1231d5e30d0aae34f354f01785
|
||||
|
||||
PKG_LICENSE:=MIT,Python-2.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_MAINTAINER:=Julien Malik <julien.malik@paraiso.me>
|
||||
|
||||
PKG_BUILD_DEPENDS:=python-flit-scm/host
|
||||
|
||||
include ../pypi.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../python3-package.mk
|
||||
|
||||
define Package/python3-exceptiongroup
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
SUBMENU:=Python
|
||||
TITLE:=Backport of PEP 654 (exception groups)
|
||||
URL:=https://github.com/agronholm/exceptiongroup
|
||||
DEPENDS:=+python3-light
|
||||
endef
|
||||
|
||||
define Package/python3-exceptiongroup/description
|
||||
This is a backport of the BaseExceptionGroup and ExceptionGroup classes from Python 3.11.
|
||||
endef
|
||||
|
||||
$(eval $(call Py3Package,python3-exceptiongroup))
|
||||
$(eval $(call BuildPackage,python3-exceptiongroup))
|
||||
$(eval $(call BuildPackage,python3-exceptiongroup-src))
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libmariadb
|
||||
PKG_VERSION:=3.1.18
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=mariadb-connector-c-$(PKG_VERSION)-src.tar.gz
|
||||
PKG_SOURCE_URL := \
|
||||
|
@ -35,7 +35,8 @@ MARIADB_CLIENT_PLUGINS := \
|
|||
auth_gssapi_client \
|
||||
remote_io
|
||||
|
||||
PKG_BUILD_DEPENDS:=curl
|
||||
PKG_BUILD_DEPENDS:=curl USE_MUSL:libucontext
|
||||
|
||||
PKG_CONFIG_DEPENDS := \
|
||||
$(patsubst %,CONFIG_PACKAGE_$(PKG_NAME)-plugin-%,$(subst _,-,$(MARIADB_CLIENT_PLUGINS)))
|
||||
|
||||
|
|
61
libs/libmariadb/patches/010-link-to-libucontext.patch
Normal file
61
libs/libmariadb/patches/010-link-to-libucontext.patch
Normal file
|
@ -0,0 +1,61 @@
|
|||
libmariadb: Fix async api by linking to libucontext
|
||||
The asynchronous API of libmariadb uses cooperative multi threading
|
||||
by using the system calls
|
||||
* makecontext
|
||||
* swapcontext
|
||||
* getcontext
|
||||
* setcontext
|
||||
of the ucontext.h C-API.
|
||||
|
||||
Thus additionally link libmariadb to libucontext which is a library
|
||||
providing these system calls on platforms not supporting them out of
|
||||
the box - like musl based platforms.
|
||||
--- a/libmariadb/CMakeLists.txt
|
||||
+++ b/libmariadb/CMakeLists.txt
|
||||
@@ -417,7 +417,7 @@ ELSE()
|
||||
SET_TARGET_PROPERTIES(libmariadb PROPERTIES LINKER_LANGUAGE C)
|
||||
ENDIF()
|
||||
|
||||
-TARGET_LINK_LIBRARIES(libmariadb LINK_PRIVATE ${SYSTEM_LIBS})
|
||||
+TARGET_LINK_LIBRARIES(libmariadb LINK_PRIVATE ${SYSTEM_LIBS} ${LIBUCONTEXT_POSIX} ${LIBUCONTEXT})
|
||||
|
||||
SIGN_TARGET(libmariadb)
|
||||
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -227,6 +227,14 @@ IF(UNIX)
|
||||
SEARCH_LIBRARY(LIBPTHREAD pthread_getspecific "pthread;pthreads")
|
||||
SEARCH_LIBRARY(LIBNSL gethostbyname_r "nsl_r;nsl")
|
||||
SEARCH_LIBRARY(LIBSOCKET setsockopt socket)
|
||||
+ SEARCH_LIBRARY(LIBUCONTEXT libucontext_swapcontext libucontext.a)
|
||||
+ SEARCH_LIBRARY(LIBUCONTEXT_POSIX swapcontext libucontext_posix.a)
|
||||
+ IF (NOT HAVE_LIBUCONTEXT_POSIX OR NOT HAVE_LIBUCONTEXT)
|
||||
+ UNSET(HAVE_LIBUCONTEXT)
|
||||
+ UNSET(LIBUCONTEXT)
|
||||
+ UNSET(HAVE_LIBUCONTEXT_POSIX)
|
||||
+ UNSET(LIBUCONTEXT_POSIX)
|
||||
+ ENDIF()
|
||||
FIND_PACKAGE(Threads)
|
||||
SET(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ${LIBNSL} ${LIBBIND} ${LIBICONV} ${LIBZ}
|
||||
${LIBSOCKET} ${CMAKE_DL_LIBS} ${LIBM} ${LIBPTHREAD})
|
||||
--- a/include/ma_config.h.in
|
||||
+++ b/include/ma_config.h.in
|
||||
@@ -28,6 +28,7 @@
|
||||
#cmakedefine HAVE_SYS_UN_H 1
|
||||
#cmakedefine HAVE_UNISTD_H 1
|
||||
#cmakedefine HAVE_UCONTEXT_H 1
|
||||
+#cmakedefine HAVE_LIBUCONTEXT_POSIX 1
|
||||
|
||||
/*
|
||||
* function definitions - processed in LibmysqlFunctions.txt
|
||||
--- a/include/ma_context.h
|
||||
+++ b/include/ma_context.h
|
||||
@@ -31,7 +31,7 @@
|
||||
#define MY_CONTEXT_USE_X86_64_GCC_ASM
|
||||
#elif defined(__GNUC__) && __GNUC__ >= 3 && defined(__i386__)
|
||||
#define MY_CONTEXT_USE_I386_GCC_ASM
|
||||
-#elif defined(HAVE_UCONTEXT_H)
|
||||
+#elif defined(HAVE_UCONTEXT_H) || defined(HAVE_LIBUCONTEXT_POSIX)
|
||||
#define MY_CONTEXT_USE_UCONTEXT
|
||||
#else
|
||||
#define MY_CONTEXT_DISABLE
|
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=ffmpeg
|
||||
PKG_VERSION:=5.1.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://ffmpeg.org/releases/
|
||||
|
|
|
@ -0,0 +1,71 @@
|
|||
From: Rémi Denis-Courmont <remi@remlab.net>
|
||||
Date: Sun, 16 Jul 2023 15:18:02 +0000 (+0300)
|
||||
Subject: avcodec/x86/mathops: clip constants used with shift instructions within inline assembly
|
||||
X-Git-Url: http://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff_plain/25cd95a9dc3510c3cc0d7aad6f9d83f6a1078c7e?hp=e5b5dd66535f444451e0fee59247b224d866f334
|
||||
|
||||
avcodec/x86/mathops: clip constants used with shift instructions within inline assembly
|
||||
|
||||
Fixes assembling with binutil as >= 2.41
|
||||
|
||||
Signed-off-by: James Almer <jamrial@gmail.com>
|
||||
(cherry picked from commit effadce6c756247ea8bae32dc13bb3e6f464f0eb)
|
||||
---
|
||||
|
||||
--- a/libavcodec/x86/mathops.h
|
||||
+++ b/libavcodec/x86/mathops.h
|
||||
@@ -35,12 +35,20 @@
|
||||
static av_always_inline av_const int MULL(int a, int b, unsigned shift)
|
||||
{
|
||||
int rt, dummy;
|
||||
+ if (__builtin_constant_p(shift))
|
||||
__asm__ (
|
||||
"imull %3 \n\t"
|
||||
"shrdl %4, %%edx, %%eax \n\t"
|
||||
:"=a"(rt), "=d"(dummy)
|
||||
- :"a"(a), "rm"(b), "ci"((uint8_t)shift)
|
||||
+ :"a"(a), "rm"(b), "i"(shift & 0x1F)
|
||||
);
|
||||
+ else
|
||||
+ __asm__ (
|
||||
+ "imull %3 \n\t"
|
||||
+ "shrdl %4, %%edx, %%eax \n\t"
|
||||
+ :"=a"(rt), "=d"(dummy)
|
||||
+ :"a"(a), "rm"(b), "c"((uint8_t)shift)
|
||||
+ );
|
||||
return rt;
|
||||
}
|
||||
|
||||
@@ -113,19 +121,31 @@ __asm__ volatile(\
|
||||
// avoid +32 for shift optimization (gcc should do that ...)
|
||||
#define NEG_SSR32 NEG_SSR32
|
||||
static inline int32_t NEG_SSR32( int32_t a, int8_t s){
|
||||
+ if (__builtin_constant_p(s))
|
||||
__asm__ ("sarl %1, %0\n\t"
|
||||
: "+r" (a)
|
||||
- : "ic" ((uint8_t)(-s))
|
||||
+ : "i" (-s & 0x1F)
|
||||
);
|
||||
+ else
|
||||
+ __asm__ ("sarl %1, %0\n\t"
|
||||
+ : "+r" (a)
|
||||
+ : "c" ((uint8_t)(-s))
|
||||
+ );
|
||||
return a;
|
||||
}
|
||||
|
||||
#define NEG_USR32 NEG_USR32
|
||||
static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
|
||||
+ if (__builtin_constant_p(s))
|
||||
__asm__ ("shrl %1, %0\n\t"
|
||||
: "+r" (a)
|
||||
- : "ic" ((uint8_t)(-s))
|
||||
+ : "i" (-s & 0x1F)
|
||||
);
|
||||
+ else
|
||||
+ __asm__ ("shrl %1, %0\n\t"
|
||||
+ : "+r" (a)
|
||||
+ : "c" ((uint8_t)(-s))
|
||||
+ );
|
||||
return a;
|
||||
}
|
||||
|
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=crowdsec
|
||||
PKG_VERSION:=1.5.2
|
||||
PKG_VERSION:=1.5.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/crowdsecurity/crowdsec/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=18de78572600166c3a7636e9cd4ea011d204211638810969d99cb65feb78c231
|
||||
PKG_HASH:=afa4021f77e9cb87d7fd11cd86146770836dc15cad1ae8a4edce1314b14be98a
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -29,7 +29,7 @@ CWD_BUILD_CODENAME:=alphaga
|
|||
CWD_BUILD_TIMESTAMP:=$(shell date +%F"_"%T)
|
||||
CWD_BUILD_TAG:=openwrt-$(PKG_VERSION)-$(PKG_RELEASE)
|
||||
|
||||
CWD_VERSION_PKG:=github.com/crowdsecurity/crowdsec/pkg/cwversion
|
||||
CWD_VERSION_PKG:=github.com/crowdsecurity/go-cs-lib/version
|
||||
|
||||
GO_PKG:=github.com/crowdsecurity/crowdsec
|
||||
GO_PKG_INSTALL_ALL:=1
|
||||
|
|
|
@ -17,6 +17,7 @@ PKG_SOURCE_URL:=@SF/iperf2
|
|||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_CPE_ID:=cpe:/a:iperf_project:iperf
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_FLAGS:=lto
|
||||
|
|
|
@ -17,6 +17,7 @@ PKG_HASH:=bdb77c11f72bce90214883159577fa24412013e62b2083cf5f54391d79b1d8ff
|
|||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_CPE_ID:=cpe:/a:es:iperf3
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=samba
|
||||
PKG_VERSION:=4.18.0
|
||||
PKG_VERSION:=4.18.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -13,7 +13,7 @@ PKG_SOURCE_URL:= \
|
|||
http://www.nic.funet.fi/index/samba/pub/samba/stable/ \
|
||||
http://samba.mirror.bit.nl/samba/ftp/stable/ \
|
||||
https://download.samba.org/pub/samba/stable/
|
||||
PKG_HASH:=70348656ef807be9c8be4465ca157cef4d99818e234253d2c684cc18b8408149
|
||||
PKG_HASH:=284c8a994ce989c87cd6808c390fcb9d00c36b21a0dc1a8a75474b67c9e715e7
|
||||
|
||||
PKG_BUILD_FLAGS:=gc-sections
|
||||
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=transmission
|
||||
PKG_VERSION:=4.0.3
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/transmission/transmission/releases/download/$(PKG_VERSION)/
|
||||
|
@ -45,7 +45,7 @@ define Package/transmission/template
|
|||
DEPENDS:=+libatomic +libcurl +libdeflate +libdht +libevent2 \
|
||||
+libevent2-pthreads +libminiupnpc +libnatpmp +libpthread +libpsl \
|
||||
+librt +libutp +zlib +LIBCURL_NOSSL:libmbedtls \
|
||||
+LIBCURL_GNUTLS:libmbedtls
|
||||
+LIBCURL_GNUTLS:libmbedtls +LIBCURL_MBEDTLS:libmbedtls
|
||||
endef
|
||||
|
||||
define Package/transmission-daemon
|
||||
|
|
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=btrfs-progs
|
||||
PKG_VERSION:=6.3
|
||||
PKG_VERSION:=6.5.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/kdave/btrfs-progs
|
||||
PKG_HASH:=40a0bdff787ecb490e5533dbcefd4852176daf12aae5a1158203db43d8ad6a7d
|
||||
PKG_HASH:=dacbb28136e82586af802205263a428c3d1941778bc3fdc9b1b386ea12eb904e
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Karel Kočí <karel.koci@nic.cz>
|
||||
|
|
Loading…
Reference in a new issue