poco: update to version 1.8.1
Fix CVE-2017-1000472 - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000472 Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
This commit is contained in:
parent
5d0971b9cc
commit
3916b08b30
2 changed files with 11 additions and 11 deletions
libs/poco
|
@ -9,12 +9,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=poco
|
PKG_NAME:=poco
|
||||||
PKG_VERSION:=1.7.7
|
PKG_VERSION:=1.8.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_URL:=http://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_HASH:=17783e30f5ef9c852544ac0e9d1fd316c4804317026059a9d6aad798b61c77f8
|
PKG_HASH:=2e4c07ac73174ee06c7e2c7cf2b7642a5b3aea81d0203e1c069b32ac4a8ecfbc
|
||||||
|
|
||||||
PKG_LICENSE:=BSL-1.0
|
PKG_LICENSE:=BSL-1.0
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
--- a/Foundation/src/Error.cpp
|
--- a/Foundation/src/Error.cpp
|
||||||
+++ b/Foundation/src/Error.cpp
|
+++ b/Foundation/src/Error.cpp
|
||||||
@@ -66,7 +66,7 @@
|
@@ -70,7 +70,7 @@ namespace Poco {
|
||||||
without -D_GNU_SOURCE is needed, otherwise the GNU version is
|
|
||||||
preferred.
|
#if (_XOPEN_SOURCE >= 600) || POCO_ANDROID || __APPLE__
|
||||||
*/
|
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
|
||||||
-#if defined _GNU_SOURCE && !POCO_ANDROID
|
-#elif _GNU_SOURCE
|
||||||
+#if (defined _GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__)) && !POCO_ANDROID
|
+#elif (_GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__))
|
||||||
char errmsg[256] = "";
|
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
|
||||||
return std::string(strerror_r(errorCode, errmsg, 256));
|
#else
|
||||||
#elif (_XOPEN_SOURCE >= 600) || POCO_ANDROID
|
setMessage(strerror(err));
|
||||||
|
|
Loading…
Reference in a new issue