libiio: update to 0.25
While at, backport fix to compile against libxml 2.12.0. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
fd44545bd8
commit
3893763d9c
2 changed files with 31 additions and 4 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libiio
|
||||
PKG_VERSION:=0.21
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=0.25
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/analogdevicesinc/libiio/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=03d13165cbeb83b036743cbd9a10e336c728da162714f39d13250a3d94305cac
|
||||
PKG_HASH:=21972599a3c143ab1f98002ad2b3f28f4aff927fde5f677478311cd4e517730c
|
||||
|
||||
PKG_LICENSE:=LGPL-2.1
|
||||
PKG_LICENSE_FILES:=COPYING.txt
|
||||
|
@ -35,7 +35,7 @@ include $(INCLUDE_DIR)/cmake.mk
|
|||
|
||||
CMAKE_OPTIONS += -DWITH_DOC=OFF
|
||||
CMAKE_OPTIONS += -DENABLE_IPV6=$(if $(CONFIG_IPV6),ON,OFF)
|
||||
CMAKE_OPTIONS += -DENABLE_AIO=OFF
|
||||
CMAKE_OPTIONS += -DWITH_AIO=OFF
|
||||
CMAKE_OPTIONS += -DWITH_LOCAL_BACKEND=$(if $(CONFIG_LIBIIO_LOCAL_BACKEND),ON,OFF)
|
||||
CMAKE_OPTIONS += -DWITH_LOCAL_CONFIG=OFF
|
||||
CMAKE_OPTIONS += -DWITH_NETWORK_BACKEND=$(if $(CONFIG_LIBIIO_NETWORK_BACKEND),ON,OFF)
|
||||
|
|
|
@ -0,0 +1,27 @@
|
|||
From bb688d04294dda45e68dfaf13e3bc1187841e52a Mon Sep 17 00:00:00 2001
|
||||
From: Jan Tojnar <jtojnar@gmail.com>
|
||||
Date: Sun, 10 Dec 2023 21:52:05 +0100
|
||||
Subject: [PATCH] xml: Fix compatibility with libxml 2.12
|
||||
|
||||
libxml 2.12.0 reorganized includes, resulting in the following no longer being in scope:
|
||||
|
||||
- XML_PARSE_DTDVALID
|
||||
- xmlReadMemory
|
||||
- xmlReadFile
|
||||
- xmlCleanupParser
|
||||
|
||||
Signed-off-by: Jan Tojnar <jtojnar@gmail.com>
|
||||
---
|
||||
xml.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- a/xml.c
|
||||
+++ b/xml.c
|
||||
@@ -10,6 +10,7 @@
|
||||
#include "iio-private.h"
|
||||
|
||||
#include <errno.h>
|
||||
+#include <libxml/parser.h>
|
||||
#include <libxml/tree.h>
|
||||
#include <string.h>
|
||||
|
Loading…
Reference in a new issue