Merge pull request #12126 from lucize/netopeer
Netopeer2: update Netopeer2 and dependencies to master
This commit is contained in:
commit
386f5b58e5
13 changed files with 60 additions and 186 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libnetconf2
|
PKG_NAME:=libnetconf2
|
||||||
PKG_VERSION:=0.12-r2
|
PKG_VERSION:=1.1.24
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/libnetconf2/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/libnetconf2/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=760061fb1c1fe87a2a068d5a9e5affcef280044c5940ef344854e9ea7ec26452
|
PKG_HASH:=1a69db028bf970f0dab15ed508b58e0cf0806a7e4492828404b75c97ec8ab306
|
||||||
|
|
||||||
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
@ -43,9 +43,6 @@ endef
|
||||||
define Package/libnetconf2/install
|
define Package/libnetconf2/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetconf2.so* $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetconf2.so* $(1)/usr/lib/
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/share/libnetconf2
|
|
||||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/libnetconf2/*.yin $(1)/usr/share/libnetconf2/
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libnetconf2))
|
$(eval $(call BuildPackage,libnetconf2))
|
||||||
|
|
11
libs/libnetconf2/patches/001-cmake_not_updated.patch
Normal file
11
libs/libnetconf2/patches/001-cmake_not_updated.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/CMakeLists.txt 2020-05-08 13:29:30.903800624 +0300
|
||||||
|
+++ b/CMakeLists.txt 2020-05-08 13:29:50.943582218 +0300
|
||||||
|
@@ -153,7 +153,7 @@
|
||||||
|
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNC_ENABLED_SSH")
|
||||||
|
message(STATUS "LibSSH version ${LibSSH_VERSION} found")
|
||||||
|
|
||||||
|
- if(LibSSH_VERSION VERSION_EQUAL 0.9.3 OR LibSSH_VERSION VERSION_EQUAL 0.9.4)
|
||||||
|
+ if(LibSSH_VERSION VERSION_EQUAL 0.9.x)
|
||||||
|
message(FATAL_ERROR "LibSSH ${LibSSH_VERSION} includes regression bugs and libnetconf2 will NOT work properly, try to use another version")
|
||||||
|
endif()
|
||||||
|
|
|
@ -1,38 +0,0 @@
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -176,6 +176,7 @@ target_link_libraries(netconf2 ${CMAKE_THREAD_LIBS_INIT})
|
|
||||||
set(CMAKE_REQUIRED_LIBRARIES pthread)
|
|
||||||
check_include_file(stdatomic.h HAVE_STDATOMIC)
|
|
||||||
check_function_exists(pthread_mutex_timedlock HAVE_PTHREAD_MUTEX_TIMEDLOCK)
|
|
||||||
+check_function_exists(pthread_rwlockattr_setkind_np HAVE_PTHREAD_RWLOCKATTR_SETKIND_NP)
|
|
||||||
|
|
||||||
# dependencies - openssl
|
|
||||||
if(ENABLE_TLS OR ENABLE_DNSSEC OR ENABLE_SSH)
|
|
||||||
--- a/src/config.h.in
|
|
||||||
+++ b/src/config.h.in
|
|
||||||
@@ -73,4 +73,7 @@
|
|
||||||
*/
|
|
||||||
#define NC_PS_QUEUE_SIZE @MAX_PSPOLL_THREAD_COUNT@
|
|
||||||
|
|
||||||
+/* Portability feature-check macros. */
|
|
||||||
+#cmakedefine HAVE_PTHREAD_RWLOCKATTR_SETKIND_NP
|
|
||||||
+
|
|
||||||
#endif /* NC_CONFIG_H_ */
|
|
||||||
--- a/src/session_server.c
|
|
||||||
+++ b/src/session_server.c
|
|
||||||
@@ -560,6 +560,7 @@ nc_server_init(struct ly_ctx *ctx)
|
|
||||||
errno=0;
|
|
||||||
|
|
||||||
if (pthread_rwlockattr_init(&attr) == 0) {
|
|
||||||
+#if defined(HAVE_PTHREAD_RWLOCKATTR_SETKIND_NP)
|
|
||||||
if (pthread_rwlockattr_setkind_np(&attr, PTHREAD_RWLOCK_PREFER_WRITER_NONRECURSIVE_NP) == 0) {
|
|
||||||
if (pthread_rwlock_init(&server_opts.endpt_lock, &attr) != 0) {
|
|
||||||
ERR("%s: failed to init rwlock(%s).", __FUNCTION__, strerror(errno));
|
|
||||||
@@ -570,6 +571,7 @@ nc_server_init(struct ly_ctx *ctx)
|
|
||||||
} else {
|
|
||||||
ERR("%s: failed set attribute (%s).", __FUNCTION__, strerror(errno));
|
|
||||||
}
|
|
||||||
+#endif
|
|
||||||
pthread_rwlockattr_destroy(&attr);
|
|
||||||
} else {
|
|
||||||
ERR("%s: failed init attribute (%s).", __FUNCTION__, strerror(errno));
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/src/io.c
|
|
||||||
+++ b/src/io.c
|
|
||||||
@@ -62,7 +62,7 @@ nc_ssl_error_get_reasons(void)
|
|
||||||
ERRMEM;
|
|
||||||
return NULL;
|
|
||||||
}
|
|
||||||
- reason_len += sprintf(reasons + reason_len, ERR_reason_error_string(e));
|
|
||||||
+ reason_len += sprintf(reasons + reason_len, "%s", ERR_reason_error_string(e));
|
|
||||||
}
|
|
||||||
|
|
||||||
return reasons;
|
|
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libyang
|
PKG_NAME:=libyang
|
||||||
PKG_VERSION:=1.0.130
|
PKG_VERSION:=1.0.167
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/libyang/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/libyang/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=c9703079f10fbf7154882562322b4b01764bc7735345da555ca51201b02e536c
|
PKG_HASH:=2431fa5c7cfbe6a6f2c0873547b976f018438967adfe268726911dd3d95eaa31
|
||||||
|
|
||||||
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
|
|
@ -10,12 +10,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=Netopeer2
|
PKG_NAME:=Netopeer2
|
||||||
PKG_VERSION:=0.7-r2
|
PKG_VERSION:=1.1.27
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/Netopeer2/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/Netopeer2/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=59688271be4fecbbee671fc7eb3dc0538b13b4baab53e923e26eaeb33e6f7ec0
|
PKG_HASH:=e3914aae78d19f445a37ef37408f7ce209ebf0b05deb412b1bc56a021448885f
|
||||||
|
|
||||||
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
@ -65,26 +65,30 @@ define Package/netopeer2/description
|
||||||
endef
|
endef
|
||||||
|
|
||||||
CMAKE_OPTIONS += \
|
CMAKE_OPTIONS += \
|
||||||
-DKEYSTORED_KEYS_DIR:STRING=/etc/keystored/keys \
|
-DGENERATE_HOSTKEY:BOOL=OFF \
|
||||||
-DENABLE_CONFIGURATION:BOOL=OFF \
|
-DINSTALL_MODULES:BOOL=OFF \
|
||||||
-DMODEL_INSTALL:BOOL=OFF \
|
-DCMAKE_BUILD_TYPE=release
|
||||||
-DSSH_KEY_INSTALL:BOOL=OFF
|
|
||||||
|
#-DKEYSTORED_KEYS_DIR:STRING=/etc/keystored/keys \
|
||||||
|
|
||||||
define Package/netopeer2-server/install
|
define Package/netopeer2-server/install
|
||||||
$(INSTALL_DIR) $(1)/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/server/netopeer2-server $(1)/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/netopeer2-server $(1)/usr/bin/
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/etc/sysrepo/yang
|
$(INSTALL_DIR) $(1)/etc/sysrepo/yang
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-ssh-server.yang $(1)/etc/sysrepo/yang/ietf-ssh-server@2016-11-02.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-ssh-server@2019-07-02.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-tls-server.yang $(1)/etc/sysrepo/yang/ietf-tls-server@2016-11-02.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-tls-server@2019-07-02.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/iana-crypt-hash.yang $(1)/etc/sysrepo/yang/iana-crypt-hash@2014-08-06.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/iana-crypt-hash@2014-08-06.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-x509-cert-to-name.yang $(1)/etc/sysrepo/yang/ietf-x509-cert-to-name@2014-12-10.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-x509-cert-to-name@2014-12-10.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-server.yang $(1)/etc/sysrepo/yang/ietf-netconf-server@2016-11-02.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-server@2019-07-02.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-monitoring.yang $(1)/etc/sysrepo/yang/ietf-netconf-monitoring@2010-10-04.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-monitoring@2010-10-04.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-with-defaults.yang $(1)/etc/sysrepo/yang/ietf-netconf-with-defaults@2011-06-01.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-acm@2018-02-14.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-system.yang $(1)/etc/sysrepo/yang/ietf-system@2014-08-06.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf-nmda@2019-01-07.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-datastores.yang $(1)/etc/sysrepo/yang/ietf-datastores@2017-08-17.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-netconf@2013-09-29.yang $(1)/etc/sysrepo/yang/
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-yang-library.yang $(1)/etc/sysrepo/yang/ietf-yang-library@2018-01-17.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-datastores@2017-08-17.yang $(1)/etc/sysrepo/yang/
|
||||||
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-crypto-types@2019-07-02.yang $(1)/etc/sysrepo/yang/
|
||||||
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/iana-crypt-hash@2014-08-06.yang $(1)/etc/sysrepo/yang/
|
||||||
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-tcp-server@2019-07-02.yang $(1)/etc/sysrepo/yang/
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/etc/uci-defaults
|
$(INSTALL_DIR) $(1)/etc/uci-defaults
|
||||||
$(INSTALL_BIN) ./files/netopeer2-server.default $(1)/etc/uci-defaults/98_netopeer2-server
|
$(INSTALL_BIN) ./files/netopeer2-server.default $(1)/etc/uci-defaults/98_netopeer2-server
|
||||||
|
@ -97,16 +101,13 @@ define Package/netopeer2-server/install
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/netopeer2-cli/install
|
define Package/netopeer2-cli/install
|
||||||
$(INSTALL_DIR) $(1)/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/cli/netopeer2-cli $(1)/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/netopeer2-cli $(1)/usr/bin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/netopeer2-keystored/install
|
define Package/netopeer2-keystored/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/sysrepo/plugins/
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/keystored/libkeystored.so $(1)/usr/lib/sysrepo/plugins/
|
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/etc/sysrepo/yang
|
$(INSTALL_DIR) $(1)/etc/sysrepo/yang
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-keystore.yang $(1)/etc/sysrepo/yang/ietf-keystore@2016-10-31.yang
|
$(INSTALL_DATA) $(PKG_BUILD_DIR)/modules/ietf-keystore@2019-07-02.yang $(1)/etc/sysrepo/yang/
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/etc/uci-defaults
|
$(INSTALL_DIR) $(1)/etc/uci-defaults
|
||||||
|
|
||||||
|
@ -120,8 +121,6 @@ else
|
||||||
$(INSTALL_DATA) ./files/ssh_host_rsa_key.pub.pem $(1)/etc/keystored/keys
|
$(INSTALL_DATA) ./files/ssh_host_rsa_key.pub.pem $(1)/etc/keystored/keys
|
||||||
endif
|
endif
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/share/netopeer2-keystored
|
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/keystored/stock_key_config.xml $(1)/usr/share/netopeer2-keystored
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,netopeer2-server))
|
$(eval $(call BuildPackage,netopeer2-server))
|
||||||
|
|
|
@ -5,7 +5,7 @@
|
||||||
if [ -x /bin/sysrepoctl ]; then
|
if [ -x /bin/sysrepoctl ]; then
|
||||||
match=$(sysrepoctl -l | grep "ietf-keystore ")
|
match=$(sysrepoctl -l | grep "ietf-keystore ")
|
||||||
if [ ! "$match" ]; then
|
if [ ! "$match" ]; then
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-keystore@2016-10-31.yang -o root:root -p 600
|
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-keystore@2019-07-02.yang -o root:root -p 600
|
||||||
if [ -x /bin/sysrepocfg ]; then
|
if [ -x /bin/sysrepocfg ]; then
|
||||||
sysrepocfg -f xml -d startup -i /usr/share/netopeer2-keystored/stock_key_config.xml ietf-keystore
|
sysrepocfg -f xml -d startup -i /usr/share/netopeer2-keystored/stock_key_config.xml ietf-keystore
|
||||||
rm /usr/share/netopeer2-keystored/stock_key_config.xml
|
rm /usr/share/netopeer2-keystored/stock_key_config.xml
|
||||||
|
|
|
@ -5,7 +5,7 @@
|
||||||
if [ -x /bin/sysrepoctl ]; then
|
if [ -x /bin/sysrepoctl ]; then
|
||||||
match=$(sysrepoctl -l | grep "ietf-keystore ")
|
match=$(sysrepoctl -l | grep "ietf-keystore ")
|
||||||
if [ ! "$match" ]; then
|
if [ ! "$match" ]; then
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-keystore@2016-10-31.yang -o root:root -p 600
|
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-keystore@2019-07-02.yang -o root:root -p 600
|
||||||
if [ -x /bin/sysrepocfg ]; then
|
if [ -x /bin/sysrepocfg ]; then
|
||||||
sysrepocfg -f xml -d startup -i /usr/share/netopeer2-keystored/stock_key_config.xml ietf-keystore
|
sysrepocfg -f xml -d startup -i /usr/share/netopeer2-keystored/stock_key_config.xml ietf-keystore
|
||||||
rm /usr/share/netopeer2-keystored/stock_key_config.xml
|
rm /usr/share/netopeer2-keystored/stock_key_config.xml
|
||||||
|
|
|
@ -5,12 +5,12 @@
|
||||||
if [ -x /bin/sysrepoctl ]; then
|
if [ -x /bin/sysrepoctl ]; then
|
||||||
match=$(sysrepoctl -l | grep "ietf-ssh-server ")
|
match=$(sysrepoctl -l | grep "ietf-ssh-server ")
|
||||||
if [ ! "$match" ]; then
|
if [ ! "$match" ]; then
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-ssh-server@2016-11-02.yang -p 600
|
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-ssh-server@2019-07-02.yang -p 600
|
||||||
fi
|
fi
|
||||||
|
|
||||||
match=$(sysrepoctl -l | grep "ietf-tls-server ")
|
match=$(sysrepoctl -l | grep "ietf-tls-server ")
|
||||||
if [ ! "$match" ]; then
|
if [ ! "$match" ]; then
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-tls-server@2016-11-02.yang -p 600
|
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-tls-server@2019-07-02.yang -p 600
|
||||||
fi
|
fi
|
||||||
|
|
||||||
match=$(sysrepoctl -l | grep "iana-crypt-hash ")
|
match=$(sysrepoctl -l | grep "iana-crypt-hash ")
|
||||||
|
@ -25,7 +25,7 @@ if [ -x /bin/sysrepoctl ]; then
|
||||||
|
|
||||||
match=$(sysrepoctl -l | grep "ietf-netconf-server ")
|
match=$(sysrepoctl -l | grep "ietf-netconf-server ")
|
||||||
if [ ! "$match" ]; then
|
if [ ! "$match" ]; then
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-server@2016-11-02.yang -o root:root -p 600
|
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-server@2019-07-02.yang -o root:root -p 600
|
||||||
sysrepoctl -m ietf-netconf-server -e listen
|
sysrepoctl -m ietf-netconf-server -e listen
|
||||||
sysrepoctl -m ietf-netconf-server -e ssh-listen
|
sysrepoctl -m ietf-netconf-server -e ssh-listen
|
||||||
sysrepoctl -m ietf-netconf-server -e tls-listen
|
sysrepoctl -m ietf-netconf-server -e tls-listen
|
||||||
|
@ -46,14 +46,7 @@ if [ -x /bin/sysrepoctl ]; then
|
||||||
|
|
||||||
match=$(sysrepoctl -l | grep "ietf-netconf-with-defaults ")
|
match=$(sysrepoctl -l | grep "ietf-netconf-with-defaults ")
|
||||||
if [ ! "$match" ]; then
|
if [ ! "$match" ]; then
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-with-defaults@2011-06-01.yang -o root:root -p 600
|
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf@2013-09-29.yang -o root:root -p 600
|
||||||
fi
|
|
||||||
|
|
||||||
match=$(sysrepoctl -l | grep "ietf-system ")
|
|
||||||
if [ ! "$match" ]; then
|
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-system@2014-08-06.yang -o root:root -p 600
|
|
||||||
sysrepoctl -m ietf-system -e authentication
|
|
||||||
sysrepoctl -m ietf-system -e local-users
|
|
||||||
fi
|
fi
|
||||||
|
|
||||||
match=$(sysrepoctl -l | grep "ietf-datastores ")
|
match=$(sysrepoctl -l | grep "ietf-datastores ")
|
||||||
|
@ -61,10 +54,6 @@ if [ -x /bin/sysrepoctl ]; then
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-datastores@2017-08-17.yang -o root:root -p 600
|
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-datastores@2017-08-17.yang -o root:root -p 600
|
||||||
fi
|
fi
|
||||||
|
|
||||||
match=$(sysrepoctl -l | grep "ietf-yang-library ")
|
|
||||||
if [ ! "$match" ]; then
|
|
||||||
sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-yang-library@2018-01-17.yang -o root:root -p 600
|
|
||||||
fi
|
|
||||||
fi
|
fi
|
||||||
|
|
||||||
exit 0
|
exit 0
|
||||||
|
|
|
@ -1,68 +0,0 @@
|
||||||
--- /dev/null
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -0,0 +1,5 @@
|
|
||||||
+cmake_minimum_required(VERSION 2.6)
|
|
||||||
+
|
|
||||||
+add_subdirectory(server)
|
|
||||||
+add_subdirectory(cli)
|
|
||||||
+add_subdirectory(keystored)
|
|
||||||
--- a/cli/CMakeLists.txt
|
|
||||||
+++ b/cli/CMakeLists.txt
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
cmake_minimum_required(VERSION 2.6)
|
|
||||||
|
|
||||||
# include custom Modules
|
|
||||||
-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/../CMakeModules/")
|
|
||||||
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/CMakeModules/")
|
|
||||||
|
|
||||||
project(netopeer2-cli C)
|
|
||||||
include(GNUInstallDirs)
|
|
||||||
@@ -84,7 +84,7 @@ endif()
|
|
||||||
install(FILES ${PROJECT_SOURCE_DIR}/doc/${PROJECT_NAME}.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
|
|
||||||
|
|
||||||
# clean cmake cache
|
|
||||||
-add_custom_target(cleancache
|
|
||||||
+add_custom_target(cleancache_cli
|
|
||||||
COMMAND make clean
|
|
||||||
COMMAND find . -iname '*cmake*' -not -name CMakeLists.txt -exec rm -rf {} +
|
|
||||||
COMMAND rm -rf Makefile Doxyfile
|
|
||||||
--- a/keystored/CMakeLists.txt
|
|
||||||
+++ b/keystored/CMakeLists.txt
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
cmake_minimum_required(VERSION 2.6)
|
|
||||||
|
|
||||||
# include custom Modules
|
|
||||||
-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/../CMakeModules/")
|
|
||||||
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/CMakeModules/")
|
|
||||||
|
|
||||||
project(keystored C)
|
|
||||||
include(GNUInstallDirs)
|
|
||||||
@@ -147,7 +147,7 @@ if (SSH_KEY_INSTALL)
|
|
||||||
execute_process(COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/scripts/ssh-key-import.sh)")
|
|
||||||
endif()
|
|
||||||
|
|
||||||
-add_custom_target(install-scripts-ide
|
|
||||||
+add_custom_target(install-scripts-ide-keystored
|
|
||||||
scripts/model-install.sh
|
|
||||||
scripts/ssh-key-import.sh
|
|
||||||
)
|
|
||||||
--- a/server/CMakeLists.txt
|
|
||||||
+++ b/server/CMakeLists.txt
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
cmake_minimum_required(VERSION 2.8.9)
|
|
||||||
|
|
||||||
# include custom Modules
|
|
||||||
-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/../CMakeModules/")
|
|
||||||
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/CMakeModules/")
|
|
||||||
|
|
||||||
project(netopeer2-server C)
|
|
||||||
include(GNUInstallDirs)
|
|
||||||
@@ -208,7 +208,7 @@ if (ENABLE_CONFIGURATION)
|
|
||||||
execute_process(COMMAND ${PROJECT_BINARY_DIR}/model-install.sh)")
|
|
||||||
endif()
|
|
||||||
|
|
||||||
-add_custom_target(install-scripts-ide
|
|
||||||
+add_custom_target(install-scripts-ide-server
|
|
||||||
${PROJECT_BINARY_DIR}/model-install.sh
|
|
||||||
)
|
|
||||||
|
|
11
net/Netopeer2/patches/001-openss_1.1_support.patch
Normal file
11
net/Netopeer2/patches/001-openss_1.1_support.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/cli/commands.c 2020-05-08 16:29:28.284509842 +0300
|
||||||
|
+++ b/cli/commands.c 2020-05-08 16:29:38.856397844 +0300
|
||||||
|
@@ -1725,7 +1725,7 @@
|
||||||
|
BIO_printf(bio_out, "\n");
|
||||||
|
|
||||||
|
BIO_printf(bio_out, "Valid until: ");
|
||||||
|
- ASN1_TIME_print(bio_out, X509_get_notAfter(cert));
|
||||||
|
+ ASN1_TIME_print(bio_out, X509_get0_notAfter(cert));
|
||||||
|
BIO_printf(bio_out, "\n");
|
||||||
|
|
||||||
|
has_san = 0;
|
|
@ -1,16 +0,0 @@
|
||||||
--- a/keystored/CMakeLists.txt
|
|
||||||
+++ b/keystored/CMakeLists.txt
|
|
||||||
@@ -69,6 +69,8 @@ find_package(SYSREPO REQUIRED)
|
|
||||||
target_link_libraries(keystored ${SYSREPO_LIBRARIES})
|
|
||||||
include_directories(${SYSREPO_INCLUDE_DIRS})
|
|
||||||
|
|
||||||
+# skip step because of cross compiling
|
|
||||||
+if (FALSE)
|
|
||||||
# get sysrepo plugins directory
|
|
||||||
if (NOT SR_PLUGINS_DIR)
|
|
||||||
if (PKG_CONFIG_FOUND)
|
|
||||||
@@ -154,3 +156,4 @@ add_custom_target(install-scripts-ide
|
|
||||||
|
|
||||||
# plugins should be installed into sysrepo plugins dir
|
|
||||||
install(TARGETS keystored DESTINATION ${SR_PLUGINS_DIR})
|
|
||||||
+endif()
|
|
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=sysrepo
|
PKG_NAME:=sysrepo
|
||||||
PKG_VERSION:=1.4.2
|
PKG_VERSION:=1.4.58
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/sysrepo/sysrepo/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/sysrepo/sysrepo/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=d84d4f092feab83b0a39fef5d0d62bc6ed1f0f8aa274329f2cbf0a95a6528d8a
|
PKG_HASH:=9c134658a5b812cd86b9113c30fc01be5a094616f473e747032ccf614af9e4dd
|
||||||
|
|
||||||
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
|
||||||
PKG_LICENSE:=Apache-2.0
|
PKG_LICENSE:=Apache-2.0
|
||||||
|
|
Loading…
Reference in a new issue