commit
384703fe06
3 changed files with 0 additions and 81 deletions
|
@ -1,46 +0,0 @@
|
|||
#
|
||||
# Copyright (C) 2017 Lucian Cristian <lucian.cristian@gmail.com>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=clamsmtp
|
||||
PKG_VERSION:=1.10
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE_URL:=http://thewalter.net/stef/software/clamsmtp/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=a52fdb4b26e11ece30c478a806c95b1eda16f4e73937bd560ece7017fb0df92a
|
||||
|
||||
MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
||||
PKG_LICENSE:=GPLv2
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/clamsmtp
|
||||
SECTION:=mail
|
||||
CATEGORY:=Mail
|
||||
DEPENDS:=+libpthread
|
||||
TITLE:=clamsmtp
|
||||
URL:=http://thewalter.net/stef/software/clamsmtp/
|
||||
endef
|
||||
|
||||
define Package/clamsmtp/description
|
||||
ClamSMTP is an SMTP filter that allows you to check for viruses using the ClamAV anti-virus software.
|
||||
endef
|
||||
|
||||
define Package/clamsmtp/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin \
|
||||
$(1)/etc/init.d
|
||||
$(CP) $(PKG_BUILD_DIR)/src/clamsmtpd $(1)/usr/sbin/
|
||||
$(CP) $(PKG_BUILD_DIR)/doc/clamsmtpd.conf $(1)/etc/
|
||||
$(INSTALL_BIN) ./files/clamsmtpd.init $(1)/etc/init.d/clamsmtpd
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,clamsmtp))
|
|
@ -1,16 +0,0 @@
|
|||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2017 Lucian Cristian
|
||||
|
||||
START=91
|
||||
USE_PROCD=1
|
||||
|
||||
PROG=/usr/sbin/clamsmtpd
|
||||
|
||||
start_service(){
|
||||
procd_open_instance
|
||||
procd_set_param command $PROG -p /var/run/clamsmtpd.pid
|
||||
procd_close_instance
|
||||
}
|
||||
service_triggers(){
|
||||
procd_add_reload_trigger "clamsmtpd"
|
||||
}
|
|
@ -1,19 +0,0 @@
|
|||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -78,16 +78,6 @@ AC_CHECK_HEADERS([limits.h err.h paths.h],,)
|
||||
AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h], ,
|
||||
[echo "ERROR: Required C header missing"; exit 1])
|
||||
|
||||
-# Check for linux type transparent proxy support
|
||||
-AC_CHECK_HEADERS([linux/netfilter_ipv4.h],
|
||||
- AC_DEFINE(LINUX_TRANSPARENT_PROXY, 1, [Whether the system supports a linux type transparent proxy]),
|
||||
- ,
|
||||
- [[
|
||||
- #ifdef HAVE_LIMITS_H
|
||||
- #include <limits.h>
|
||||
- #endif
|
||||
- ]] )
|
||||
-
|
||||
# Checks for typedefs, structures, and compiler characteristics.
|
||||
AC_C_CONST
|
||||
AC_TYPE_SIZE_T
|
Loading…
Reference in a new issue