php7: update to 7.2.2
Also refresh patches to reflect new year. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
be1012d242
commit
379f4a9507
3 changed files with 32 additions and 48 deletions
|
@ -6,8 +6,8 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=php
|
PKG_NAME:=php
|
||||||
PKG_VERSION:=7.2.1
|
PKG_VERSION:=7.2.2
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
||||||
|
|
||||||
|
@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||||
PKG_HASH:=6c6cf82fda6660ed963821eb0525214bb3547e8e29f447b9c15b2d8e6efd8822
|
PKG_HASH:=47d7607d38a1d565fc43ea942c92229a7cd165f156737f210937e375b243cb11
|
||||||
|
|
||||||
PKG_FIXUP:=libtool autoreconf
|
PKG_FIXUP:=libtool autoreconf
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -11,11 +11,9 @@ Subject: Add patch to remove build timestamps from generated binaries.
|
||||||
sapi/phpdbg/phpdbg.c | 4 +---
|
sapi/phpdbg/phpdbg.c | 4 +---
|
||||||
6 files changed, 10 insertions(+), 22 deletions(-)
|
6 files changed, 10 insertions(+), 22 deletions(-)
|
||||||
|
|
||||||
diff --git a/ext/standard/info.c b/ext/standard/info.c
|
|
||||||
index e74d6b4..883fbdf 100644
|
|
||||||
--- a/ext/standard/info.c
|
--- a/ext/standard/info.c
|
||||||
+++ b/ext/standard/info.c
|
+++ b/ext/standard/info.c
|
||||||
@@ -865,7 +865,6 @@ PHPAPI void php_print_info(int flag)
|
@@ -830,7 +830,6 @@ PHPAPI void php_print_info(int flag)
|
||||||
php_info_print_box_end();
|
php_info_print_box_end();
|
||||||
php_info_print_table_start();
|
php_info_print_table_start();
|
||||||
php_info_print_table_row(2, "System", ZSTR_VAL(php_uname));
|
php_info_print_table_row(2, "System", ZSTR_VAL(php_uname));
|
||||||
|
@ -23,12 +21,10 @@ index e74d6b4..883fbdf 100644
|
||||||
#ifdef COMPILER
|
#ifdef COMPILER
|
||||||
php_info_print_table_row(2, "Compiler", COMPILER);
|
php_info_print_table_row(2, "Compiler", COMPILER);
|
||||||
#endif
|
#endif
|
||||||
diff --git a/sapi/apache2handler/config.m4 b/sapi/apache2handler/config.m4
|
|
||||||
index f286b1a..fba92b8 100644
|
|
||||||
--- a/sapi/apache2handler/config.m4
|
--- a/sapi/apache2handler/config.m4
|
||||||
+++ b/sapi/apache2handler/config.m4
|
+++ b/sapi/apache2handler/config.m4
|
||||||
@@ -59,18 +59,9 @@ if test "$PHP_APXS2" != "no"; then
|
@@ -67,18 +67,9 @@ if test "$PHP_APXS2" != "no"; then
|
||||||
APACHE_CFLAGS="$APACHE_CPPFLAGS -I$APXS_INCLUDEDIR $APR_CFLAGS $APU_CFLAGS -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1"
|
fi
|
||||||
|
|
||||||
APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
|
APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
|
||||||
- if test -z `$APXS -q SYSCONFDIR`; then
|
- if test -z `$APXS -q SYSCONFDIR`; then
|
||||||
|
@ -49,63 +45,55 @@ index f286b1a..fba92b8 100644
|
||||||
|
|
||||||
case $host_alias in
|
case $host_alias in
|
||||||
*aix*)
|
*aix*)
|
||||||
diff --git a/sapi/cgi/cgi_main.c b/sapi/cgi/cgi_main.c
|
|
||||||
index 0b6deb1..bb9014a 100644
|
|
||||||
--- a/sapi/cgi/cgi_main.c
|
--- a/sapi/cgi/cgi_main.c
|
||||||
+++ b/sapi/cgi/cgi_main.c
|
+++ b/sapi/cgi/cgi_main.c
|
||||||
@@ -2342,9 +2342,9 @@ consult the installation file that came with this distribution, or visit \n\
|
@@ -2427,9 +2427,9 @@ consult the installation file that came
|
||||||
SG(request_info).no_headers = 1;
|
SG(request_info).no_headers = 1;
|
||||||
}
|
}
|
||||||
#if ZEND_DEBUG
|
#if ZEND_DEBUG
|
||||||
- php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
- php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
||||||
+ php_printf("PHP %s (%s) (DEBUG)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
+ php_printf("PHP %s (%s) (DEBUG)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
||||||
#else
|
#else
|
||||||
- php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
- php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
||||||
+ php_printf("PHP %s (%s)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
+ php_printf("PHP %s (%s)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
||||||
#endif
|
#endif
|
||||||
php_request_shutdown((void *) 0);
|
php_request_shutdown((void *) 0);
|
||||||
fcgi_shutdown();
|
fcgi_shutdown();
|
||||||
diff --git a/sapi/cli/php_cli.c b/sapi/cli/php_cli.c
|
|
||||||
index dc92045..bb28364 100644
|
|
||||||
--- a/sapi/cli/php_cli.c
|
--- a/sapi/cli/php_cli.c
|
||||||
+++ b/sapi/cli/php_cli.c
|
+++ b/sapi/cli/php_cli.c
|
||||||
@@ -690,8 +690,8 @@ static int do_cli(int argc, char **argv) /* {{{ */
|
@@ -697,8 +697,8 @@ static int do_cli(int argc, char **argv)
|
||||||
goto out;
|
goto out;
|
||||||
|
|
||||||
case 'v': /* show php version & quit */
|
case 'v': /* show php version & quit */
|
||||||
- php_printf("PHP %s (%s) (built: %s %s) ( %s)\nCopyright (c) 1997-2017 The PHP Group\n%s",
|
- php_printf("PHP %s (%s) (built: %s %s) ( %s)\nCopyright (c) 1997-2018 The PHP Group\n%s",
|
||||||
- PHP_VERSION, cli_sapi_module.name, __DATE__, __TIME__,
|
- PHP_VERSION, cli_sapi_module.name, __DATE__, __TIME__,
|
||||||
+ php_printf("PHP %s (%s) ( %s)\nCopyright (c) 1997-2017 The PHP Group\n%s",
|
+ php_printf("PHP %s (%s) ( %s)\nCopyright (c) 1997-2018 The PHP Group\n%s",
|
||||||
+ PHP_VERSION, cli_sapi_module.name,
|
+ PHP_VERSION, cli_sapi_module.name,
|
||||||
#if ZTS
|
#if ZTS
|
||||||
"ZTS "
|
"ZTS "
|
||||||
#else
|
#else
|
||||||
diff --git a/sapi/fpm/fpm/fpm_main.c b/sapi/fpm/fpm/fpm_main.c
|
|
||||||
index 6768113..545c52e 100644
|
|
||||||
--- a/sapi/fpm/fpm/fpm_main.c
|
--- a/sapi/fpm/fpm/fpm_main.c
|
||||||
+++ b/sapi/fpm/fpm/fpm_main.c
|
+++ b/sapi/fpm/fpm/fpm_main.c
|
||||||
@@ -1756,9 +1756,9 @@ int main(int argc, char *argv[])
|
@@ -1755,9 +1755,9 @@ int main(int argc, char *argv[])
|
||||||
SG(request_info).no_headers = 1;
|
SG(request_info).no_headers = 1;
|
||||||
|
|
||||||
#if ZEND_DEBUG
|
#if ZEND_DEBUG
|
||||||
- php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
- php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
||||||
+ php_printf("PHP %s (%s) (DEBUG)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
+ php_printf("PHP %s (%s) (DEBUG)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
||||||
#else
|
#else
|
||||||
- php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
- php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
||||||
+ php_printf("PHP %s (%s)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
+ php_printf("PHP %s (%s)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
||||||
#endif
|
#endif
|
||||||
php_request_shutdown((void *) 0);
|
php_request_shutdown((void *) 0);
|
||||||
fcgi_shutdown();
|
fcgi_shutdown();
|
||||||
diff --git a/sapi/phpdbg/phpdbg.c b/sapi/phpdbg/phpdbg.c
|
|
||||||
index b47c7c8..ab94bba 100644
|
|
||||||
--- a/sapi/phpdbg/phpdbg.c
|
--- a/sapi/phpdbg/phpdbg.c
|
||||||
+++ b/sapi/phpdbg/phpdbg.c
|
+++ b/sapi/phpdbg/phpdbg.c
|
||||||
@@ -1699,10 +1699,8 @@ phpdbg_main:
|
@@ -1697,10 +1697,8 @@ phpdbg_main:
|
||||||
phpdbg_do_help_cmd(exec);
|
phpdbg_do_help_cmd(exec);
|
||||||
} else if (show_version) {
|
} else if (show_version) {
|
||||||
phpdbg_out(
|
phpdbg_out(
|
||||||
- "phpdbg %s (built: %s %s)\nPHP %s, Copyright (c) 1997-2017 The PHP Group\n%s",
|
- "phpdbg %s (built: %s %s)\nPHP %s, Copyright (c) 1997-2018 The PHP Group\n%s",
|
||||||
+ "phpdbg %s\nPHP %s, Copyright (c) 1997-2017 The PHP Group\n%s",
|
+ "phpdbg %s\nPHP %s, Copyright (c) 1997-2018 The PHP Group\n%s",
|
||||||
PHPDBG_VERSION,
|
PHPDBG_VERSION,
|
||||||
- __DATE__,
|
- __DATE__,
|
||||||
- __TIME__,
|
- __TIME__,
|
||||||
|
|
|
@ -1,8 +1,6 @@
|
||||||
Index: php-7.1.12/ext/opcache/ZendAccelerator.c
|
--- a/ext/opcache/ZendAccelerator.c
|
||||||
===================================================================
|
+++ b/ext/opcache/ZendAccelerator.c
|
||||||
--- php-7.1.12.orig/ext/opcache/ZendAccelerator.c
|
@@ -2456,11 +2456,6 @@ static void accel_gen_system_id(void)
|
||||||
+++ php-7.1.12/ext/opcache/ZendAccelerator.c
|
|
||||||
@@ -2604,11 +2604,6 @@ static void accel_gen_system_id(void)
|
|
||||||
PHP_MD5Update(&context, PHP_VERSION, sizeof(PHP_VERSION)-1);
|
PHP_MD5Update(&context, PHP_VERSION, sizeof(PHP_VERSION)-1);
|
||||||
PHP_MD5Update(&context, ZEND_EXTENSION_BUILD_ID, sizeof(ZEND_EXTENSION_BUILD_ID)-1);
|
PHP_MD5Update(&context, ZEND_EXTENSION_BUILD_ID, sizeof(ZEND_EXTENSION_BUILD_ID)-1);
|
||||||
PHP_MD5Update(&context, ZEND_BIN_ID, sizeof(ZEND_BIN_ID)-1);
|
PHP_MD5Update(&context, ZEND_BIN_ID, sizeof(ZEND_BIN_ID)-1);
|
||||||
|
@ -14,19 +12,17 @@ Index: php-7.1.12/ext/opcache/ZendAccelerator.c
|
||||||
PHP_MD5Final(digest, &context);
|
PHP_MD5Final(digest, &context);
|
||||||
for (i = 0; i < 16; i++) {
|
for (i = 0; i < 16; i++) {
|
||||||
c = digest[i] >> 4;
|
c = digest[i] >> 4;
|
||||||
Index: php-7.1.12/sapi/litespeed/lsapi_main.c
|
--- a/sapi/litespeed/lsapi_main.c
|
||||||
===================================================================
|
+++ b/sapi/litespeed/lsapi_main.c
|
||||||
--- php-7.1.12.orig/sapi/litespeed/lsapi_main.c
|
@@ -1034,9 +1034,9 @@ static int cli_main( int argc, char * ar
|
||||||
+++ php-7.1.12/sapi/litespeed/lsapi_main.c
|
|
||||||
@@ -1036,9 +1036,9 @@ static int cli_main( int argc, char * ar
|
|
||||||
case 'v':
|
case 'v':
|
||||||
if (php_request_startup() != FAILURE) {
|
if (php_request_startup() != FAILURE) {
|
||||||
#if ZEND_DEBUG
|
#if ZEND_DEBUG
|
||||||
- php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
- php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
||||||
+ php_printf("PHP %s (%s) (DEBUG)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
+ php_printf("PHP %s (%s) (DEBUG)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
||||||
#else
|
#else
|
||||||
- php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
- php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
|
||||||
+ php_printf("PHP %s (%s)\nCopyright (c) 1997-2017 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
+ php_printf("PHP %s (%s)\nCopyright (c) 1997-2018 The PHP Group\n%s", PHP_VERSION, sapi_module.name, get_zend_version());
|
||||||
#endif
|
#endif
|
||||||
#ifdef PHP_OUTPUT_NEWAPI
|
#ifdef PHP_OUTPUT_NEWAPI
|
||||||
php_output_end_all();
|
php_output_end_all();
|
||||||
|
|
Loading…
Reference in a new issue