vsftpd: update to 3.0.4
Switch to AUTORELEASE for simplicity. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
9477468efe
commit
3737c84bbd
3 changed files with 8 additions and 8 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=vsftpd
|
PKG_NAME:=vsftpd
|
||||||
PKG_VERSION:=3.0.3
|
PKG_VERSION:=3.0.4
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://security.appspot.com/downloads/
|
PKG_SOURCE_URL:=https://security.appspot.com/downloads/
|
||||||
PKG_HASH:=9d4d2bf6e6e2884852ba4e69e157a2cecd68c5a7635d66a3a8cf8d898c955ef7
|
PKG_HASH:=6b9421bd27e8a6cdeed5b31154f294a20b003a11a26c09500715a0a6b1b86a26
|
||||||
|
|
||||||
PKG_MAINTAINER:=Cezary Jackiewicz <cezary@eko.one.pl>
|
PKG_MAINTAINER:=Cezary Jackiewicz <cezary@eko.one.pl>
|
||||||
PKG_LICENSE:=GPLv2
|
PKG_LICENSE:=GPLv2
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/tunables.c
|
--- a/tunables.c
|
||||||
+++ b/tunables.c
|
+++ b/tunables.c
|
||||||
@@ -254,7 +254,7 @@ tunables_load_defaults()
|
@@ -261,7 +261,7 @@ tunables_load_defaults()
|
||||||
/* -rw------- */
|
/* -rw------- */
|
||||||
tunable_chown_upload_mode = 0600;
|
tunable_chown_upload_mode = 0600;
|
||||||
|
|
||||||
|
|
|
@ -20,7 +20,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||||
#include <errno.h>
|
#include <errno.h>
|
||||||
#include <limits.h>
|
#include <limits.h>
|
||||||
|
|
||||||
@@ -59,8 +62,12 @@ ssl_init(struct vsf_session* p_sess)
|
@@ -66,8 +69,12 @@ ssl_init(struct vsf_session* p_sess)
|
||||||
SSL_CTX* p_ctx;
|
SSL_CTX* p_ctx;
|
||||||
long options;
|
long options;
|
||||||
int verify_option = 0;
|
int verify_option = 0;
|
||||||
|
@ -33,7 +33,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||||
if (p_ctx == NULL)
|
if (p_ctx == NULL)
|
||||||
{
|
{
|
||||||
die("SSL: could not allocate SSL context");
|
die("SSL: could not allocate SSL context");
|
||||||
@@ -120,6 +127,7 @@ ssl_init(struct vsf_session* p_sess)
|
@@ -139,6 +146,7 @@ ssl_init(struct vsf_session* p_sess)
|
||||||
{
|
{
|
||||||
die("SSL: RNG is not seeded");
|
die("SSL: RNG is not seeded");
|
||||||
}
|
}
|
||||||
|
@ -41,7 +41,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||||
{
|
{
|
||||||
EC_KEY* key = EC_KEY_new_by_curve_name(NID_X9_62_prime256v1);
|
EC_KEY* key = EC_KEY_new_by_curve_name(NID_X9_62_prime256v1);
|
||||||
if (key == NULL)
|
if (key == NULL)
|
||||||
@@ -129,6 +137,7 @@ ssl_init(struct vsf_session* p_sess)
|
@@ -148,6 +156,7 @@ ssl_init(struct vsf_session* p_sess)
|
||||||
SSL_CTX_set_tmp_ecdh(p_ctx, key);
|
SSL_CTX_set_tmp_ecdh(p_ctx, key);
|
||||||
EC_KEY_free(key);
|
EC_KEY_free(key);
|
||||||
}
|
}
|
||||||
|
@ -49,7 +49,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||||
if (tunable_ssl_request_cert)
|
if (tunable_ssl_request_cert)
|
||||||
{
|
{
|
||||||
verify_option |= SSL_VERIFY_PEER;
|
verify_option |= SSL_VERIFY_PEER;
|
||||||
@@ -660,7 +669,9 @@ ssl_cert_digest(SSL* p_ssl, struct vsf_s
|
@@ -685,7 +694,9 @@ ssl_cert_digest(SSL* p_ssl, struct vsf_s
|
||||||
static char*
|
static char*
|
||||||
get_ssl_error()
|
get_ssl_error()
|
||||||
{
|
{
|
||||||
|
|
Loading…
Reference in a new issue