picocom: Update to 3.1
Switched to new upstream. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
0264b90152
commit
35d51936c8
3 changed files with 17 additions and 22 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=picocom
|
||||
PKG_VERSION:=1.7
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/picocom
|
||||
PKG_HASH:=d0f31c8f7a215a76922d30c81a52b9a2348c89e02a84935517002b3bc2c1129e
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/npat-efault/picocom/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=e6761ca932ffc6d09bd6b11ff018bdaf70b287ce518b3282d29e0270e88420bb
|
||||
|
||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
|
@ -24,7 +24,7 @@ define Package/picocom
|
|||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=A minimal dumb-terminal emulation program
|
||||
URL:=http://code.google.com/p/picocom/
|
||||
URL:=https://github.com/npat-efault/picocom
|
||||
SUBMENU:=Terminal
|
||||
endef
|
||||
|
||||
|
|
12
utils/picocom/patches/010-fix-compile.patch
Normal file
12
utils/picocom/patches/010-fix-compile.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff --git a/Makefile b/Makefile
|
||||
index d6a4d60..a07d801 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -51,7 +51,6 @@ linenoise-1.0/linenoise.o : linenoise-1.0/linenoise.c linenoise-1.0/linenoise.h
|
||||
|
||||
OBJS += picocom.o term.o fdio.o split.o termios2.o custbaud_bsd.o
|
||||
picocom : $(OBJS)
|
||||
- $(LD) $(LDFLAGS) -o $@ $(OBJS) $(LDLIBS)
|
||||
|
||||
picocom.o : picocom.c term.h fdio.h split.h custbaud.h
|
||||
term.o : term.c term.h termios2.h custbaud_bsd.h custbaud.h
|
|
@ -1,17 +0,0 @@
|
|||
Index: picocom-1.7/term.c
|
||||
===================================================================
|
||||
--- picocom-1.7.orig/term.c
|
||||
+++ picocom-1.7/term.c
|
||||
@@ -33,10 +33,11 @@
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
#include <unistd.h>
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) && (defined(__GLIBC__) || defined(__UCLIBC__))
|
||||
#include <termio.h>
|
||||
#else
|
||||
#include <termios.h>
|
||||
+#include <sys/ioctl.h>
|
||||
#endif /* of __linux__ */
|
||||
|
||||
#include "term.h"
|
Loading…
Reference in a new issue