avrdude: add no timestamp patch to make it reproducible
The no-cpp-timestamp patch taken from debian and is already accepted upstream. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
This commit is contained in:
parent
a2de0d04b4
commit
35bf4d15d4
2 changed files with 22 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=avrdude
|
||||
PKG_VERSION:=6.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
|
||||
|
|
21
utils/avrdude/patches/020-no-cpp-timestamps.patch
Normal file
21
utils/avrdude/patches/020-no-cpp-timestamps.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
Description: no CPP macro timestamps
|
||||
Reporducible builds project support, see:
|
||||
http://wiki.debian.org/ReproducibleBuilds/TimestampsFromCPPMacros
|
||||
Author: Milan Kupcevic <milan@debian.org>
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
--- a/main.c
|
||||
+++ b/main.c
|
||||
@@ -679,10 +679,10 @@
|
||||
* Print out an identifying string so folks can tell what version
|
||||
* they are running
|
||||
*/
|
||||
- avrdude_message(MSG_NOTICE, "\n%s: Version %s, compiled on %s at %s\n"
|
||||
+ avrdude_message(MSG_NOTICE, "\n%s: Version %s\n"
|
||||
"%sCopyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/\n"
|
||||
"%sCopyright (c) 2007-2014 Joerg Wunsch\n\n",
|
||||
- progname, version, __DATE__, __TIME__, progbuf, progbuf);
|
||||
+ progname, version, progbuf, progbuf);
|
||||
avrdude_message(MSG_NOTICE, "%sSystem wide configuration file is \"%s\"\n",
|
||||
progbuf, sys_config);
|
||||
|
Loading…
Reference in a new issue