vim: Update Vim to 8.0.069
Vim stable is at version 8 now Signed-off-by: Shane Peelar <lookatyouhacker@gmail.com>
This commit is contained in:
parent
91b140bdcf
commit
33b52a63e9
2 changed files with 4 additions and 45 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vim
|
||||
PKG_VERSION:=7.4
|
||||
PKG_RELEASE:=3
|
||||
VIMVER:=74
|
||||
PKG_VERSION:=8.0.069
|
||||
PKG_RELEASE:=4
|
||||
VIMVER:=80
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix/
|
||||
PKG_MD5SUM:=607e135c559be642f210094ad023dc65
|
||||
PKG_MD5SUM:=457543a7754b0d3c1c0aa4d4c3bb4070
|
||||
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)$(VIMVER)
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
--- a/src/auto/configure
|
||||
+++ b/src/auto/configure
|
||||
@@ -12294,37 +12294,8 @@ _ACEOF
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking uint32_t is 32 bits" >&5
|
||||
$as_echo_n "checking uint32_t is 32 bits... " >&6; }
|
||||
-if test "$cross_compiling" = yes; then :
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: cannot check uint32_t when cross-compiling." >&5
|
||||
-$as_echo "$as_me: WARNING: cannot check uint32_t when cross-compiling." >&2;}
|
||||
-else
|
||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-#ifdef HAVE_STDINT_H
|
||||
-# include <stdint.h>
|
||||
-#endif
|
||||
-#ifdef HAVE_INTTYPES_H
|
||||
-# include <inttypes.h>
|
||||
-#endif
|
||||
-main() {
|
||||
- uint32_t nr1 = (uint32_t)-1;
|
||||
- uint32_t nr2 = (uint32_t)0xffffffffUL;
|
||||
- if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) exit(1);
|
||||
- exit(0);
|
||||
-}
|
||||
-_ACEOF
|
||||
-if ac_fn_c_try_run "$LINENO"; then :
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: ok" >&5
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: assuming ok" >&5
|
||||
$as_echo "ok" >&6; }
|
||||
-else
|
||||
- as_fn_error "WRONG! uint32_t not defined correctly." "$LINENO" 5
|
||||
-fi
|
||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext \
|
||||
- conftest.$ac_objext conftest.beam conftest.$ac_ext
|
||||
-fi
|
||||
-
|
||||
-
|
||||
|
||||
bcopy_test_prog='
|
||||
#include "confdefs.h"
|
Loading…
Reference in a new issue