libflac: update to 1.3.2, refresh patches
No mention of sigemptyset seen in source code; dropped patch Signed-off-by: Ian Leonard <antonlacon@gmail.com>
This commit is contained in:
parent
557485abfc
commit
32e6240b5c
5 changed files with 8 additions and 19 deletions
|
@ -8,12 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=flac
|
||||
PKG_VERSION:=1.3.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/flac/
|
||||
PKG_MD5SUM:=b9922c9a0378c88d3e901b234f852698
|
||||
PKG_MD5SUM:=454f1bfa3f93cc708098d7890d0499bd
|
||||
PKG_HASH:=91cfc3ed61dc40f47f050a109b08610667d73477af6ef36dcad31c31a4a8d53f
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -4,7 +4,7 @@
|
|||
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
-SUBDIRS = doc include m4 man src examples test build objs
|
||||
-SUBDIRS = doc include m4 man src examples test build objs microbench
|
||||
+SUBDIRS = include m4 src build objs
|
||||
|
||||
EXTRA_DIST = \
|
||||
|
|
|
@ -2,8 +2,8 @@
|
|||
+++ b/src/Makefile.am
|
||||
@@ -27,10 +27,7 @@ endif
|
||||
SUBDIRS = \
|
||||
share \
|
||||
libFLAC \
|
||||
share \
|
||||
- flac \
|
||||
- metaflac \
|
||||
$(XMMS_DIRS) \
|
||||
|
|
|
@ -1,16 +1,15 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -348,11 +348,11 @@ fi
|
||||
@@ -386,10 +386,11 @@ fi
|
||||
|
||||
if test "x$debug" = xtrue; then
|
||||
CPPFLAGS="-DDEBUG $CPPFLAGS"
|
||||
- CFLAGS=$(echo "$CFLAGS" | sed 's/-g//')
|
||||
- CFLAGS="-g $CFLAGS"
|
||||
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-g[0-9]*//')
|
||||
+ CFLAGS="-g3 $CFLAGS"
|
||||
else
|
||||
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
||||
- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g//')
|
||||
- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//')
|
||||
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g[0-9]*//')
|
||||
CFLAGS="-O3 -funroll-loops $CFLAGS"
|
||||
fi
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/libFLAC/cpu.c
|
||||
+++ b/src/libFLAC/cpu.c
|
||||
@@ -243,7 +243,7 @@ void FLAC__cpu_info(FLAC__CPUInfo *info)
|
||||
struct sigaction sigill_save;
|
||||
struct sigaction sigill_sse;
|
||||
sigill_sse.sa_sigaction = sigill_handler_sse_os;
|
||||
- __sigemptyset(&sigill_sse.sa_mask);
|
||||
+ sigemptyset(&sigill_sse.sa_mask);
|
||||
sigill_sse.sa_flags = SA_SIGINFO | SA_RESETHAND; /* SA_RESETHAND just in case our SIGILL return jump breaks, so we don't get stuck in a loop */
|
||||
if(0 == sigaction(SIGILL, &sigill_sse, &sigill_save))
|
||||
{
|
Loading…
Reference in a new issue