commit
31d37ec6d5
9 changed files with 17 additions and 103 deletions
|
@ -7,13 +7,13 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
SRC_NAME:=libselinux
|
||||
PKG_NAME:=python3-$(SRC_NAME)
|
||||
PKG_VERSION:=3.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/python-libselinux/$(SRC_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(SRC_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
|
||||
PKG_HASH:=ea5dcbb4d859e3f999c26a13c630da2f16dff9462e3cc8cb7b458ac157d112e7
|
||||
PKG_HASH:=df758ef1d9d4811051dd901ea6b029ae334ffd7c671c128beb16bce1e25ac161
|
||||
PKG_BUILD_DEPENDS:=swig/host
|
||||
|
||||
PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -131,7 +131,7 @@ SWIGRUBY = swig -Wall -ruby -o $(SWIGRUB
|
||||
@@ -139,7 +139,7 @@ SWIGRUBY = swig -Wall -ruby -o $(SWIGRUB
|
||||
all: $(LIBA) $(LIBSO) $(LIBPC)
|
||||
|
||||
pywrap: all selinuxswig_python_exception.i
|
||||
|
|
|
@ -1,66 +0,0 @@
|
|||
From 398d2ceef92cb1baac18e6b34a1a8e1bf41296cd Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Iooss <nicolas.iooss@m4x.org>
|
||||
Date: Tue, 16 Feb 2021 22:13:28 +0100
|
||||
Subject: [PATCH] libselinux: rename gettid() to something which never
|
||||
conflicts with the libc
|
||||
|
||||
Musl recently added a wrapper for gettid() syscall. There is no way to
|
||||
detect this new version in a reliable way, so rename our gettid()
|
||||
wrapper to a non-conflicting name.
|
||||
|
||||
Introduce a new function which, when using a libc known to provide a
|
||||
wrapper for gettid(), calls it, and which, otherwise, performs the
|
||||
syscall directly.
|
||||
|
||||
Anyway this function is only used on systems where /proc/thread-self
|
||||
does not exist, which are therefore running Linux<3.17.
|
||||
|
||||
Fixes: https://github.com/SELinuxProject/selinux/issues/282
|
||||
Signed-off-by: Nicolas Iooss <nicolas.iooss@m4x.org>
|
||||
Acked-by: Petr Lautrbach <plautrba@redhat.com>
|
||||
---
|
||||
src/procattr.c | 18 ++++++++++--------
|
||||
1 file changed, 10 insertions(+), 8 deletions(-)
|
||||
|
||||
--- a/src/procattr.c
|
||||
+++ b/src/procattr.c
|
||||
@@ -25,21 +25,23 @@ static __thread char destructor_initiali
|
||||
/* Bionic and glibc >= 2.30 declare gettid() system call wrapper in unistd.h and
|
||||
* has a definition for it */
|
||||
#ifdef __BIONIC__
|
||||
- #define OVERRIDE_GETTID 0
|
||||
+ #define HAVE_GETTID 1
|
||||
#elif !defined(__GLIBC_PREREQ)
|
||||
- #define OVERRIDE_GETTID 1
|
||||
+ #define HAVE_GETTID 0
|
||||
#elif !__GLIBC_PREREQ(2,30)
|
||||
- #define OVERRIDE_GETTID 1
|
||||
+ #define HAVE_GETTID 0
|
||||
#else
|
||||
- #define OVERRIDE_GETTID 0
|
||||
+ #define HAVE_GETTID 1
|
||||
#endif
|
||||
|
||||
-#if OVERRIDE_GETTID
|
||||
-static pid_t gettid(void)
|
||||
+static pid_t selinux_gettid(void)
|
||||
{
|
||||
+#if HAVE_GETTID
|
||||
+ return gettid();
|
||||
+#else
|
||||
return syscall(__NR_gettid);
|
||||
-}
|
||||
#endif
|
||||
+}
|
||||
|
||||
static void procattr_thread_destructor(void __attribute__((unused)) *unused)
|
||||
{
|
||||
@@ -94,7 +96,7 @@ static int openattr(pid_t pid, const cha
|
||||
if (fd >= 0 || errno != ENOENT)
|
||||
goto out;
|
||||
free(path);
|
||||
- tid = gettid();
|
||||
+ tid = selinux_gettid();
|
||||
rc = asprintf(&path, "/proc/self/task/%d/attr/%s", tid, attr);
|
||||
} else {
|
||||
errno = EINVAL;
|
|
@ -7,13 +7,13 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
SRC_NAME:=libsemanage
|
||||
PKG_NAME:=python3-$(SRC_NAME)
|
||||
PKG_VERSION:=3.1
|
||||
PKG_VERSION:=3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/python-libsemanage/$(SRC_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(SRC_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
|
||||
PKG_HASH:=22d6c75526e40d1781c30bcf29abf97171bdfe6780923f11c8e1c76a75a21ff8
|
||||
PKG_HASH:=d722a55ca4fe2d4e2b30527720db657e6238b28079e69e2e4affeb8e733ee511
|
||||
PKG_BUILD_DEPENDS:=swig/host
|
||||
|
||||
PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
|
|
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=selinux-python
|
||||
PKG_VERSION:=3.1
|
||||
PKG_VERSION:=3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
|
||||
PKG_HASH:=f4d0a1a030bc291a6af498b26e0676b745075dd289a8ba16cdec86c3ea8f2f02
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
|
||||
PKG_HASH:=770855ea8120ef23007fdb9db94b1ed6e8cd77917b584ed8877bbee9c16e74fb
|
||||
|
||||
PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
|
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=semodule-utils
|
||||
PKG_VERSION:=3.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
|
||||
PKG_HASH:=0cc37f9cec751d9c2abb5f2b228b060567e973cb47c19b53b8a4a7378baaa853
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
|
||||
PKG_HASH:=be155654883c8dc4d05493e04a3eb9e56d28803009f1fdd721d42c68b878f757
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
|
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=setools
|
||||
PKG_VERSION:=4.3.0
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=4.4.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/setools/releases/download/4.3.0
|
||||
PKG_HASH:=315df3ae0eb29b399123c5e3330480c5d1c0da038671c9fd62a439c49a6f9105
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/setools/releases/download/$(PKG_VERSION)
|
||||
PKG_HASH:=f3786677e40b7f16a226f48f233dcf835e700739614a7dbed2ff61cc9607814e
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/setools
|
||||
|
||||
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=Cython # Cython>=0.27
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -109,7 +109,6 @@ ext_py_mods = [Extension('setools.policy
|
||||
extra_compile_args=['-Werror', '-Wextra',
|
||||
'-Waggregate-return',
|
||||
'-Wfloat-equal',
|
||||
- '-Wformat', '-Wformat=2',
|
||||
'-Winit-self',
|
||||
'-Wmissing-format-attribute',
|
||||
'-Wmissing-include-dirs',
|
|
@ -1,10 +0,0 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -125,6 +125,7 @@ ext_py_mods = [Extension('setools.policy
|
||||
'-Wno-unreachable-code',
|
||||
'-Wno-implicit-fallthrough',
|
||||
'-Wno-cast-function-type',
|
||||
+ '-Wno-deprecated-declarations',
|
||||
'-fno-exceptions'])]
|
||||
|
||||
installed_data = [('share/man/man1', glob.glob("man/*.1"))]
|
Loading…
Reference in a new issue