redis: update to version 6.0.9
Patches were adjusted to the new version. Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
This commit is contained in:
parent
6e3c3c4b7c
commit
3171299888
3 changed files with 14 additions and 16 deletions
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=redis
|
||||
PKG_VERSION:=6.0.8
|
||||
PKG_VERSION:=6.0.9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=http://download.redis.io/releases/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=04fa1fddc39bd1aecb6739dd5dd73858a3515b427acd1e2947a66dadce868d68
|
||||
PKG_HASH:=dc2bdcf81c620e9f09cfd12e85d3bc631c897b2db7a55218fd8a65eaa37f86dd
|
||||
|
||||
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
Index: redis-5.0.0/src/atomicvar.h
|
||||
===================================================================
|
||||
--- redis-5.0.0.orig/src/atomicvar.h
|
||||
+++ redis-5.0.0/src/atomicvar.h
|
||||
--- a/src/atomicvar.h
|
||||
+++ b/src/atomicvar.h
|
||||
@@ -68,7 +68,7 @@
|
||||
* is reported. */
|
||||
// #define __ATOMIC_VAR_FORCE_SYNC_MACROS
|
||||
|
|
|
@ -11,13 +11,13 @@
|
|||
#ifdef __APPLE__
|
||||
#include <AvailabilityMacros.h>
|
||||
#endif
|
||||
@@ -62,9 +66,9 @@
|
||||
@@ -63,9 +67,9 @@
|
||||
#endif
|
||||
|
||||
/* Test for backtrace() */
|
||||
-#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || \
|
||||
+#if (defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || \
|
||||
defined(__FreeBSD__) || (defined(__OpenBSD__) && defined(USE_BACKTRACE))\
|
||||
defined(__FreeBSD__) || ((defined(__OpenBSD__) || defined(__NetBSD__)) && defined(USE_BACKTRACE))\
|
||||
- || defined(__DragonFly__)
|
||||
+ || defined(__DragonFly__)) && !defined(__UCLIBC__)
|
||||
#define HAVE_BACKTRACE 1
|
||||
|
|
Loading…
Reference in a new issue