postgresql: update to version 14.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
494a13dd23
commit
30dabb07ae
6 changed files with 24 additions and 16 deletions
|
@ -5,7 +5,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=postgresql
|
||||
PKG_VERSION:=13.4
|
||||
PKG_VERSION:=14.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=PostgreSQL
|
||||
|
@ -17,7 +17,7 @@ PKG_SOURCE_URL:=\
|
|||
http://ftp.postgresql.org/pub/source/v$(PKG_VERSION) \
|
||||
ftp://ftp.postgresql.org/pub/source/v$(PKG_VERSION)
|
||||
|
||||
PKG_HASH:=ea93e10390245f1ce461a54eb5f99a48d8cabd3a08ce4d652ec2169a357bc0cd
|
||||
PKG_HASH:=ee2ad79126a7375e9102c4db77c4acae6ae6ffe3e082403b88826d96d927a122
|
||||
|
||||
PKG_USE_MIPS16:=0
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
@ -82,18 +82,23 @@ PostgreSQL databases Server.
|
|||
endef
|
||||
|
||||
PGSQL_SERVER_BIN := \
|
||||
pg_amcheck \
|
||||
pg_archivecleanup \
|
||||
pg_basebackup \
|
||||
pg_checksums \
|
||||
pg_controldata \
|
||||
pg_ctl \
|
||||
pg_dump \
|
||||
pg_dumpall \
|
||||
pg_isready \
|
||||
pg_recvlogical \
|
||||
pg_receivewal \
|
||||
pg_resetwal \
|
||||
pg_restore \
|
||||
pg_standby \
|
||||
pg_rewind \
|
||||
pg_upgrade \
|
||||
pg_verifybackup \
|
||||
pg_waldump \
|
||||
postgres \
|
||||
initdb
|
||||
|
||||
|
@ -103,14 +108,17 @@ PGSQL_CLI_EXTRA_BIN := \
|
|||
createuser \
|
||||
dropdb \
|
||||
dropuser \
|
||||
oid2name \
|
||||
pgbench \
|
||||
reindexdb \
|
||||
vacuumdb
|
||||
vacuumdb \
|
||||
vacuumlo
|
||||
|
||||
PGSQL_CONFIG_VARS:= \
|
||||
pgac_cv_snprintf_long_long_int_format="%lld" \
|
||||
pgac_cv_snprintf_size_t_support=yes \
|
||||
USE_DEV_URANDOM=1 \
|
||||
ac_cv_file__dev_urandom="/dev/urandom" \
|
||||
ZIC=zic
|
||||
|
||||
ifeq ($(CONFIG_USE_UCLIBC),y)
|
||||
|
|
|
@ -7,5 +7,5 @@
|
|||
-$(call recurse,all install,src config)
|
||||
+$(call recurse,all install,src config contrib)
|
||||
|
||||
all:
|
||||
+@echo "All of PostgreSQL successfully made. Ready to install."
|
||||
docs:
|
||||
$(MAKE) -C doc all
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/port/Makefile
|
||||
+++ b/src/port/Makefile
|
||||
@@ -82,6 +82,7 @@ uninstall:
|
||||
@@ -84,6 +84,7 @@ uninstall:
|
||||
libpgport.a: $(OBJS)
|
||||
rm -f $@
|
||||
$(AR) $(AROPT) $@ $^
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/Makefile.shlib
|
||||
+++ b/src/Makefile.shlib
|
||||
@@ -387,14 +387,27 @@ endif # PORTNAME == cygwin || PORTNAME =
|
||||
@@ -391,14 +391,27 @@ endif # PORTNAME == cygwin || PORTNAME =
|
||||
|
||||
|
||||
%.pc: $(MAKEFILE_LIST)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -2019,9 +2019,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2091,9 +2091,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
|
||||
# flags. If not, check if adding -march=armv8-a+crc flag helps.
|
||||
# CFLAGS_ARMV8_CRC32C is set if the extra flag is required.
|
||||
PGAC_ARMV8_CRC32C_INTRINSICS([])
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
static char *argv0 = NULL;
|
||||
static bool allow_core_files = false;
|
||||
static time_t start_time;
|
||||
@@ -2055,6 +2056,9 @@ do_help(void)
|
||||
@@ -2049,6 +2050,9 @@ do_help(void)
|
||||
#endif
|
||||
printf(_(" -s, --silent only print errors, no informational messages\n"));
|
||||
printf(_(" -t, --timeout=SECS seconds to wait when using -w option\n"));
|
||||
|
@ -18,7 +18,7 @@
|
|||
printf(_(" -V, --version output version information, then exit\n"));
|
||||
printf(_(" -w, --wait wait until operation completes (default)\n"));
|
||||
printf(_(" -W, --no-wait do not wait until operation completes\n"));
|
||||
@@ -2267,6 +2271,7 @@ main(int argc, char **argv)
|
||||
@@ -2261,6 +2265,7 @@ main(int argc, char **argv)
|
||||
{"options", required_argument, NULL, 'o'},
|
||||
{"silent", no_argument, NULL, 's'},
|
||||
{"timeout", required_argument, NULL, 't'},
|
||||
|
@ -26,7 +26,7 @@
|
|||
{"core-files", no_argument, NULL, 'c'},
|
||||
{"wait", no_argument, NULL, 'w'},
|
||||
{"no-wait", no_argument, NULL, 'W'},
|
||||
@@ -2307,20 +2312,6 @@ main(int argc, char **argv)
|
||||
@@ -2301,20 +2306,6 @@ main(int argc, char **argv)
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -47,7 +47,7 @@
|
|||
|
||||
env_wait = getenv("PGCTLTIMEOUT");
|
||||
if (env_wait != NULL)
|
||||
@@ -2407,11 +2398,15 @@ main(int argc, char **argv)
|
||||
@@ -2400,11 +2391,15 @@ main(int argc, char **argv)
|
||||
wait_seconds_arg = true;
|
||||
break;
|
||||
case 'U':
|
||||
|
@ -63,7 +63,7 @@
|
|||
break;
|
||||
case 'w':
|
||||
do_wait = true;
|
||||
@@ -2493,6 +2488,41 @@ main(int argc, char **argv)
|
||||
@@ -2486,6 +2481,41 @@ main(int argc, char **argv)
|
||||
exit(1);
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue