python: Replace utime with utimes

Optionally fixes compilation with uClibc-ng.

Based on the surrounding code, this looks like an oversight.

Signed-off-by: Rosen Penev <rosenp@gmail.com>

(cherry picked from 608df65a62)
Adjusted PKG_RELEASE
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
Rosen Penev 2019-07-30 23:33:40 -07:00 committed by Jeffery To
parent 1ec76dd7ca
commit 30d0c2ee0f
2 changed files with 12 additions and 1 deletions

View file

@ -12,7 +12,7 @@ include ../python-version.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)

View file

@ -0,0 +1,11 @@
--- a/Modules/posixmodule.c
+++ b/Modules/posixmodule.c
@@ -3070,7 +3070,7 @@ done:
if (arg == Py_None) {
/* optional time values not given */
Py_BEGIN_ALLOW_THREADS
- res = utime(path, NULL);
+ res = utimes(path, NULL);
Py_END_ALLOW_THREADS
}
else if (!PyTuple_Check(arg) || PyTuple_Size(arg) != 2) {